Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.28.5 (build 3282) - 23 February 2024

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

Help w/Web Page After Upgrade

Other discussion about creating web sites for Cumulus that doesn't have a specific subforum

Moderator: daj

randy52644
Posts: 51
Joined: Tue 15 Jan 2013 3:15 am
Weather Station: Vantage Pro2
Operating System: Jessie & CumulusMX
Location: Mt. Union, IA

Help w/Web Page After Upgrade

Post by randy52644 »

I've been running Cumulus MX since 2013 and it's been mostly flawless. However recently 1 or more of the 3 RPi's that I was using have become unstable. 1 running MX, another as a local server and the 3rd connected to a wall display. Now I have consolidated to a single SFF computer running Windows. 3.25.2 MX is running fine on the new installation. But publishing a html file to my local web server is the problem. It worked great previously but not with the new setup.

Back in 2014, I created a html file that displayed just the wx parameters of interest along with an embedded radar image on a wall monitor. MXdiags reports extra realtime web file not found and list the path. That path is listed in the extra web files. I have copied the web files from the previous version and dropped them into the same CumulusMX\web folder.

I was pretty familiar with MX from 2013-2014 when I set this up. But the latest version menu reorganization has me confused.
water01
Posts: 3165
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: Ecowitt HP2551
Operating System: Windows 10 64bit
Location: Burnham-on-Sea
Contact:

Re: Help w/Web Page After Upgrade

Post by water01 »

Not sure what to make of this because as far as I was aware CumulusMX was not released as a Beta until 2015, so how you were using it in 2013/14 is a mystery to me.

Are you doing a local copy of the files for your server because the way this is done was changed to an optional feature in release 3.24.0. I would suggest you read this release topic viewtopic.php?p=170328#p170328
David
Image
randy52644
Posts: 51
Joined: Tue 15 Jan 2013 3:15 am
Weather Station: Vantage Pro2
Operating System: Jessie & CumulusMX
Location: Mt. Union, IA

Re: Help w/Web Page After Upgrade

Post by randy52644 »

water01 wrote: Sat 24 Jun 2023 2:33 pm Not sure what to make of this because as far as I was aware CumulusMX was not released as a Beta until 2015, so how you were using it in 2013/14 is a mystery to me.

Are you doing a local copy of the files for your server because the way this is done was changed to an optional feature in release 3.24.0. I would suggest you read this release topic viewtopic.php?p=170328#p170328
I was running CumulusMX 3.0.0.b3036 and my first data entry was January 14,2013

In the link you posted, were you referring to the use of PHP for uploading? If so, I tried that but it specifies an upload URL and not a local file location. Sorry but you're going to have to dumb down your answers since I only periodically dabble with MX because once I get it set up, it just works.
User avatar
PaulMy
Posts: 3732
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: Help w/Web Page After Upgrade

Post by PaulMy »

Hi,
I was running CumulusMX 3.0.0.b3036 and my first data entry was January 14,2013
That might be your data that you added, but as David indicated the first release was 2015, actually CMX b3000 was Jan 2, 2015 - I remember it well... viewtopic.php?p=138841#p138841
b 3036 is dated Dec 4, 2015 viewtopic.php?p=138880#p138880
But publishing a html file to my local web server is the problem. It worked great previously but not with the new setup.

Back in 2014, I created a html file that displayed just the wx parameters of interest along with an embedded radar image on a wall monitor. MXdiags reports extra realtime web file not found and list the path. That path is listed in the extra web files. I have copied the web files from the previous version and dropped them into the same CumulusMX\web folder.
As David indicated the CMX webfiles and the data files processed by CMX, now xxx.json rather than the former xxxT.htm, is quite different but you can still make the old ones being created by adding them to the Extra web files setting. Can you provide a screen capture of what you are trying to do - Extra web file, Internet settings, Enable File Copy of standard files?

Enjoy,
Paul
Davis Vantage Pro2+
C1 www.komokaweather.com/komokaweather-ca
MX www .komokaweather.com/cumulusmxwll/index.htm
MX www.komokaweather.com/cumulusmx/index.php
MX www.komokaweather.com/cumulusmx/index.html

Image
randy52644
Posts: 51
Joined: Tue 15 Jan 2013 3:15 am
Weather Station: Vantage Pro2
Operating System: Jessie & CumulusMX
Location: Mt. Union, IA

Re: Help w/Web Page After Upgrade

Post by randy52644 »

I have attached a couple of screenshots to this reply.
You do not have the required permissions to view the files attached to this post.
SamiS
Posts: 350
Joined: Sun 27 Feb 2011 5:13 pm
Weather Station: Ecowitt HP2551 & GW1100
Operating System: Raspberry Pi OS
Location: Kangasala, Finland

Re: Help w/Web Page After Upgrade

Post by SamiS »

One possible failure cause is that windows by default prevents users and programs from writing anywhere under Program Files hierarchy. I suggest you first try to write your files somewhere that stadard user has write premission. Maybe also posting a logfile from MXDiags would give us some ideas.
randy52644
Posts: 51
Joined: Tue 15 Jan 2013 3:15 am
Weather Station: Vantage Pro2
Operating System: Jessie & CumulusMX
Location: Mt. Union, IA

Re: Help w/Web Page After Upgrade

Post by randy52644 »

Here is just a couple of minutes from MXdiags since it appears the errors just repeat.
I'm not seeing any errors due to lack of permissions to write to htdocs.

23-06-24 13:09:00.338 LocalCopy: Error copy NOAA reports - Could not find a part of the path 'apache/apache2.2/htdocs/Reports\NOAAMO0623.txt'.
2023-06-24 13:09:00.552 LocalCopy: Error copying moon image - Could not find a part of the path 'apache/apache2.2/htdocs/images\moon.png'.
2023-06-24 13:09:01.219 Realtime[180]: Extra realtime web file[1] not found - C:\CumulusMXDist3245\CumulusMX\web\realtime-xT.txt
2023-06-24 13:09:31.218 Realtime[181]: Extra realtime web file[1] not found - C:\CumulusMXDist3245\CumulusMX\web\realtime-xT.txt
2023-06-24 13:10:00.348 DoLogFile: Writing log entry for 6/24/2023 1:10:00 PM
2023-06-24 13:10:00.348 DoLogFile: log entry for 6/24/2023 1:10:00 PM written
2023-06-24 13:10:00.349 Writing today.ini, LastUpdateTime = 6/24/2023 1:10:00 PM raindaystart = 10.64 rain counter = 10.64
2023-06-24 13:10:00.381 LocalCopy: Error copy NOAA reports - Could not find a part of the path 'apache/apache2.2/htdocs/Reports\NOAAMO0623.txt'.
2023-06-24 13:10:00.594 LocalCopy: Error copying moon image - Could not find a part of the path 'apache/apache2.2/htdocs/images\moon.png'.
2023-06-24 13:10:01.235 Realtime[182]: Extra realtime web file[1] not found - C:\CumulusMXDist3245\CumulusMX\web\realtime-xT.txt
2023-06-24 13:10:27.782 SendLoopCommand: Starting - LPS 2 1
2023-06-24 13:10:27.860 SendLoopCommand: Starting - LOOP 50
2023-06-24 13:10:31.248 Realtime[183]: Extra realtime web file[1] not found - C:\CumulusMXDist3245\CumulusMX\web\realtime-xT.txt
2023-06-24 13:11:00.531 LocalCopy: Error copy NOAA reports - Could not find a part of the path 'apache/apache2.2/htdocs/Reports\NOAAMO0623.txt'.
2023-06-24 13:11:00.750 LocalCopy: Error copying moon image - Could not find a part of the path 'apache/apache2.2/htdocs/images\moon.png'.
2023-06-24 13:11:01.250 Realtime[184]: Extra realtime web file[1] not found - C:\CumulusMXDist3245\CumulusMX\web\realtime-xT.txt
freddie
Posts: 2394
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2 + Ecowitt
Operating System: GNU/Linux Ubuntu 22.04 LXC
Location: Alcaston, Shropshire, UK
Contact:

Re: Help w/Web Page After Upgrade

Post by freddie »

The spaces in the path to the Apache installation look like they're causing MX problems. Try surrounding the file path with quotation marks.
Freddie
Image
SamiS
Posts: 350
Joined: Sun 27 Feb 2011 5:13 pm
Weather Station: Ecowitt HP2551 & GW1100
Operating System: Raspberry Pi OS
Location: Kangasala, Finland

Re: Help w/Web Page After Upgrade

Post by SamiS »

If the full path for source files is valid, the errors seem to suggest that you should not use full paths to files. I have not used that feature, so I don’t have a working example, but I think that you should specify only the source filename without path, and Cumulus expects to find it from web folder. The same probably applies to destination filenames, since the folder path is specified on the local copy setting.
randy52644
Posts: 51
Joined: Tue 15 Jan 2013 3:15 am
Weather Station: Vantage Pro2
Operating System: Jessie & CumulusMX
Location: Mt. Union, IA

Re: Help w/Web Page After Upgrade

Post by randy52644 »

freddie wrote: Sat 24 Jun 2023 6:27 pm The spaces in the path to the Apache installation look like they're causing MX problems. Try surrounding the file path with quotation marks.
Quotation marks produced an illegal character error in MXDiag. But thanks for the suggestion.
randy52644
Posts: 51
Joined: Tue 15 Jan 2013 3:15 am
Weather Station: Vantage Pro2
Operating System: Jessie & CumulusMX
Location: Mt. Union, IA

Re: Help w/Web Page After Upgrade

Post by randy52644 »

SamiS wrote: Sat 24 Jun 2023 7:05 pm If the full path for source files is valid, the errors seem to suggest that you should not use full paths to files. I have not used that feature, so I don’t have a working example, but I think that you should specify only the source filename without path, and Cumulus expects to find it from web folder. The same probably applies to destination filenames, since the folder path is specified on the local copy setting.
I think my destination folder path is correct since MX is publishing the json files and realtime and realtimeguages text files to htdocs.
Sorry I should have mentioned that in my original post.
SamiS
Posts: 350
Joined: Sun 27 Feb 2011 5:13 pm
Weather Station: Ecowitt HP2551 & GW1100
Operating System: Raspberry Pi OS
Location: Kangasala, Finland

Re: Help w/Web Page After Upgrade

Post by SamiS »

randy52644 wrote: Sat 24 Jun 2023 8:09 pm I think my destination folder path is correct since MX is publishing the json files and realtime and realtimeguages text files to htdocs.
Sorry I should have mentioned that in my original post.
Ok, so the Local copy destination folder setting is good. But then you missed my original point. Since the logfile clearly shows that

”Extra realtime web file[1] not found - C:\CumulusMXDist3245\CumulusMX\web\realtime-xT.txt”

this means your ”Local filename” setting is wrong. It probably should include only the filename without path. And probably you should have only the filename without path on the ”Destination filename” field.
randy52644
Posts: 51
Joined: Tue 15 Jan 2013 3:15 am
Weather Station: Vantage Pro2
Operating System: Jessie & CumulusMX
Location: Mt. Union, IA

Re: Help w/Web Page After Upgrade

Post by randy52644 »

SamiS wrote: Sat 24 Jun 2023 9:34 pm
randy52644 wrote: Sat 24 Jun 2023 8:09 pm I think my destination folder path is correct since MX is publishing the json files and realtime and realtimeguages text files to htdocs.
Sorry I should have mentioned that in my original post.
Ok, so the Local copy destination folder setting is good. But then you missed my original point. Since the logfile clearly shows that

”Extra realtime web file[1] not found - C:\CumulusMXDist3245\CumulusMX\web\realtime-xT.txt”

this means your ”Local filename” setting is wrong. It probably should include only the filename without path. And probably you should have only the filename without path on the ”Destination filename” field.
That doesn't seem to work either.

2023-06-24 16:43:00.112 LocalCopy: Error copy NOAA reports - Could not find a part of the path 'apache/apache2.2/htdocs/Reports\NOAAMO0623.txt'.
2023-06-24 16:43:00.336 LocalCopy: Error copying moon image - Could not find a part of the path 'apache/apache2.2/htdocs/images\moon.png'.
2023-06-24 16:43:04.312 Realtime[96]: Extra realtime web file[0] not found - nowT.htm
2023-06-24 16:43:04.313 Realtime[96]: Extra realtime web file[1] not found - realtime-xT.txt
2023-06-24 16:43:34.330 Realtime[97]: Extra realtime web file[0] not found - nowT.htm
2023-06-24 16:43:34.331 Realtime[97]: Extra realtime web file[1] not found - realtime-xT.txt
water01
Posts: 3165
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: Ecowitt HP2551
Operating System: Windows 10 64bit
Location: Burnham-on-Sea
Contact:

Re: Help w/Web Page After Upgrade

Post by water01 »

I presume that that both nowT.htm and realtime-xT.txt are in the /web directory you have stated in the Extra Files path. They are non standard files so they need to be present to be processed.

The others are caused by you mixing up Linux and Windows delimiters in the path. Windows uses back slash "\" delimiters and you are using Linux forward slash "/" for the first part of the path. Will not work.
David
Image
SamiS
Posts: 350
Joined: Sun 27 Feb 2011 5:13 pm
Weather Station: Ecowitt HP2551 & GW1100
Operating System: Raspberry Pi OS
Location: Kangasala, Finland

Re: Help w/Web Page After Upgrade

Post by SamiS »

randy52644 wrote: Sat 24 Jun 2023 9:51 pm That doesn't seem to work either.

2023-06-24 16:43:00.112 LocalCopy: Error copy NOAA reports - Could not find a part of the path 'apache/apache2.2/htdocs/Reports\NOAAMO0623.txt'.
2023-06-24 16:43:00.336 LocalCopy: Error copying moon image - Could not find a part of the path 'apache/apache2.2/htdocs/images\moon.png'.
2023-06-24 16:43:04.312 Realtime[96]: Extra realtime web file[0] not found - nowT.htm
2023-06-24 16:43:04.313 Realtime[96]: Extra realtime web file[1] not found - realtime-xT.txt
2023-06-24 16:43:34.330 Realtime[97]: Extra realtime web file[0] not found - nowT.htm
2023-06-24 16:43:34.331 Realtime[97]: Extra realtime web file[1] not found - realtime-xT.txt
I checked the extra files feature documentation from the wiki. Actually if you give only a filename, Cumulus looks for it in CumulusMX folder root. You can enter also a relative path (eg. web\file.txt), but it also accepts a full path. So your initial setup was actually with correct syntax, but the files just are not there. One explanation might be if you have ”hide file extensions” enabled on Windows Explorer, you might have accidentally renamed your files to nowT.htm.htm and realtime-xT.txt.txt.

@water01 is right, that you cannot mix linux-type slashes (/) and windows-type backslashes (\) on the same path, so you have to fix the NOAA reports path and moon image path also.

Edit. NOAA Reports copy folder is setup from Settings -> NOAA Settings -> Local Copy Options and Moon image from Settings -> Internet Settings -> Moon Image
Post Reply