Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.28.5 (build 3282) - 23 February 2024

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

AWEKAS

Talk about anything that doesn't fit elsewhere - PLEASE don't put Cumulus queries in here!
Mapantz
Posts: 1772
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 11 x64
Location: Dorset - UK
Contact:

AWEKAS

Post by Mapantz »

I just had a notification to say my station is offline..

Code: Select all

2022-12-31 15:30:01.590 AWEKAS: Exception = Type definitions should start with a '{', expecting serialized type 'AwekasResponse', got string starting with: 20221231 02:25:00 20221231 04:29:07

Code: Select all

2022-12-31 15:40:00.483 AWEKAS: Exception = Object reference not set to an instance of an object.
I have no other issues with other networks. Has anyone else got this problem?
Image
freddie
Posts: 2404
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2 + Ecowitt
Operating System: GNU/Linux Ubuntu 22.04 LXC
Location: Alcaston, Shropshire, UK
Contact:

Re: AWEKAS

Post by freddie »

Yeah I've had this for a couple of days now - since Thursday evening. I think it may be a problem at their end as you can see the odd 500 response from their servers in MXdiags logs.

Unless they've changed their API and we don't know about the change?
Freddie
Image
User avatar
PaulMy
Posts: 3743
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: AWEKAS

Post by PaulMy »

I see the same error in my current MXdiags. The oldest file in my MXdiags folder is Dec 23rd and there are no such errors in it, so fairly recent issue. The AWEKAS site seems to have all the data so uploads are ok.

Enjoy,
Paul
Davis Vantage Pro2+
C1 www.komokaweather.com/komokaweather-ca
MX www .komokaweather.com/cumulusmxwll/index.htm
MX www.komokaweather.com/cumulusmx/index.php
MX www.komokaweather.com/cumulusmx/index.html

Image
Mapantz
Posts: 1772
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 11 x64
Location: Dorset - UK
Contact:

Re: AWEKAS

Post by Mapantz »

My data stopped updating on their site about 5 hours ago.
Image
Mapantz
Posts: 1772
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 11 x64
Location: Dorset - UK
Contact:

Re: AWEKAS

Post by Mapantz »

I restarted CMX, but still no data going to them. It has to be an issue their end.. oh well, no worries.
Image
User avatar
mcrossley
Posts: 12565
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Bullseye Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: AWEKAS

Post by mcrossley »

The error I am getting intermittently is...

Code: Select all

<html>
<head>
	<title>500 Internal Server Error</title>
</head>
<body>
	<h2>Request Timeout</h2>
	<p>This request takes too long to process, it is timed out by the server. If it should not be timed out, please contact administrator of this web site to increase 'Connection Timeout'.</p>
</body>
</html>
This is being returned instead of the correct JSON response. My data is generally updating though, just some missed updates.
Mapantz
Posts: 1772
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 11 x64
Location: Dorset - UK
Contact:

Re: AWEKAS

Post by Mapantz »

Since a restart, the only error I get is this:

Code: Select all

2022-12-31 20:40:00.365 AWEKAS: Exception = Object reference not set to an instance of an object.
Strange how everyone else's data is getting through though, and mine isn't
Image
User avatar
mcrossley
Posts: 12565
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Bullseye Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: AWEKAS

Post by mcrossley »

That looks like a bug in that is erroring and not recovering for some reason - I'll take a look at it next year.
Mapantz
Posts: 1772
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 11 x64
Location: Dorset - UK
Contact:

Re: AWEKAS

Post by Mapantz »

mcrossley wrote: Sat 31 Dec 2022 10:02 pm I'll take a look at it next year.
:lol:
Image
Mapantz
Posts: 1772
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 11 x64
Location: Dorset - UK
Contact:

Re: AWEKAS

Post by Mapantz »

Data has stopped again, according to them.

Code: Select all

2023-01-05 15:55:00.311 AWEKAS: Exception = Object reference not set to an instance of an object.
I sent them an email last time out, and I never got a reply back.

I'll probably stop sending data to them altogether. I don't use their site to be honest, and I have found the admin to be very rude in the past.
Image
User avatar
ConligWX
Posts: 1563
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis vPro2+ w/DFARS + AirLink
Operating System: Ubuntu 22.04 LTS
Location: Bangor, NI
Contact:

Re: AWEKAS

Post by ConligWX »

Regards Simon

https://www.conligwx.org - @conligwx
Davis Vantage Pro2 Plus with Daytime FARS • WeatherLink Live • Davis AirLink • PurpleAir •

Image
User avatar
mcrossley
Posts: 12565
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Bullseye Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: AWEKAS

Post by mcrossley »

I looked at the "Exception = Object reference not set to an instance of an object." - it's a spurious message that should not occur, the previous error should have exited the routine but didn't, hence the code trying access something that had not been initialised.
Fixed in the next release.
Mapantz
Posts: 1772
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 11 x64
Location: Dorset - UK
Contact:

Re: AWEKAS

Post by Mapantz »

Well, I finally got a reply from the email I sent 7 days ago
Hello

Your transfer string ist corrupt. The & delimeter is missing in sailtemeratures,
Image
User avatar
mcrossley
Posts: 12565
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Bullseye Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: AWEKAS

Post by mcrossley »

Ok. I'll take a look at that. Have you just started to send soil temperatures? Or is it a new problem in the latest build?

Annoying that it coincided with the awekas server problem.
freddie
Posts: 2404
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2 + Ecowitt
Operating System: GNU/Linux Ubuntu 22.04 LXC
Location: Alcaston, Shropshire, UK
Contact:

Re: AWEKAS

Post by freddie »

I've got the same problem, it started on 29th December, and they haven't received any data from me since that point. Not related to moving to the latest build. I've not changed anything at my end, apart from updating to the latest build on the 2nd. Same errors in MXdiags in both builds.
Freddie
Image
Post Reply