Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.14.0 (build 3159) - 04 December 2021

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

If you are interested in supporting Cumulus then maybe you would like to contribute to the maintenance of the Wiki? This need not take hours of your time - just a half hour here and there can make a big difference, particularly if many people are doing this. Any contributions are very welcome, whether they involve new content or editing of existing content. It will be very helpful to current and future users of Cumulus software if the Wiki is kept well-maintained and current. If you are interested then please contact forum user saratogaWX and ask for a Wiki account.

WMR200 Data retrieve fails sometimes during history download

Discussion specific to Oregon Scientific weather stations
Post Reply
docinfo57
Posts: 4
Joined: Fri 21 Aug 2020 9:02 am
Weather Station: WMR200
Operating System: Win7

WMR200 Data retrieve fails sometimes during history download

Post by docinfo57 »

Hi,
I often (once a month) notice that data fails to retrieve during history download.

My weather station information, when I ask "datalogger day rest", is according to the amount of data history in memory.

1) Sometimes CumuluxMX loops and I have to reset the weather station memory for going further, loosing my history data :bash:

2) Sometimes, looks like it's taking data, update dayfile the correct way, but not Monthly logs !

3) Sometimes, like In the join debug log, everything was OK since line 1670850, then it starts to ignored history data and finish with a Day reset required (line 1671217), clearing further data in the memory of the station without asking :groan:

I observed this behavior since january 2017, when I started to use CumuluxMX in several release versions.

Before, I used to use EasyWeather and I never notice such problems. I switch to CumulusMX for sending weather station informations on APRS.

If you could take a look at the routine wich import history data and secure it, that would be nice. I initially think this could be a timeout error, but the log doesn't show this...
And please, never clearing data in Weather station without asking !

I've noticed that retrieving several days of data (1/mn, 3600/day ) from the weather station is quite long. Perhaps due to reading/deleting for each record individualy.
During this period, which may take several minutes, new datas of the weather station are lost !

Is'nt possible to read all the history data, and at the end, asking for delete, with the possibility of checking the importation in the MonthLog, before confirmation ?
Perhaps through a beta option ?

Thanks and :clap: for you work.

Dominique
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 9240
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: WMR200 Data retrieve fails sometimes during history download

Post by mcrossley »

Let us be clear about one thing at the start, Cumulus MX does not at any point "clear" the log data from the WMR200.

You have 1 minute logging enabled.

From the log file, it starts reading the logger at 08:21:20, and the first log entry returned is for 27/08/21 22:14

Each record read takes about 0.29 seconds (the WMR200 uses a pretty inefficient transfer protocol - sending one byte per 9 byte USB message!)

MX reads 12,129 records, which takes it up to 05/09/21 11:19
The WMR can hold up to 27,000 history records I believe, which equates to just over 18 days at 1 minute logging.

The last logger record is read at 09:20:54

CMX then requests the next log record and receives a Temperature packet followed by a Status packet etc. In other words the WMR200 has switched from logger download mode to normal "live" operation.

Further calls to download log data are ignored, so I assume the WMR has no more data.

Questions:

1. You have not run Cumulus MX against your WMR200 since 27/08/21 @ 22:14?

That is an awful long time with one minute logging. I'd recommend that you restrict the CMX downtime to shorter periods.

2. No other program was reading the "live" WMR data between 05/09/21 and yesterday?

User avatar
mcrossley
Posts: 9240
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: WMR200 Data retrieve fails sometimes during history download

Post by mcrossley »

Also, please read the notes Steve made originally about the WMR200 - viewtopic.php?p=44096

* WMR200 is SLOW reading the logger
* WMR200 cannot provide "live" data, and log data at the same time
* CMX cannot process "live" data whilst it is processing historic data

Post Reply