Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.13.1 (build 3147) - 13 September 2021

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

If you are interested in supporting Cumulus then maybe you would like to contribute to the maintenance of the Wiki? This need not take hours of your time - just a half hour here and there can make a big difference, particularly if many people are doing this. Any contributions are very welcome, whether they involve new content or editing of existing content. It will be very helpful to current and future users of Cumulus software if the Wiki is kept well-maintained and current. If you are interested then please contact forum user saratogaWX and ask for a Wiki account.

WS3085 base station locking up

Discussion specific to Fine Offset and similar rebadged weather stations
Post Reply
flort
Posts: 25
Joined: Thu 17 Dec 2020 9:06 am
Weather Station: Aercus WS3085
Operating System: Raspbian GNU/Linux 10 (buster)
Location: Tin Can Bay, Queensland, Australia
Contact:

WS3085 base station locking up

Post by flort »

I recently purchased an AERCUS WS3085 to replace my aging WS2083. I'm having an issue where the base station randomly locks up. It still receives the data from the outdoor sensors but is unable to pass it onto the computer.

When this occurs the CumulusMX ServiceConsoleLog says:
- Looking for Fine Offset station
- Fine Offset station found
- Connected to station
- Error reading data from station - it may need resetting

The history on the base station no longer works and it's unable to read the station from within Easyweather either. The only way to get things working again is to do a complete reset of the station.

There is no pattern to this occurring. Sometimes it will run for days without any problems after doing a reset but it might also lock up again after just a couple of hours.

To me it seems like a problem with the base station itself and I've been in discussion with the supplier but they are reluctant to supply a new base station because they say there are many other factors which could cause the problem. I was wondering whether anyone else has experienced this problem with a WS3085 and, if so, what did you do to resolve the issue?

Thanks,
Trevor

AllyCat
Posts: 1089
Joined: Sat 26 Feb 2011 1:58 pm
Weather Station: Fine Offset 1080/1 & 3080
Operating System: Windows XP SP3
Location: SE London

Re: WS3085 base station locking up

Post by AllyCat »

Hi,

Do you have the "Synchronise Fine Offset Reads" option set? It's a well known issue (and possibly the only solution), so try looking though a forum search if you haven't already. Over 100 hits I'm afraid.

Cheers, Alan.

euphbass
Posts: 9
Joined: Tue 23 Mar 2021 10:07 pm
Weather Station: Aercus WS3085
Operating System: Mac OSX

Re: WS3085 base station locking up

Post by euphbass »

We have the same issues (since getting the station at the start of this year), and haven't found a solution yet. The only answer is to restart both Cumulus and the base station completely. It's a total pain. The historical data is often badly corrupted as well after it happens, with crazy values. Since installing Cumulus b3130 we also get no UV readings at all, and occasional memory overflow problems which cause Cumulus to shutdown completely (but it's running on a Raspberry Pi, so that may be more prone to being affected by that sort of bug). The base unit itself continues to show all readings just fine, it's a connection issue of some sort is my best guess.

flort
Posts: 25
Joined: Thu 17 Dec 2020 9:06 am
Weather Station: Aercus WS3085
Operating System: Raspbian GNU/Linux 10 (buster)
Location: Tin Can Bay, Queensland, Australia
Contact:

Re: WS3085 base station locking up

Post by flort »

Thank you for the responses. I do have "Synchronise Fine Offset Reads" option set. I've also tried adjusting the "Request/Read Delay" and also ticking "Set the Fine Offset Logger interval to match Cumulus MX interval".

I'm also running a Raspberry Pi and have tried doing regular reboots and different USB ports to see if there were any issues there. The supplier said they've only seen this issue where users are attempting to use the station as an online station, with a high update frequency. They suggested only connecting the station to upload the data but that makes it a pretty useless weather station when I want realtime data on my website. There is nothing in the documentation to indicate you can't use it as an online station with high update frequency. The silly part is my WS2083 worked seamlessly for over 4 years as an online station and the WS3085 is supposed to be a step up from that.

Regards,
Trevor

sfws
Posts: 1021
Joined: Fri 27 Jul 2012 11:29 am
Weather Station: Combination Mix of FO stations
Operating System: R Pi OS

Re: WS3085 base station locking up

Post by sfws »

Personally, I find MX is far more reliable for Fine Offset stations without synchronization selected. Try that.

Please note, I don't have experience of your model, and my advice was implemented by me at an old release.

Mark has been recently working on how MX interacts with Fine Offset stations, and he may be able to explain more.

Cumulus 1 software worked better with that option, so that is why it was recommended in an earlier post, and indeed the past posts about locking issues mostly refer to the original Cumulus.

flort
Posts: 25
Joined: Thu 17 Dec 2020 9:06 am
Weather Station: Aercus WS3085
Operating System: Raspbian GNU/Linux 10 (buster)
Location: Tin Can Bay, Queensland, Australia
Contact:

Re: WS3085 base station locking up

Post by flort »

Thanks. I did originally have it without synchronization selected as my WH2083 worked fine with that setting. I only turned it on once I started having issues but it hasn't made any difference.

flort
Posts: 25
Joined: Thu 17 Dec 2020 9:06 am
Weather Station: Aercus WS3085
Operating System: Raspbian GNU/Linux 10 (buster)
Location: Tin Can Bay, Queensland, Australia
Contact:

Re: WS3085 base station locking up

Post by flort »

Just a further update ........

The supplier has kindly offered me a full refund as the station doesn't allow me to run a live site. They have updated their website to advise the WS3085 is not recommended for 24/7 connection to a computer for live weather reading and they are continuing to investigate the cause of this.

davepaterson
Posts: 28
Joined: Tue 01 Jan 2019 8:12 pm
Weather Station: WS3085
Operating System: Windows 10
Location: Hamilton, Sth Lanarkshire UK

Re: WS3085 base station locking up

Post by davepaterson »

I have now also been given the option of a full refund, however I also have a WS3085 extra console which they advised me to sell on Ebay as Amazon? would not except it as a return. Having the spare console has allowed me to continue after a lock up or loss of data on one of the station and also went back to using Cumulus1. The solar/UV reading are well out and I have written into my own software adjustment to the reading so that they are closer to what they should be, you do not get a UV of 15 and 2638W/M2 in the central belt of Scotland. As there is very few stations now that are not wifi controlled with no data download and the work I have done to counter the lost data, lock ups and Solar problems I will be keeping the station but would advise not buying the WS3085

ptb
Posts: 7
Joined: Mon 12 Jul 2021 4:18 pm
Weather Station: FO3083
Operating System: Win XP

Re: WS3085 base station locking up

Post by ptb »

I've had the same problem with a WS3083 running on cumulus 1.
once again no pattern as to why it locks up.
Sometimes after a reset history is there sometimes not.
In the past it tended to occur once the memory on console was full and it was then being overwritten.
I now clear the memory on console using easyweather weekly and since doing that for past six months I've only had one lock up.
I run system from 7am to 10pm daily
Paul B

Post Reply