Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.28.5 (build 3282) - 23 February 2024

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

Ecowitt Advice

GW1000 WiFi gateway
Post Reply
water01
Posts: 3163
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: Ecowitt HP2551
Operating System: Windows 10 64bit
Location: Burnham-on-Sea
Contact:

Re: Ecowitt Advice

Post by water01 »

to connect to the CMX dashboard you have to set up the customised output in the weather server output, otherwise the HP2551 will not connect (as per the instructions in the HTTP (Ecowitt) Settings) and my post above.

Your MXdiags shows the HP2551 is NOT connecting and getting incorrect checksums. the website is a red herring you do not need it but you do need the customised output set up.
David
Image
davepaterson
Posts: 137
Joined: Tue 01 Jan 2019 8:12 pm
Weather Station: HP2552 , WH40/WH68+WH57/GW1100C
Operating System: Windows 11/11
Location: Hamilton, Scotland UK

Re: Ecowitt Advice

Post by davepaterson »

Thanks David, but where do I find the weather server output page?
water01
Posts: 3163
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: Ecowitt HP2551
Operating System: Windows 10 64bit
Location: Burnham-on-Sea
Contact:

Re: Ecowitt Advice

Post by water01 »

Assuming you have a HP2551/2 screen press the extreme right corner button at the bottom. this brings up the Setup screen. Then press the up arrow button until Weather Server Setup is selected (highlighted), Then press the extreme left button to select it. this in then the Weather Server setup. Then press up arrow once to highlight the Customised setup. Then press the extreme left hand button again. Then enter the data as per my post. Some are fields that are enabled and disabled using the left hand button, or select using the button. Some come up with tables i.e. IP address. Some set the values for each digit by pressing the left hand button and the left or right arrow to select the digit position, etc. etc

When it is complete back out using the extreme right hand return button.
David
Image
davepaterson
Posts: 137
Joined: Tue 01 Jan 2019 8:12 pm
Weather Station: HP2552 , WH40/WH68+WH57/GW1100C
Operating System: Windows 11/11
Location: Hamilton, Scotland UK

Re: Ecowitt Advice

Post by davepaterson »

Thanks again David. No wonder I couldn't find it in CMX :bash: will check it out
davepaterson
Posts: 137
Joined: Tue 01 Jan 2019 8:12 pm
Weather Station: HP2552 , WH40/WH68+WH57/GW1100C
Operating System: Windows 11/11
Location: Hamilton, Scotland UK

Re: Ecowitt Advice

Post by davepaterson »

Set up the Weather Server pic attached
Weather Server.jpg

and changed ' Ecowitt Local API Settings' to the HP2551,s but still failed to connect correctly. Diag attached
20230610-101144.zip
. There's somthing either missing OR I have made YET another mistake.
You do not have the required permissions to view the files attached to this post.
freddie
Posts: 2394
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2 + Ecowitt
Operating System: GNU/Linux Ubuntu 22.04 LXC
Location: Alcaston, Shropshire, UK
Contact:

Re: Ecowitt Advice

Post by freddie »

No trailing slash needed - so:

Code: Select all

/station/ecowitt
NOT

Code: Select all

/station/ecowitt/
Freddie
Image
davepaterson
Posts: 137
Joined: Tue 01 Jan 2019 8:12 pm
Weather Station: HP2552 , WH40/WH68+WH57/GW1100C
Operating System: Windows 11/11
Location: Hamilton, Scotland UK

Re: Ecowitt Advice

Post by davepaterson »

My thanks to David and Freddie :clap: Data now from HP2552
davepaterson
Posts: 137
Joined: Tue 01 Jan 2019 8:12 pm
Weather Station: HP2552 , WH40/WH68+WH57/GW1100C
Operating System: Windows 11/11
Location: Hamilton, Scotland UK

Re: Ecowitt Advice

Post by davepaterson »

ooooooooooooooopppppppppppppssssssssssss no it's not. Data must still have been coming from the GW1100 I did not restart CMX. new diag
20230610-141314.zip
You do not have the required permissions to view the files attached to this post.
User avatar
philpugh
Posts: 375
Joined: Tue 24 May 2011 8:34 am
Weather Station: See Signature
Operating System: Debian 11 (RPi4)
Location: Antrobus, Cheshire, UK
Contact:

Re: Ecowitt Advice

Post by philpugh »

Dave,

What ECOWITT station type have you got set in the Station settings in CumuluMX? (Settings/Station/General)

I think you should have (HTTP) ECOWITT set but I suspect you may have ECOWITT API set instead?

Phil
Phil Pugh
GW1000 + WH65/WH57/WH31; HP2551 + WS68/WH40A; GW2001 WittBoy
cumulusutils generating website
http://goosegate.uk/
davepaterson
Posts: 137
Joined: Tue 01 Jan 2019 8:12 pm
Weather Station: HP2552 , WH40/WH68+WH57/GW1100C
Operating System: Windows 11/11
Location: Hamilton, Scotland UK

Re: Ecowitt Advice

Post by davepaterson »

Yes was still using the API, changed to HTTP and filled in the IP data but CMX couldn't start

'connection failed because connected host has failed to respond 192.18.0.57:45000' was in the diag. and also 'Error opening TCP port:'
The grey hair still on top is getting pulled out. It's not as simple as I first thought
davepaterson
Posts: 137
Joined: Tue 01 Jan 2019 8:12 pm
Weather Station: HP2552 , WH40/WH68+WH57/GW1100C
Operating System: Windows 11/11
Location: Hamilton, Scotland UK

Re: Ecowitt Advice

Post by davepaterson »

I hate getting beaten, the grey matter got a kick and went back to the HTTP setting and ticked 'Allow Cumulus to configure your Ecowitt gateway for you' and guess what it is now working thanks to all who helped. It's simple when you know how. Hope this post will help other that want to change from the GW1100 to a console
SamiS
Posts: 349
Joined: Sun 27 Feb 2011 5:13 pm
Weather Station: Ecowitt HP2551 & GW1100
Operating System: Raspberry Pi OS
Location: Kangasala, Finland

Re: Ecowitt Advice

Post by SamiS »

davepaterson wrote: Sat 10 Jun 2023 4:28 pm I hate getting beaten, the grey matter got a kick and went back to the HTTP setting and ticked 'Allow Cumulus to configure your Ecowitt gateway for you' and guess what it is now working thanks to all who helped. It's simple when you know how. Hope this post will help other that want to change from the GW1100 to a console
Something does not add up here regarding previous steps. When you select HTTP (Ecowitt) as station type, there is no ip settings to fill, and there is no reason why CMX would not start since with http protocol it starts up and just listens forever for someone to send data. So the error ”can’t connect to…” tells that the ecowitt api protocol was still in use for some reason on that startup (maybe save settings forgotten).

Also I’m quite sure that CMX cannot autoconfigure your console to send data, because even Ecowitt’s own WS View cannot configure it remotely. If I had to guess, probably the data still comes from GW1100 if it is connected to the same network, since CMX finds it automatically when you ask to autoconfigure your gateway. Even the function name does not suggest that it would configure your console.

If my guess is correct, on GW110 settings page you probably see under Weather Services -> Customized -> enabled and ip address of your CMX. If this is the case, disabling it should trigger ”data stopped” alarm on CMX Dashboard. On the other hand, if you made the custom settings to the HP2552 correctly on the earlier try, it probably also sends data to CMX and the autoconfiguration didn’t actually do nothing. It is always a bit tricky if you are having several devices from the same manufacturer on the same network, so it is hard to give exact tips how to set things up properly.
davepaterson
Posts: 137
Joined: Tue 01 Jan 2019 8:12 pm
Weather Station: HP2552 , WH40/WH68+WH57/GW1100C
Operating System: Windows 11/11
Location: Hamilton, Scotland UK

Re: Ecowitt Advice

Post by davepaterson »

Way above my head, but the GW1100 is now disconnected and data is still being updated.
20230610-171918.zip
You do not have the required permissions to view the files attached to this post.
SamiS
Posts: 349
Joined: Sun 27 Feb 2011 5:13 pm
Weather Station: Ecowitt HP2551 & GW1100
Operating System: Raspberry Pi OS
Location: Kangasala, Finland

Re: Ecowitt Advice

Post by SamiS »

davepaterson wrote: Sat 10 Jun 2023 6:42 pm Way above my head, but the GW1100 is now disconnected and data is still being updated.
20230610-171918.zip
Interestingly the logfile indeed suggests, that the autoconfig is being used also with the console. This time I’m gladly wrong.

One thing I did however spot from your logfile. Historic data catch-up from ecowitt.net is not working properly now. It gives error about invalid mac address, so it seems that you have not given the console mac address correctly. The setting in CMX is under Station Settings -> Ecowitt Data Access API. You can check the mac from your console’s setup menu or from ecowitt.net account settings.
freddie
Posts: 2394
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2 + Ecowitt
Operating System: GNU/Linux Ubuntu 22.04 LXC
Location: Alcaston, Shropshire, UK
Contact:

Re: Ecowitt Advice

Post by freddie »

SamiS wrote: Sat 10 Jun 2023 7:14 pmOne thing I did however spot from your logfile. Historic data catch-up from ecowitt.net is not working properly now. It gives error about invalid mac address, so it seems that you have not given the console mac address correctly. The setting in CMX is under Station Settings -> Ecowitt Data Access API. You can check the mac from your console’s setup menu or from ecowitt.net account settings.
Is that not the MAC address associated with the ecowitt.net account profile?
Freddie
Image
Post Reply