Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.28.5 (build 3282) - 23 February 2024

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

Reworked default websites

Other discussion about creating web sites for Cumulus that doesn't have a specific subforum

Moderator: daj

Post Reply
User avatar
PaulMy
Posts: 3740
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: Reworked default websites

Post by PaulMy »

Hi,
The latest download on the WiKi has the 'yesterday' file so that is all good now for me, thank you :clap:

I am trying the different colour themes and think I finally got it to work but difficult to confirm as in appears to be cashed with the default blue theme.
I've tried it on 4 computers, with 3 or 4 different browsers on each and also incognito views. Only once have I seen a change in colour from the default Blue. Current view should be GreyRed http://www.komokaweather.com/cumulusmxw ... index.html Can anyone confirm they see it in the GreyRed theme?

As I understand the only thing to do is change one of the theme-colour .css file name, i.e. from GreyRed.css to colours.css to go from Blue to GreyRed so new colour.css has GreyRed theme

Code: Select all

/*	--------------------------------------------------------
 * 	Theme: Grey Red		  Base colour: #393333    Version: 3
 *  --------------------------------------------------------
 *  Designed for CumulusMX Version 3.10.1 and above.
 *  Produced using w3Schools colour generator
 *  ---------------------------------------------------------
 * 	Author: Neil Thomas		Last edit:	25th Sept 2021
 *	---------------------------------------------------------

*	Theme Colour Variable Definitions	*/


Enjoy,
Paul
Davis Vantage Pro2+
C1 www.komokaweather.com/komokaweather-ca
MX www .komokaweather.com/cumulusmxwll/index.htm
MX www.komokaweather.com/cumulusmx/index.php
MX www.komokaweather.com/cumulusmx/index.html

Image
User avatar
HansR
Posts: 5773
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: Reworked default websites

Post by HansR »

PaulMy wrote: Sun 25 Jun 2023 3:31 pm Can anyone confirm they see it in the GreyRed theme?
I don't. I just see blue.
Hans

https://meteo-wagenborgen.nl
CMX build 3278 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspberry OS 6.1.21 ● Mono 6.12.0.200
https://meteo-wagenborgen.nl/CMX4/NET8/ (beta)
CMX build 4003+ ● RPi 4B ● RPi OS 6.1.0-rpi7-rpi-v8 aarch64 ● dotnet 8.0.1
flort
Posts: 208
Joined: Thu 17 Dec 2020 9:06 am
Weather Station: Davis Vantage Vue
Operating System: Raspbian GNU/Linux 10 (buster)
Location: Tin Can Bay, Queensland, Australia
Contact:

Re: Reworked default websites

Post by flort »

How do you get to that? If I use Neil’s link

https://www.cumuluswiki.org/a/Default_W ... lt_Website
I used the same link so it must have been a caching issue. Tried this morning and everything is fine.

Regards,
Trevor
Image
flort
Posts: 208
Joined: Thu 17 Dec 2020 9:06 am
Weather Station: Davis Vantage Vue
Operating System: Raspbian GNU/Linux 10 (buster)
Location: Tin Can Bay, Queensland, Australia
Contact:

Re: Reworked default websites

Post by flort »

Hi Paul,
I am trying the different colour themes and think I finally got it to work but difficult to confirm as in appears to be cashed with the default blue theme.
I've tried it on 4 computers, with 3 or 4 different browsers on each and also incognito views. Only once have I seen a change in colour from the default Blue. Current view should be GreyRed http://www.komokaweather.com/cumulusmxw ... index.html Can anyone confirm they see it in the GreyRed theme?

As I understand the only thing to do is change one of the theme-colour .css file name, i.e. from GreyRed.css to colours.css to go from Blue to GreyRed so new colour.css has GreyRed theme
From Neil's notes the only change you need to make to change colour theme is in page-manager.js. The first line allows you to specify the colour theme. I changed mine to -

Code: Select all

let CMXConfig = { 'Theme': 'CylonYellow',
It worked straight away. Also be aware that you can only use the colour themes contained in the css folder. There are only 4 themes to choose from and each one has a dark variation. GreyRed is not one of those.

Regards,
Trevor
Image
User avatar
PaulMy
Posts: 3740
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: Reworked default websites

Post by PaulMy »

Hi flort,
I was going by the About_CMC_Themes

Code: Select all

The Default Website
===================

1.	Upload your chosen theme(s) to the css folder on your remote site.
2.	Rename the existing 'colours.css' file.  This ensures that it is available in the 
	future, should you wish to revert to it.
3.	Rename your chose CumulusMX theme to 'colours.css'. Please ensure that it is exactly 
	the same - no capitals.

You published website will now use your chosen theme stylesheet for all pages.
But that
I have done the edit you indicated in page-manager.js but that is not what I had expected http://www.komokaweather.com/cumulusmxw ... index.html

Enjoy,
Paul
Davis Vantage Pro2+
C1 www.komokaweather.com/komokaweather-ca
MX www .komokaweather.com/cumulusmxwll/index.htm
MX www.komokaweather.com/cumulusmx/index.php
MX www.komokaweather.com/cumulusmx/index.html

Image
NeilThomas
Posts: 255
Joined: Thu 11 Oct 2012 9:51 am
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 4
Location: Gloucester
Contact:

Re: Reworked default websites

Post by NeilThomas »

HansR wrote: Sun 25 Jun 2023 3:59 pm
PaulMy wrote: Sun 25 Jun 2023 3:31 pm Can anyone confirm they see it in the GreyRed theme?
I don't. I just see blue.
Hi Folks

There is NO GreyRed with the new default website. I have only converted as small number the original themes due to issues with providing light and dark variations that work.

Neil.
Neil Thomas
website: weather.oaktreewebs.co.uk | Davis Vantage Pro II | CumulusMX, Raspberry Pi 4 | MX V4 build 4010
User avatar
PaulMy
Posts: 3740
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: Reworked default websites

Post by PaulMy »

Hi,
All fine now that I also read the ReadMeDS notes :bash:
Well done Neil :clap:

Enjoy,
Paul
Davis Vantage Pro2+
C1 www.komokaweather.com/komokaweather-ca
MX www .komokaweather.com/cumulusmxwll/index.htm
MX www.komokaweather.com/cumulusmx/index.php
MX www.komokaweather.com/cumulusmx/index.html

Image
Mapantz
Posts: 1770
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 11 x64
Location: Dorset - UK
Contact:

Re: Reworked default websites

Post by Mapantz »

Hi Paul

One thing I have noticed is, when navigating to different pages, everything is blue, then flicks to the red/brown colour.
Image
NeilThomas
Posts: 255
Joined: Thu 11 Oct 2012 9:51 am
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 4
Location: Gloucester
Contact:

Re: Reworked default websites

Post by NeilThomas »

Mapantz wrote: Fri 30 Jun 2023 8:42 pm Hi Paul

One thing I have noticed is, when navigating to different pages, everything is blue, then flicks to the red/brown colour.
Hi

This is probably because the whole page loads before the colour theme is changed. I'll investigate making it happen sooner so that there is no flash of colour.

Neil
Neil Thomas
website: weather.oaktreewebs.co.uk | Davis Vantage Pro II | CumulusMX, Raspberry Pi 4 | MX V4 build 4010
LindaFNM
Posts: 149
Joined: Wed 06 Jan 2021 3:01 pm
Weather Station: Ecowitt
Operating System: Raspberry Pi

Re: Reworked default websites

Post by LindaFNM »

Thank you Neil for the website.

I have an oddity with it! For some reason my Today/Yesterday page is only showing temperature values down to Temperature Range, the rest is ‘missing’. If I refresh the page you can see the remaining values briefly before the page fully loads. This is happening on both Edge (Win11) and Safari (ipad). I’ve re-downloaded the file and think I have the latest pages - 24 June. Grateful for your advice please.

Thanks very much.
griffo42
Posts: 220
Joined: Thu 10 Dec 2015 6:41 am
Weather Station: Davis Vantage Pro2
Operating System: Win 11 Home
Location: Brisbane, Queensland, Australia
Contact:

Re: Reworked default websites

Post by griffo42 »

@LindaFNM

I had the same problem and my fix was this:

in line 117 of the distro of Today/Yesterday I added "w3-show" as per below

<div class="w3-row w3-show" data-cmx-feels>

best wishes
Keith
Davis Vantage Pro2 Model #6152AU - CumulusMX - Win11 - Saratoga/CUMX Default Scripts
https://www.kstwx.net/index.php
https://www.kstwx.net/cumx/index.html
Image
NeilThomas
Posts: 255
Joined: Thu 11 Oct 2012 9:51 am
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 4
Location: Gloucester
Contact:

Re: Reworked default websites

Post by NeilThomas »

griffo42 wrote: Sun 02 Jul 2023 1:45 am @LindaFNM

I had the same problem and my fix was this:

in line 117 of the distro of Today/Yesterday I added "w3-show" as per below

<div class="w3-row w3-show" data-cmx-feels>

best wishes
This will be a coding error on my part. I’ll investigate and upload a correction.

Neil
Neil Thomas
website: weather.oaktreewebs.co.uk | Davis Vantage Pro II | CumulusMX, Raspberry Pi 4 | MX V4 build 4010
LindaFNM
Posts: 149
Joined: Wed 06 Jan 2021 3:01 pm
Weather Station: Ecowitt
Operating System: Raspberry Pi

Re: Reworked default websites

Post by LindaFNM »

Thank you very much, worked treat :D
NeilThomas
Posts: 255
Joined: Thu 11 Oct 2012 9:51 am
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 4
Location: Gloucester
Contact:

Re: Reworked default websites

Post by NeilThomas »

NeilThomas wrote: Sun 02 Jul 2023 10:58 am
griffo42 wrote: Sun 02 Jul 2023 1:45 am @LindaFNM

I had the same problem and my fix was this:

in line 117 of the distro of Today/Yesterday I added "w3-show" as per below

<div class="w3-row w3-show" data-cmx-feels>

best wishes
This will be a coding error on my part. I’ll investigate and upload a correction.

Neil
Hi

I've had a look and this bit of code is identical to the original so no idea why it works on my system but not on others. However, if you add the class 'w3-show' as indicated, it will always show the 'feels like' data regardless of your preference settings in the AI. That's your choice.

Neil.
Neil Thomas
website: weather.oaktreewebs.co.uk | Davis Vantage Pro II | CumulusMX, Raspberry Pi 4 | MX V4 build 4010
LindaFNM
Posts: 149
Joined: Wed 06 Jan 2021 3:01 pm
Weather Station: Ecowitt
Operating System: Raspberry Pi

Re: Reworked default websites

Post by LindaFNM »

Neil,

Thanks for looking at this, it could well be my error then. I have yet to get to grips with looking at the configuration and was leaving it as is for now so if the default is not to show then that’s what caused the issue. Sorry if you’ve had to look at it for no reason, I’m afraid it’s a learn as you break it process for me.

Linda
Post Reply