Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.28.5 (build 3282) - 23 February 2024

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

Pausing data upload when sensor contact lost (Fine Offset)

General news concerning announcements of new releases, forum outages etc.
Post Reply
TedM
Posts: 2
Joined: Sun 14 Feb 2016 10:45 pm
Weather Station: WS2083
Operating System: Rasbian
Location: Bridport, Dorset

Pausing data upload when sensor contact lost (Fine Offset)

Post by TedM »

Hello,
I recently got a Fine Offset WS2083 (badged as Aercus) and set it up running Cumulus MX on a Raspberry Pi. All was well for several days, then I started getting 'Sensor contact lost' errors. I have read lots of reports in the forum from other FO owners with the same problem, so I will follow up their suggestions about transmitter/console location, batteries, shielded leads etc. In the meantime, is there a way of preventing bad data being uploaded to the MetOffice WOW website? It appears that when sensor contact is lost, Cumulus recognises this by setting a flag, but continues to upload the last valid data, even though it may be hours old. I'd prefer to have missing data rather than errors.

Ted
http://wow.metoffice.gov.uk/
Bridport north (Site ID 956156001)
User avatar
steve
Cumulus Author
Posts: 26702
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Pausing data upload when sensor contact lost (Fine Offse

Post by steve »

There's a request in the enhancement request section for Cumulus to stop uploading and logging when sensor contact is lost. I'll get around to it one day, hopefully!
Steve
TedM
Posts: 2
Joined: Sun 14 Feb 2016 10:45 pm
Weather Station: WS2083
Operating System: Rasbian
Location: Bridport, Dorset

Re: Pausing data upload when sensor contact lost (Fine Offse

Post by TedM »

Thanks Steve, it's good to know that I'm not alone with the problem, and I fully understand the constraints on your time. Although I raised it as a Fine Offset problem, there could be other instances and equipment when data that appears plausible is actually incorrect, so rather than stopping uploading and logging maybe a simpler solution would be for Cumulus to routinely output a 'valid data' flag and then leave it up to the import routine in the target system to check this. My particular interest is the MetOffice WOW site, but I don't know enough about this yet to know whether it performs any screening of input data. Just thinking aloud really...

Ted
Post Reply