Welcome to the Cumulus Support forum.

Latest Cumulus MX V4 release 4.1.1 (build 4025) - 19 June 2024

Latest Cumulus MX V3 release 3.28.6 (build 3283) - 21 March 2024

Legacy Cumulus 1 release 1.9.4 (build 1099) - 28 November 2014
(a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

HighCharts in the mobile version - problems

Other discussion about creating web sites for Cumulus that doesn't have a specific subforum

Moderator: daj

Post Reply
User avatar
Dador
Posts: 257
Joined: Thu 24 Nov 2011 2:22 pm
Weather Station: Davis VP2 Plus & Ecowitt
Operating System: Windows 10
Location: Rybnik, Poland
Contact:

HighCharts in the mobile version - problems

Post by Dador »

Hi,

Yesterday I noticed that I was having problems displaying HighCharts correctly in the mobile version. I checked it on two phones (Samsung, Xiaomi) and on two mobile browsers (Chrome, Vivaldi).

Interestingly, the charts work properly on Samsung's proprietary browser (the one that comes with the system). Is this a more general problem with the chromium engine or just mine. I'm curious if others see this problem in themselves.

Anticipating questions.
Yes, I cleared the browser cache ;) .
User avatar
mcrossley
Posts: 13024
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Bullseye Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: HighCharts in the mobile version - problems

Post by mcrossley »

I run Edge on my phone and they are working ok in that browser too.

Edit: I tried Chrome, and that is also working for me.
Mapantz
Posts: 1845
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 11 x64
Location: Dorset - UK
Contact:

Re: HighCharts in the mobile version - problems

Post by Mapantz »

Samsung uses the Chromium engine as well.
Image
User avatar
Dador
Posts: 257
Joined: Thu 24 Nov 2011 2:22 pm
Weather Station: Davis VP2 Plus & Ecowitt
Operating System: Windows 10
Location: Rybnik, Poland
Contact:

Re: HighCharts in the mobile version - problems

Post by Dador »

The charts are actually displayed, but the dynamic data presentation is stuck or almost non-functional.
Tested on WiFi and telephone network
Interesting.
User avatar
mcrossley
Posts: 13024
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Bullseye Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: HighCharts in the mobile version - problems

Post by mcrossley »

Which chart has live data? Link please
User avatar
Dador
Posts: 257
Joined: Thu 24 Nov 2011 2:22 pm
Weather Station: Davis VP2 Plus & Ecowitt
Operating System: Windows 10
Location: Rybnik, Poland
Contact:

Re: HighCharts in the mobile version - problems

Post by Dador »

What I've noticed so far:
- charts crash on all current browsers (Chrome, Vivaldi, Edge);
- on manufacturers' browsers, e.g. Samsung browser, MUI browser (xiaomi), the charts work well, but probably because they have not been updated to the latest versions yet;
- errors are in cumuluscharts and selectachars. There are no errors in historical charts.

Currently, I have it checked on 2x Samsung phones and 1x Xiaomi phone.
This only applies to the phone version. All charts draw fine on the computer.

Links:
https://pogodarybnik.pl/trends.htm
https://pogodarybnik.pl/selectachart.htm
https://pogodarybnik.pl/historic.htm

Interestingly, the charts generated by CUtils from HansR work well.
https://pogodarybnik.pl/customcharts.htm
Mapantz
Posts: 1845
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 11 x64
Location: Dorset - UK
Contact:

Re: HighCharts in the mobile version - problems

Post by Mapantz »

I've just tried your graph links using Edge on a Galaxy S23 Ultra, and they work fine.
Image
freddie
Posts: 2592
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2 + Ecowitt
Operating System: GNU/Linux Ubuntu 22.04 LXC
Location: Alcaston, Shropshire, UK
Contact:

Re: HighCharts in the mobile version - problems

Post by freddie »

They work fine in Chrome 125.0.6422.53 on a Google Pixel 7a too.
Freddie
Image
User avatar
Dador
Posts: 257
Joined: Thu 24 Nov 2011 2:22 pm
Weather Station: Davis VP2 Plus & Ecowitt
Operating System: Windows 10
Location: Rybnik, Poland
Contact:

Re: HighCharts in the mobile version - problems

Post by Dador »

I just checked on my 3rd Samsung phone. It's the same everywhere. The graphs open, but dynamic temperature data is not displayed and you cannot select from the menu (temperature, humidity, etc.).

Strange Things :)
SamiS
Posts: 436
Joined: Sun 27 Feb 2011 5:13 pm
Weather Station: Ecowitt HP2551 & GW1100
Operating System: Raspberry Pi OS
Location: Kangasala, Finland

Re: HighCharts in the mobile version - problems

Post by SamiS »

I wonder if Highcharts CDN provides different version of their code depending from which country you access them. If I remember correctly, Hans maybe forcing the highcharts version to a specific one istead of the latest available. Or it might be I’m totally wrong too.
User avatar
Dador
Posts: 257
Joined: Thu 24 Nov 2011 2:22 pm
Weather Station: Davis VP2 Plus & Ecowitt
Operating System: Windows 10
Location: Rybnik, Poland
Contact:

Re: HighCharts in the mobile version - problems

Post by Dador »

When I go to the dashboard on the local WiFi network, these charts also do not work. I'm wondering if there's something wrong with the cumuluscharts.js and selectachart.js files on my computer and server.
Hmmm...
SamiS
Posts: 436
Joined: Sun 27 Feb 2011 5:13 pm
Weather Station: Ecowitt HP2551 & GW1100
Operating System: Raspberry Pi OS
Location: Kangasala, Finland

Re: HighCharts in the mobile version - problems

Post by SamiS »

Highcharts code is always loaded from their cloud servers (or browser cache), they are not included inside Cumulus.
User avatar
Dador
Posts: 257
Joined: Thu 24 Nov 2011 2:22 pm
Weather Station: Davis VP2 Plus & Ecowitt
Operating System: Windows 10
Location: Rybnik, Poland
Contact:

Re: HighCharts in the mobile version - problems

Post by Dador »

Today I received an update to Vivaldi and possibly Chrome on my phone. The latest versions solved my chart problem. Now everything loads quickly and efficiently.

Maybe they improved optimizations for older versions of Android? I'm using version 8.0 (yes, I know, quite old), but I'm waiting to replace my phone with a new one. The current one works fine, but has little internal memory :)
Post Reply