Welcome to the Cumulus Support forum.

Latest Cumulus MX V4 release 4.1.1 (build 4025) - 19 June 2024

Latest Cumulus MX V3 release 3.28.6 (build 3283) - 21 March 2024

Legacy Cumulus 1 release 1.9.4 (build 1099) - 28 November 2014
(a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

Problem upgrading to V4

Topics concerning the Support Forum.
Post Reply
Joe Curtis
Posts: 42
Joined: Sun 07 Jun 2009 2:07 pm
Weather Station: W-8681
Operating System: RPI Bookworm MX 4023
Contact:

Problem upgrading to V4

Post by Joe Curtis »

I have followed the upgrading instructions (to the letter I think), migrated the data, but when I try to restart I get the following:

cmx@Pi3SOS:/opt/CumulusMX $ dotnet CumulusMX.dll
Cumulus MX v.4.1.0 build 4024
Working Dir: /opt/CumulusMX/

Cumulus running at: http://localhost:8998/
http://127.0.1.1:8998/
http://xxx.xxx.x.xxx:8998/

Open the admin interface by entering one of the above URLs into a web browser.

Opening station type 5 - Fine Offset
Last update: 2024-05-28T13:50:00
Looking for Fine Offset station
Fine Offset station found
Looking for Fine Offset station
Fine Offset station found

The last two lines are repeated continually

Are there any pointers to where I am going wrong? V3 was working without a problem

RaspberryPi 3B+

Joe Curtis
Joe Curtis
broadstairs
Posts: 826
Joined: Thu 14 Aug 2008 7:17 am
Weather Station: Ecowitt GW1003/GW1103/GW2000
Operating System: Linux openSUSE
Location: Broadstairs, Kent, UK
Contact:

Re: Problem upgrading to V4

Post by broadstairs »

Assuming you followed the full instructions to the letter then a copy of the latest MXDiags file from a restart which might give us a clue.

Stuart
Currently running CMX V4 4023
Joe Curtis
Posts: 42
Joined: Sun 07 Jun 2009 2:07 pm
Weather Station: W-8681
Operating System: RPI Bookworm MX 4023
Contact:

Re: Problem upgrading to V4

Post by Joe Curtis »

Thanks for the reply. As this is the first time I have used this service I was rather woolly on the procedure.
I attach the contents of the MXdiags folder. I can see errors in there but why it doesn't like the dayfile data (which I've also attached) is beyond me!
You do not have the required permissions to view the files attached to this post.
Joe Curtis
User avatar
ConligWX
Posts: 1683
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis vPro2+ w/DFARS + AirLink
Operating System: Ubuntu 24.04 LTS
Location: Bangor, NI
Contact:

Re: Problem upgrading to V4

Post by ConligWX »

your dayfile seperators between values are : (full colon) and not , (commas)

not sure why this is.

Code: Select all

01/05/24:13:90:20:06:13.2:23:47:17.0:19:58:1017.9:23:57:1019.7:21:21:0.00:00:00:17.20:14.8:19.2:9:20:14:73:20:00:84:23:47:0.000:0.0:17.0:19:58:16.9:19:49:11.5:23:56:0.00:00:00:13.2:23:47:12.4:19:49:10.4:23:49:82:0.6:0.0:0:00:00:0.0:00:00:17.0:19:49:12.3:23:56:19.4:19:58:0.0:0.00:00:00
mine shows

Code: Select all

05/06/24,24,244,11:23,7.0,05:17,14.3,17:31,1009.9,04:46,1013.6,23:48,77.4,20:08,7.0,10.2,83.4,8,13:16,60,11:21,95,22:26,3.10,10.7,14.3,17:31,13.4,17:06,4.9,05:55,4.4,20:20,6.3,06:38,10.1,13:41,4.1,04:36,262,8.2,0.0,1020,15:39,4.2,13:41,14.0,17:31,6.2,05:55,15.4,17:31,1918.7,7.0,20:20
Regards Simon

https://www.conligwx.org - @conligwx
Davis Vantage Pro2 Plus with Daytime FARS • WeatherLink Live • Davis AirLink • PurpleAir • CumulusMX 4.1.1 (build 4025)
Image
Joe Curtis
Posts: 42
Joined: Sun 07 Jun 2009 2:07 pm
Weather Station: W-8681
Operating System: RPI Bookworm MX 4023
Contact:

Re: Problem upgrading to V4

Post by Joe Curtis »

It's very curious that those semicolons are in that file and I have no idea how they got there, but going back one version, I have a file in the correct format as is the file in the datav3 folder. When I restart again, however, the result is the same although the error in the diagnostic file is different.
You do not have the required permissions to view the files attached to this post.
Joe Curtis
Joe Curtis
Posts: 42
Joined: Sun 07 Jun 2009 2:07 pm
Weather Station: W-8681
Operating System: RPI Bookworm MX 4023
Contact:

Re: Problem upgrading to V4

Post by Joe Curtis »

It would appear that the extra/wrong semicolons that occur in the dayfile.txt file are put there by the migrate program!
If I delete my current data folder, check in my datav3 folder that the dayfile.txt is in the correct format and run the migrate program

cmx@Pi3SOS:/opt/CumulusMX $ dotnet MigrateData3to4.dll
MigrateData v.1.0.1

This will convert your log files from Cumulus MX v3 to Cumulus MX v4 format
Files will be read from : /opt/CumulusMX/datav3
New files will created in: /opt/CumulusMX/data

Any existing files in the output folder will be overwritten

Press a Enter to continue, or Ctrl-C to exit

Processing started: Friday, 7 June 2024 13:08:13

Target folder 'data' does not exist, creating it...
Migrating v3 dayfile.txt to data/dayfile.txt

Migrating monthly log files
Found 1 monthly log files to process
Processing file datav3/May24log.txt... done.

Migrating Extra monthly log files
Found 0 monthly Extra log files to process

Migrating AirLink monthly log files
Found 0 monthly AirLink log files to process

Migrating Custom monthly log files

No Custom interval log files defined in Cumulus.ini

Migrating Custom daily log files

No Custom daily log files defined in Cumulus.ini

Copying 'other' files
Copying alltime.ini to destination... Copied OK
Copying month.ini to destination... Copied OK
Copying monthlyalltime.ini to destination... Copied OK
Copying today.ini to destination... Copied OK
Copying year.ini to destination... Copied OK
Copying yesterday.ini to destination... Copied OK
Copying cumulusmx.db to destination... Copied OK
Copying diary.db to destination... Copied OK

Processing completed: Friday, 7 June 2024 13:08:14

Press Enter to exit

Then the file in the data folder has the semicolon problem
You do not have the required permissions to view the files attached to this post.
Joe Curtis
SamiS
Posts: 425
Joined: Sun 27 Feb 2011 5:13 pm
Weather Station: Ecowitt HP2551 & GW1100
Operating System: Raspberry Pi OS
Location: Kangasala, Finland

Re: Problem upgrading to V4

Post by SamiS »

I think it is a bug in the migration program that does the conversion. We need to wait until Mark gets to it. One longshot is for you to try the older version of the migration tool delivered with earlier v4 builds.
User avatar
PaulMy
Posts: 3913
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2 Plus 24-Hour FARS
Operating System: Windows8 and Windows10
Location: Komoka, ON Canada
Contact:

Re: Problem upgrading to V4

Post by PaulMy »

Hi,
I am using Windows 10 so will be some differences... Looking at your Migrate txt vs mine:

Code: Select all

Joe Curtis - 
2024-06-06 19:29:34.655 MigrateData v.1.0.1
2024-06-06 19:29:34.857 Reading Cumulus.ini file
2024-06-06 19:29:49.621 Processing started
2024-06-06 19:29:49.641 Target folder 'data' does not exist, creating it...
2024-06-06 19:29:49.681 Dayfile: Found input file: datav3/dayfile.txt
2024-06-06 19:29:49.806 LogFile: File datav3/dayfile.txt is using the separator: ,
2024-06-06 19:29:49.818 LogFile: File is using the time separator: ,
2024-06-06 19:29:49.822 LogFile: File datav3/dayfile.txt is using the line ending: \n
2024-06-06 19:29:49.834 Migrating monthly log files
2024-06-06 19:29:49.856 LogFile: Found 1 monthly log files to process
2024-06-06 19:29:49.859 Processing file datav3/May24log.txt
2024-06-06 19:29:49.896 LogFile: File is using the field separator: ,
2024-06-06 19:29:49.906 LogFile: File is using the time separator: :
2024-06-06 19:29:49.908 LogFile: File datav3/May24log.txt will be written to data/202405log.txt
2024-06-06 19:29:49.909 LogFile: File datav3/May24log.txt is using the line ending: \n
2024-06-06 19:29:50.151 Finished writing to file, lines processed = 3853

KomokaWeather - Windows 10
2024-05-25 11:56:57.246 MigrateData v.1.0.0
2024-05-25 11:56:57.257 Reading Cumulus.ini file
2024-05-25 11:57:10.979 Processing started
2024-05-25 11:57:10.981 Target folder 'data' does not exist, creating it...
2024-05-25 11:57:10.985 Dayfile: Found input file: datav3\dayfile.txt
2024-05-25 11:57:11.008 LogFile: File datav3\dayfile.txt is using the separator: ,
2024-05-25 11:57:11.008 LogFile: File datav3\dayfile.txt is using the line ending: \r\n
2024-05-25 11:57:11.044 Migrating monthly log files
2024-05-25 11:57:11.048 LogFile: Found 188 monthly log files to process
2024-05-25 11:57:11.048 Processing file datav3\Apr09log.txt
2024-05-25 11:57:11.060 LogFile: File is using the separator: ,
2024-05-25 11:57:11.060 LogFile: File datav3\Apr09log.txt will be written to data\200904log.txt
2024-05-25 11:57:11.061 LogFile: File datav3\Apr09log.txt is using the line ending: \r\n
2024-05-25 11:57:11.071 Finished writing to file, lines processed = 1440
I see a difference in "field separator"

Not sure if it is due to my version 1.0.0 to your v1.0.1.

Enjoy,
Paul
VP2+
C1 www.komokaweather.com/komokaweather-ca
MX https://komokaweather.com/cumulusmx/index.htm /index.html /index.php
MX https://komokaweather.com/cumulusmxwll/index.htm /index.html /index.php
MX https:// komokaweather.com/cumulusmx4/index.htm
Image
User avatar
HansR
Posts: 6100
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bookworm
Location: Wagenborgen (NL)
Contact:

Re: Problem upgrading to V4

Post by HansR »

Migrate has been changed due to some Finnish locale issues.
It may have introduced a bug.

I think if we are no longer sure of the correct working of MigrateData3to4 it is better to withdraw CMX v4.1 as Mark will be out for quite some time. Better than knowingly have people asking for support which we can't solve.
Hans

https://meteo-wagenborgen.nl
CMX build 4023+ ● RPi 3B+ ● Raspbian Linux 6.1.21-v7+ armv7l ● dotnet 8.0.3
Joe Curtis
Posts: 42
Joined: Sun 07 Jun 2009 2:07 pm
Weather Station: W-8681
Operating System: RPI Bookworm MX 4023
Contact:

Re: Problem upgrading to V4

Post by Joe Curtis »

I'm not out of the woods yet I'm afraid. I have gone back to 4021(I was on 4023/4 before and never got to 4.1) and the semi colon problem has gone but the duplicated lines remain, which appear to be caused by Stream open failure according to the diagnostic report.

Interestingly the error message continued even after closing cumulus with Ctrl +C.

cmx@Pi3SOS:/opt/CumulusMX $ dotnet CumulusMX.dll
Cumulus MX v.4.0.0 build 4021
Working Dir: /opt/CumulusMX/

Cumulus running at: http://localhost:8998/
http://127.0.1.1:8998/
http://192.168.1.107:8998/

Open the admin interface by entering one of the above URLs into a web browser.

Opening station type 5 - Fine Offset
Last update: 2024-05-28T13:50:00
Looking for Fine Offset station
Fine Offset station found
You are not running the latest release version of Cumulus MX, build Build 4024 - Version 4.1.0 is available.
Looking for Fine Offset station
Fine Offset station found
Looking for Fine Offset station
Fine Offset station found
^CCtrl+C pressed
Looking for Fine Offset station
You do not have the required permissions to view the files attached to this post.
Joe Curtis
Joe Curtis
Posts: 42
Joined: Sun 07 Jun 2009 2:07 pm
Weather Station: W-8681
Operating System: RPI Bookworm MX 4023
Contact:

Re: Problem upgrading to V4

Post by Joe Curtis »

I still have problems since dropping back to 4023.

My normal website http://www.craythorneweather.info (fed from /webfiles directory) is not being updated
The administration interface is blank apart from the time
My secondary website http://crayc.uk (fed from /web directory and based on the Neil Thomas template) is perfectly OK.

The files in the /webfiles directory are set up as extra web files and copied from the equivalent files in the /web directory in the settings section of the administration interface. Although the copy action is present in the cumulus.ini file it would appear that this is not happening.

I assume that something I have done whilst setting up dotnet or migrating data has caused the problem and stopped the administration interface from operating.

Version 3283 was working properly till I upgraded to 4.

Any help would be gratefully appreciated
You do not have the required permissions to view the files attached to this post.
Joe Curtis
SamiS
Posts: 425
Joined: Sun 27 Feb 2011 5:13 pm
Weather Station: Ecowitt HP2551 & GW1100
Operating System: Raspberry Pi OS
Location: Kangasala, Finland

Re: Problem upgrading to V4

Post by SamiS »

Looked a the files, but I don’t see anything very obvious to explain what issues you are describing.

Something to check for though
- you have something wrong with your extra web files settings, complains about missing source json files ?
- your NOAA path is wrong, points to user homedirectory, not under /opt/CumulusMX ?

The empty dashboard might be a browser cache issue, try another browser or private browsing. If that does not help, check the contents and permissions of interface folder under CumulusMX.
User avatar
PaulMy
Posts: 3913
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2 Plus 24-Hour FARS
Operating System: Windows8 and Windows10
Location: Komoka, ON Canada
Contact:

Re: Problem upgrading to V4

Post by PaulMy »

Hi,
Both sites seem to be updating from here, the same time and temp and using v4.0.1 b4023

Enjoy,
Paul
VP2+
C1 www.komokaweather.com/komokaweather-ca
MX https://komokaweather.com/cumulusmx/index.htm /index.html /index.php
MX https://komokaweather.com/cumulusmxwll/index.htm /index.html /index.php
MX https:// komokaweather.com/cumulusmx4/index.htm
Image
Joe Curtis
Posts: 42
Joined: Sun 07 Jun 2009 2:07 pm
Weather Station: W-8681
Operating System: RPI Bookworm MX 4023
Contact:

Re: Problem upgrading to V4

Post by Joe Curtis »

Yes @Paul! It maybe that when I checked last night, changes hadn't filtered through and I was being a little premature. Both sites are now O.K. However the site administration site is still blank. I will follow up on SamiS suggestions to get to the bottom of that issue. Thanks everyone for the help.
Joe Curtis
Post Reply