Welcome to the Cumulus Support forum.

Latest Cumulus MX V4 release 4.0.1 (build 4023) - 16 May 2024

Latest Cumulus MX V3 release 3.28.6 (build 3283) - 21 March 2024

Legacy Cumulus 1 release 1.9.4 (build 1099) - 28 November 2014
(a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

CustomLogs as module

Discussion of the Cumulusutils tool and website generator.

Moderator: HansR

User avatar
HansR
Posts: 6054
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bookworm
Location: Wagenborgen (NL)
Contact:

Re: CustomLogs as module

Post by HansR »

Dador wrote: Wed 08 May 2024 8:43 am Edit:

Request to unblock webtag

<#TempAvg24Hrs>
Hi,

You should not do that in an [Edit] because that does not trigger a message and it would be a chance for me to see it.

But now I did, I will work on it and in a next release those tags will work in CustomLogs and also on CO2_pm1_24h and CO2_pm4_24h.

Before I do however, I have the following questions for anybody who has the answer:
  1. does #TempAvg24Hrs take date arguments for a specific day or is it for the current day only?
  2. I know what CO2_pm1_24his , but what is CO2_pm4_24h? I only know sensors taking pm1, pm2p5 and pm10. I never saw pm4!
Hans

https://meteo-wagenborgen.nl
CMX build 4023+ ● RPi 3B+ ● Raspbian Linux 6.1.21-v7+ armv7l ● dotnet 8.0.3
User avatar
mcrossley
Posts: 12929
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Bullseye Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: CustomLogs as module

Post by mcrossley »

HansR wrote: Fri 10 May 2024 11:42 am Before I do however, I have the following questions for anybody who has the answer:
  1. does #TempAvg24Hrs take date arguments for a specific day or is it for the current day only?
  2. I know what CO2_pm1_24his , but what is CO2_pm4_24h? I only know sensors taking pm1, pm2p5 and pm10. I never saw pm4!
1. No parameters, just last 24 hours
2. I think Ecowitt must derive the PM 4 value from 2.5 and 10?
User avatar
HansR
Posts: 6054
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bookworm
Location: Wagenborgen (NL)
Contact:

Re: CustomLogs as module

Post by HansR »

Thnx.

I will refrain from commenting on pm4 :roll:
Hans

https://meteo-wagenborgen.nl
CMX build 4023+ ● RPi 3B+ ● Raspbian Linux 6.1.21-v7+ armv7l ● dotnet 8.0.3
User avatar
Dador
Posts: 244
Joined: Thu 24 Nov 2011 2:22 pm
Weather Station: Davis VP2 Plus & Ecowitt
Operating System: Windows 10
Location: Rybnik, Poland
Contact:

Re: CustomLogs as module

Post by Dador »

The latest release 7.0.2 does not draw customlogs graphs, even without adding the new <#TempAvg24Hrs> tag.
I downgraded to 7.0.1 and the charts work.
Hmm...
User avatar
mcrossley
Posts: 12929
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Bullseye Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: CustomLogs as module

Post by mcrossley »

HansR wrote: Fri 10 May 2024 1:32 pm Thnx.

I will refrain from commenting on pm4 :roll:
There were three other average temp tags that do take parameters though...

Code: Select all

	<#ByMonthTempAvg mon=[1-12]>        Mean for requested month over the entire history. Omit the mon parameter for the current month
	<#MonthTempAvg m=[1-12] y=[YYYY]>   Mean for the requested specific month. Omit the parameters for the current month
	<#YearTempAvg y=[YYYY]>             Mean for the requested year. Omit the y parameter for the current year
User avatar
HansR
Posts: 6054
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bookworm
Location: Wagenborgen (NL)
Contact:

Re: CustomLogs as module

Post by HansR »

mcrossley wrote: Fri 10 May 2024 5:10 pm
HansR wrote: Fri 10 May 2024 1:32 pm Thnx.

I will refrain from commenting on pm4 :roll:
There were three other average temp tags that do take parameters though...

Code: Select all

	<#ByMonthTempAvg mon=[1-12]>        Mean for requested month over the entire history. Omit the mon parameter for the current month
	<#MonthTempAvg m=[1-12] y=[YYYY]>   Mean for the requested specific month. Omit the parameters for the current month
	<#YearTempAvg y=[YYYY]>             Mean for the requested year. Omit the y parameter for the current year
Thanks, I mixed tags I added to the Wiki list with the Tags I added to CUtils :?
Correction coming up
Hans

https://meteo-wagenborgen.nl
CMX build 4023+ ● RPi 3B+ ● Raspbian Linux 6.1.21-v7+ armv7l ● dotnet 8.0.3
User avatar
HansR
Posts: 6054
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bookworm
Location: Wagenborgen (NL)
Contact:

Re: CustomLogs as module

Post by HansR »

Dador wrote: Fri 10 May 2024 3:50 pm The latest release 7.0.2 does not draw customlogs graphs, even without adding the new <#TempAvg24Hrs> tag.
I downgraded to 7.0.1 and the charts work.
Hmm...
I don't know what you did but the CustomLogs may be reset, please wait two Interval cycles (and one day cycle for the day logs).

I modified the internal webtag tables and you may re-download CUtils 7002.
Hans

https://meteo-wagenborgen.nl
CMX build 4023+ ● RPi 3B+ ● Raspbian Linux 6.1.21-v7+ armv7l ● dotnet 8.0.3
User avatar
Dador
Posts: 244
Joined: Thu 24 Nov 2011 2:22 pm
Weather Station: Davis VP2 Plus & Ecowitt
Operating System: Windows 10
Location: Rybnik, Poland
Contact:

Re: CustomLogs as module

Post by Dador »

HansR wrote: Fri 10 May 2024 9:06 pm
Dador wrote: Fri 10 May 2024 3:50 pm The latest release 7.0.2 does not draw customlogs graphs, even without adding the new <#TempAvg24Hrs> tag.
I downgraded to 7.0.1 and the charts work.
Hmm...
I don't know what you did but the CustomLogs may be reset, please wait two Interval cycles (and one day cycle for the day logs).

I modified the internal webtag tables and you may re-download CUtils 7002.
The script appears to have stopped working in this release

Code: Select all

<script>const urlParams = new URLSearchParams(window.location.search);</script>
No chart or header for the home page. Interestingly, only for customlogs charts.
User avatar
HansR
Posts: 6054
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bookworm
Location: Wagenborgen (NL)
Contact:

Re: CustomLogs as module

Post by HansR »

Dador wrote: Fri 10 May 2024 9:26 pm The script appears to have stopped working in this release

Code: Select all

<script>const urlParams = new URLSearchParams(window.location.search);</script>
It works with the other menu options. Or do you have more locations where you have this script?
Since there is only one place where that urlParams is initialised there is no conclusion possible that it does not work.
Dador wrote: Fri 10 May 2024 9:26 pm No chart or header for the home page. Interestingly, only for customlogs charts.
CustomLogs do work in my environment, so I am not able to reproduce this. Beside that you have the module environment in a PHP situation. You really need to provide more info (logs, screenshot of console etc...)

So far I don't think it is the system that fails.

Please provide more info, this is not enough for me to go on.
Check the logfile, if there are indications of error, please provide.
Hans

https://meteo-wagenborgen.nl
CMX build 4023+ ● RPi 3B+ ● Raspbian Linux 6.1.21-v7+ armv7l ● dotnet 8.0.3
User avatar
Dador
Posts: 244
Joined: Thu 24 Nov 2011 2:22 pm
Weather Station: Davis VP2 Plus & Ecowitt
Operating System: Windows 10
Location: Rybnik, Poland
Contact:

Re: CustomLogs as module

Post by Dador »

I can't provide any errors because there are none in cutilslog. Everything seems to be working properly.

Currently, it's a waste of my and your energy. I will test the next releases. Maybe I'll come back to this.
User avatar
HansR
Posts: 6054
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bookworm
Location: Wagenborgen (NL)
Contact:

Re: CustomLogs as module

Post by HansR »

Ok. That seems the best atm.
Hans

https://meteo-wagenborgen.nl
CMX build 4023+ ● RPi 3B+ ● Raspbian Linux 6.1.21-v7+ armv7l ● dotnet 8.0.3
User avatar
HansR
Posts: 6054
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bookworm
Location: Wagenborgen (NL)
Contact:

Re: CustomLogs as module

Post by HansR »

Hi,

I found an issue in another module which set me on the track of an optimisation error in the compiler. Therefore I created a version without optimisation. It makes CUtils slightly larger and slower (but not as much as I had feared) and has timing data in its logfile.

Though I am not sure I actually am correct with my claim of the error being an optimisation problem, this executable solved my issue. And if it solves your issue for the CustomLogs I may have solved the problem in general (provisionally).

Please find v7003 attached.
You do not have the required permissions to view the files attached to this post.
Hans

https://meteo-wagenborgen.nl
CMX build 4023+ ● RPi 3B+ ● Raspbian Linux 6.1.21-v7+ armv7l ● dotnet 8.0.3
User avatar
Dador
Posts: 244
Joined: Thu 24 Nov 2011 2:22 pm
Weather Station: Davis VP2 Plus & Ecowitt
Operating System: Windows 10
Location: Rybnik, Poland
Contact:

Re: CustomLogs as module

Post by Dador »

In version 7.0.3, all charts appear to be working properly.
User avatar
HansR
Posts: 6054
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bookworm
Location: Wagenborgen (NL)
Contact:

Re: CustomLogs as module

Post by HansR »

OK.

That means that I have now two issues which disappear when compiling without optimisation. I will publish non-optimised from now on until I know whats going on or I am certain the problem has disappeared.
Hans

https://meteo-wagenborgen.nl
CMX build 4023+ ● RPi 3B+ ● Raspbian Linux 6.1.21-v7+ armv7l ● dotnet 8.0.3
User avatar
philpugh
Posts: 398
Joined: Tue 24 May 2011 8:34 am
Weather Station: See Signature
Operating System: Debian 12 (RPi5)
Location: Antrobus, Cheshire, UK
Contact:

Re: CustomLogs as module

Post by philpugh »

Hans;

I have a slight issue running 7003..

This is the start of the log with 7002
2024-05-20 11:45:02.119 Information According to Inifile Info => Error: True, Warning: True, Info: True, Verbose: False,
2024-05-20 11:45:02.125 CumulusUtils Initial: Shutting down the default listener
2024-05-20 11:45:02.125 Information CumulusUtils Initial: Shutting down the default listener
2024-05-20 11:45:02.140 CUstrings[xx].ini : CUstringsEN.ini looked for.
2024-05-20 11:45:02.147 CumulusUtils version: 7.0.2
2024-05-20 11:45:02.147 CuSupport constructor : Unit Wind (m/s, mph, km/h, kts): mph
2024-05-20 11:45:02.147 CuSupport constructor : Unit Pressure (mb,hPa,inHg): hPa
2024-05-20 11:45:02.147 CuSupport constructor : Unit Rain (mm,in): mm
2024-05-20 11:45:02.148 CuSupport constructor : Unit T (C,F): °C
2024-05-20 11:45:02.148 CuSupport constructor : Unit Distance (m, mi, km, kn): mi
2024-05-20 11:45:02.148 CuSupport constructor : Unit Height (m, ft): ft
2024-05-20 11:45:02.153 InetSupport: Constructor start
2024-05-20 11:45:02.173 CumulusUtils : ----------------------------
2024-05-20 11:45:02.174 CumulusUtils : Entering Main
2024-05-20 11:45:02.204 HelpTexts: start
2024-05-20 11:45:02.223 Information HelpTexts Contructor: stop
2024-05-20 11:45:02.249 CommandLineArgs : starting
2024-05-20 11:45:02.249 CommandLineArgs : handling arg: userreports
2024-05-20 11:45:02.250 CommandLineArgs : handling arg: sysinfo
2024-05-20 11:45:02.250 CommandLineArgs : handling arg: UserAskedData
2024-05-20 11:45:02.250 Dayfile: Reading the dayfile.txt...
2024-05-20 11:45:02.276 Information CumulusUtils : Read dayfile.txt succesfully - 696 records
2024-05-20 11:45:02.285 Information SystemStatus : starting
2024-05-20 11:45:02.295 Information GetUrlData Start: URL - http://localhost:9898/api/tags/process. ... nt&CPUTemp
This is the start with 7003 - it hangs at the last line as the address is not valid for my LAN!!
2024-05-20 11:54:54.873 Information According to Inifile Info => Error: True, Warning: True, Info: True, Verbose: False,
2024-05-20 11:54:54.885 CumulusUtils Initial: Shutting down the default listener
2024-05-20 11:54:54.885 Information CumulusUtils Initial: Shutting down the default listener
2024-05-20 11:54:54.902 CUstrings[xx].ini : CUstringsEN.ini looked for.
2024-05-20 11:54:54.910 CumulusUtils version: 7.0.3
2024-05-20 11:54:54.910 CuSupport constructor : Unit Wind (m/s, mph, km/h, kts): mph
2024-05-20 11:54:54.910 CuSupport constructor : Unit Pressure (mb,hPa,inHg): hPa
2024-05-20 11:54:54.910 CuSupport constructor : Unit Rain (mm,in): mm
2024-05-20 11:54:54.910 CuSupport constructor : Unit T (C,F): °C
2024-05-20 11:54:54.911 CuSupport constructor : Unit Distance (m, mi, km, kn): mi
2024-05-20 11:54:54.911 CuSupport constructor : Unit Height (m, ft): ft
2024-05-20 11:54:54.916 InetSupport: Constructor start
2024-05-20 11:54:54.933 CumulusUtils : ----------------------------
2024-05-20 11:54:54.933 CumulusUtils : Entering Main
2024-05-20 11:54:54.936 HelpTexts: starting
2024-05-20 11:54:54.947 Information HelpTexts Contructor: stop
2024-05-20 11:54:54.970 CommandLineArgs : starting
2024-05-20 11:54:54.970 CommandLineArgs : handling arg: website
2024-05-20 11:54:54.971 Dayfile: Reading the dayfile.txt...
2024-05-20 11:54:54.994 Information CumulusUtils : Read dayfile.txt succesfully - 696 records
2024-05-20 11:54:55.002 Information SystemStatus : starting
2024-05-20 11:54:55.005 Information GetUrlData Start: URL - http://192.168.178.143:9898/api/tags/pr ... nt&CPUTemp
i don't know where it's getting the 192.168.178.143 !!
Phil Pugh
GW1100 + WH65/WH57/WH31;GW1100 + WS68/WH40A (also with HP25xx console); GW2001 WittBoy
CumulusMX V4 / CUtils V7
Raspberry Pi 5 64bit
https://goosegate.uk/
Post Reply