Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.18.0 (build 3190) - 15 June 2022

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

If you are interested in supporting Cumulus then maybe you would like to contribute to the maintenance of the Wiki? This need not take hours of your time - just a half hour here and there can make a big difference, particularly if many people are doing this. Any contributions are very welcome, whether they involve new content or editing of existing content. It will be very helpful to current and future users of Cumulus software if the Wiki is kept well-maintained and current. If you are interested then please contact forum user saratogaWX and ask for a Wiki account.

Extra sensors and charts

Discussion of the Cumulusutils tool and website generator.

Moderator: HansR

Post Reply
sutne
Posts: 204
Joined: Sun 14 Oct 2012 4:23 pm
Weather Station: Ecowitt HP2553
Operating System: Raspbian Buster
Location: Rjoanddalen, Voss, Norway
Contact:

Extra sensors and charts

Post by sutne »

I have an Ecowitt station with an airquality sensor WH41 and I want to have data from it presented in CumulusUtils. CMX presents graph for it.
I have read the wiki and some other posts (even Very Basic Stuff which it not very basic).

The data from WH41 is presented, but not the graph.
In the wiki there are two sentences which I find contradicting:
The user can optionally create the charts himself by setting the parameter UserModificationExtraSensorCharts to false.
UserModificationExtraSensorCharts=false => If true the Extra Sensor charts will not be overwritten in CutilsCharts.def and give the user the possibility to create his own charts
Which is correct?
User avatar
philpugh
Posts: 278
Joined: Tue 24 May 2011 8:34 am
Weather Station: See Signature
Operating System: Debian 10 (Buster)
Location: Antrobus, Cheshire, UK
Contact:

Re: Extra sensors and charts

Post by philpugh »

I have an Ecowitt CO2/AQI sensor (WH45).

I have CumulusMX set to log the extra sensors output and in my cumulusutils.ini file I have the following
[ExtraSensors]
ExtraSensors=true
ParticipatesSensorCommunity=false
ExternalExtraSensors=
UserModificationExtraSensorCharts=false
CleanupExtraSensorslog=false
LightningSensor=true
Regenerate your CUtils website and there should be an ExraSensors TAB appear on the main page and the ExtraSensors page has the current values of the data and a chart with the past however many days you set.

Check my website (in signature below) to see the output

Cheers
Phil Pugh
GW1000 + WH65/WH57/WH31; HP2551 + WH68/WH40A; GW2001 WittBoy
cumulusutils generating website
http://goosegate.uk/
User avatar
HansR
Posts: 3434
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: Extra sensors and charts

Post by HansR »

sutne wrote: Sun 19 Jun 2022 1:40 pm In the wiki there are two sentences which I find contradicting:
The user can optionally create the charts himself by setting the parameter UserModificationExtraSensorCharts to false.
UserModificationExtraSensorCharts=false => If true the Extra Sensor charts will not be overwritten in CutilsCharts.def and give the user the possibility to create his own charts
Which is correct?
The second line is correct, the first one must be
The user can optionally create the charts himself by setting the parameter UserModificationExtraSensorCharts to true.
The idea is that it is false to start with so you generate the extra sensor charts automatically which shows you if everything is defined OK. Then you know the plot variables and you can start combining charts or create your own from scratch.

I corrected the error in the wiki.

[EDIT:] I believe you are the first with a WH41 so let's see what it does ;) No you are not of course: Paul has one in Komoka.
Hans

https://meteo-wagenborgen.nl
https://meteo-wagenborgen.nl/CMX4
CMX build 3183 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspberry OS 5.15.32 ● Mono 6.8.0.105
CMX build 40xx ● Ecowitt GW1100/WS80/WH40 ● RPi 4B ● Raspberry OS 5.15.32 ● .NET 6.0.1
User avatar
HansR
Posts: 3434
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: Extra sensors and charts

Post by HansR »

philpugh wrote: Sun 19 Jun 2022 2:54 pm I have an Ecowitt CO2/AQI sensor (WH45).

[...]
[ExtraSensors]
UserModificationExtraSensorCharts=false
[...]
Regenerate your CUtils website and there should be an ExraSensors TAB appear on the main page and the ExtraSensors page has the current values of the data and a chart with the past however many days you set.
Correct.
Here the chart is renewed every run which is the easiest way. A combination with other plotvars won't be necessary and the whole sensor is shown in one chart.

NOTE: if it would be just a change in the ExtraSensors then only

Code: Select all

utils/bin/cumulusutils.exe ExtraSensors
would be required for renewal of the ExtraSensors chart. The website command does everything.
Hans

https://meteo-wagenborgen.nl
https://meteo-wagenborgen.nl/CMX4
CMX build 3183 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspberry OS 5.15.32 ● Mono 6.8.0.105
CMX build 40xx ● Ecowitt GW1100/WS80/WH40 ● RPi 4B ● Raspberry OS 5.15.32 ● .NET 6.0.1
sutne
Posts: 204
Joined: Sun 14 Oct 2012 4:23 pm
Weather Station: Ecowitt HP2553
Operating System: Raspbian Buster
Location: Rjoanddalen, Voss, Norway
Contact:

Re: Extra sensors and charts

Post by sutne »

Had another try to generate graph for the AirQuality.
Failed because of missing meteocam? I have not enabled that.

Maybe someone can spot what I cannot see.

http://rjoandveret.no/utils/index.html
2206191802cumulusutils.log
cumulusutils.ini
You do not have the required permissions to view the files attached to this post.
User avatar
HansR
Posts: 3434
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: Extra sensors and charts

Post by HansR »

It surprises me you did not have that error before, did you empty or clean up the whole utils directory at some point?
Anyway, there seems to be an error in the logic of creating that file and not creating the menu.

The easy way out is to create an empty file meteocam.txt in the utils directory (or give it some content to be sure it will get transferred because some clients/servers don't accept empty files).

I will fix this for a next release (without hurry as the workaround is easy enough)
Hans

https://meteo-wagenborgen.nl
https://meteo-wagenborgen.nl/CMX4
CMX build 3183 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspberry OS 5.15.32 ● Mono 6.8.0.105
CMX build 40xx ● Ecowitt GW1100/WS80/WH40 ● RPi 4B ● Raspberry OS 5.15.32 ● .NET 6.0.1
sutne
Posts: 204
Joined: Sun 14 Oct 2012 4:23 pm
Weather Station: Ecowitt HP2553
Operating System: Raspbian Buster
Location: Rjoanddalen, Voss, Norway
Contact:

Re: Extra sensors and charts

Post by sutne »

Ok, creating that file got rid of the error.
I now have values and an empty chart.

Probably have to re-read the wiki.
sutne
Posts: 204
Joined: Sun 14 Oct 2012 4:23 pm
Weather Station: Ecowitt HP2553
Operating System: Raspbian Buster
Location: Rjoanddalen, Voss, Norway
Contact:

Re: Extra sensors and charts

Post by sutne »

did you empty or clean up the whole utils directory at some point?
When I install new versions I rename the old one and install the new from the zip-file.
And then I run the … website.
After that I started to look at AirQuality, and it was only then I noticed the error.

Edit: ok, the first installation of 6.9.0 failed with SFTP. Then I renamed directories and went back to 6.8.3, Had a new version and went back to 6.9.0 with an updated .exe-file.
Something could have been mixed up during this.
User avatar
HansR
Posts: 3434
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: Extra sensors and charts

Post by HansR »

sutne wrote: Sun 19 Jun 2022 8:24 pm Ok, creating that file got rid of the error.
I now have values and an empty chart.

Probably have to re-read the wiki.
I see values and the chart.
Looks good to me.
Reason it took time is because it takes the interval to create the User data file.

And maybe something got mixed up which exposed the bug.
No problem, things working. If any other questions let me know.
Hans

https://meteo-wagenborgen.nl
https://meteo-wagenborgen.nl/CMX4
CMX build 3183 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspberry OS 5.15.32 ● Mono 6.8.0.105
CMX build 40xx ● Ecowitt GW1100/WS80/WH40 ● RPi 4B ● Raspberry OS 5.15.32 ● .NET 6.0.1
sutne
Posts: 204
Joined: Sun 14 Oct 2012 4:23 pm
Weather Station: Ecowitt HP2553
Operating System: Raspbian Buster
Location: Rjoanddalen, Voss, Norway
Contact:

Re: Extra sensors and charts

Post by sutne »

:clap: :clap: :clap:
Post Reply