Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.14.2 (build 3162) - 21 January 2022

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

If you are interested in supporting Cumulus then maybe you would like to contribute to the maintenance of the Wiki? This need not take hours of your time - just a half hour here and there can make a big difference, particularly if many people are doing this. Any contributions are very welcome, whether they involve new content or editing of existing content. It will be very helpful to current and future users of Cumulus software if the Wiki is kept well-maintained and current. If you are interested then please contact forum user saratogaWX and ask for a Wiki account.

3rd party http not working - CMX release 3.14.0 build 3159 - Win7 [solved]

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

User avatar
Gyvate
Posts: 115
Joined: Wed 16 Dec 2020 2:14 pm
Weather Station: Ecowitt GW1x00/WH2650WiFi/HP2553
Operating System: Win 11 (PC/RPi), Raspbian 11,WSL
Location: Saarbrücken, Germany
Contact:

Re: 3rd party http not working - CMX release 3.14.0 build 3159

Post by Gyvate »

That registry hack did the job.

Now it still shows the entry
"Response status code does not indicate success: 400 (Bad Request)"
but the call goes through and the data is transferred (and displayed on the wetherwizz console screen).

it later on changed into
2021-12-05 18:34:06.649 CustomHttpSeconds: Querying - https://api.weatherwizz.com/api/update?stationid=....
2021-12-05 18:34:06.949 CustomHttpSeconds: Response - OK
2021-12-05 18:34:06.949 CustomHttpSeconds: Response Text - Success

I have attached the .reg file as a .zip file
content:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client]
"DisabledByDefault"=dword:00000000
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 9533
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: 3rd party http not working - CMX release 3.14.0 build 3159

Post by mcrossley »

Great, thanks for the confirmation, I thought that would work.

Weatherwizz does seem to be having some issues, but if it works even when it reports an error, hey!

User avatar
HansR
Posts: 2859
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: 3rd party http not working - CMX release 3.14.0 build 3159 - Win7 [solved]

Post by HansR »

@meteo19: you could try that registry hack as well and see how it goes?
Hans

https://meteo-wagenborgen.nl
https://meteo-wagenborgen.nl/CMX4/index.html
Cumulus build 3160 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspberry OS 5.10.63-v7+ ● Mono 6.12.0.122

User avatar
meteo19
Posts: 60
Joined: Tue 03 May 2016 8:13 pm
Weather Station: Davis VP2+/DP1500 SmartHub
Operating System: Microsoft Windows 7 Pro
Location: Ségur-Le-Château, France
Contact:

Re: 3rd party http not working - CMX release 3.14.0 build 3159 - Win7 [solved]

Post by meteo19 »

HansR wrote:
Sun 05 Dec 2021 5:59 pm
@meteo19: you could try that registry hack as well and see how it goes?
Already done since 5pm works normally but still no CUtils map.

Patrick

User avatar
HansR
Posts: 2859
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: 3rd party http not working - CMX release 3.14.0 build 3159 - Win7 [solved]

Post by HansR »

Mmm... I'll modify the logging around those calls to get more info and see if that helps.
I'll send you something tomorrow.
Hans

https://meteo-wagenborgen.nl
https://meteo-wagenborgen.nl/CMX4/index.html
Cumulus build 3160 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspberry OS 5.10.63-v7+ ● Mono 6.12.0.122

User avatar
HansR
Posts: 2859
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: 3rd party http not working - CMX release 3.14.0 build 3159 - Win7 [solved]

Post by HansR »

Good morning Patrick,

I don't know if you changed something else in addition but this morning I notice you are back on the map.
This means that the HTTPclient calls do work now so I regard this as problem solved: apparently the registry hack does work for you as well.
Win7 has an extension of its life ;)
I doubt though it will survive future .NET upgrades.

Regards,
Hans

https://meteo-wagenborgen.nl
https://meteo-wagenborgen.nl/CMX4/index.html
Cumulus build 3160 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspberry OS 5.10.63-v7+ ● Mono 6.12.0.122

User avatar
meteo19
Posts: 60
Joined: Tue 03 May 2016 8:13 pm
Weather Station: Davis VP2+/DP1500 SmartHub
Operating System: Microsoft Windows 7 Pro
Location: Ségur-Le-Château, France
Contact:

Re: 3rd party http not working - CMX release 3.14.0 build 3159 - Win7 [solved]

Post by meteo19 »

HansR wrote:
Mon 06 Dec 2021 5:31 am
Good morning Patrick,

I don't know if you changed something else in addition but this morning I notice you are back on the map.
This means that the HTTPclient calls do work now so I regard this as problem solved: apparently the registry hack does work for you as well.
Win7 has an extension of its life ;)
I doubt though it will survive future .NET upgrades.

Regards,
Good morning Hans,

Yes I am nothing to change since yesterday and everything works. Long live Windows 7 for my weather program.
:clap: To all Thank you very much.
Regards,
Patrick

User avatar
HansR
Posts: 2859
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: 3rd party http not working - CMX release 3.14.0 build 3159 - Win7 [solved]

Post by HansR »

meteo19 wrote:
Mon 06 Dec 2021 7:15 am
Long live Windows 7 for my weather program.
:D
Hans

https://meteo-wagenborgen.nl
https://meteo-wagenborgen.nl/CMX4/index.html
Cumulus build 3160 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspberry OS 5.10.63-v7+ ● Mono 6.12.0.122

Post Reply