Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.10.5 (build 3122) - 06 April 2021 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

THW index always reads 0.0 on default site

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

freddie
Posts: 1233
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2
Operating System: GNU/Linux Ubuntu 20.04 LXC
Location: Alcaston, Shropshire, UK
Contact:

Re: THW index always reads 0.0 on default site

Post by freddie »

ConligWX wrote:
Tue 06 Apr 2021 7:13 pm
look at the CumulsuMX Webtags, which I generate from CumulusMX each time I start the program shows

Code: Select all

THWindex
so changing to THWIndex will make the tag null and void. Unless Mark can tell me otherwise. the attached file was created today with 3.10.5 build 3122
That's what I had it set to previously and it always gave a value of 0.0. I will take a look tomorrow.
Freddie
Image

Mapantz
Posts: 932
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 10 x64
Location: Dorset - UK
Contact:

Re: THW index always reads 0.0 on default site

Post by Mapantz »

Until I saw it on Weatherlink Live, I never knew there was a THW Index. I guess it's for those who don't own a Solar Radiation sensor? As THSW Index works just fine.
Image

freddie
Posts: 1233
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2
Operating System: GNU/Linux Ubuntu 20.04 LXC
Location: Alcaston, Shropshire, UK
Contact:

Re: THW index always reads 0.0 on default site

Post by freddie »

mcrossley wrote:
Tue 06 Apr 2021 7:30 pm
Hmm, I must have misread the src code, could have sworn it was a capital I, but no it looks like it was correct with a lower case. :bash:

I'll have a look later and see if I can see anything causing it to be zero. Any idea how long it c has been reporting zero? I don't recall the VP2 code changing in some time.
I don't know, sorry. It's not something I really look at - Michael pointed out to me, otherwise I would never have noticed :)
Freddie
Image

User avatar
The Dalek Hunter
Posts: 64
Joined: Wed 05 Aug 2020 11:51 am
Weather Station: Vantage Pro 2 & WeatherLink Live
Operating System: Windows 10 running on a Micro PC
Contact:

Re: THW index always reads 0.0 on default site

Post by The Dalek Hunter »

I can confirm this - in the default website the THW Index is zero whereas WeatherLink is showing 1
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 8210
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: THW index always reads 0.0 on default site

Post by mcrossley »

OK, a mini mystery. The value for THW is not set anywhere in the Cumulus MX code!
Nor is it defined in the Davis serial protocol as being a value that can be downloaded.

I have no idea why it is there, nor why it found its way on to the default web site. :?

THSW is defined and is set by Cumulus if you have a solar sensor - though it is not recorded in the logger, so it not available during catch-up.

freddie
Posts: 1233
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2
Operating System: GNU/Linux Ubuntu 20.04 LXC
Location: Alcaston, Shropshire, UK
Contact:

Re: THW index always reads 0.0 on default site

Post by freddie »

mcrossley wrote:
Wed 07 Apr 2021 10:58 am
OK, a mini mystery. The value for THW is not set anywhere in the Cumulus MX code!
Nor is it defined in the Davis serial protocol as being a value that can be downloaded.

I have no idea why it is there, nor why it found its way on to the default web site. :?

THSW is defined and is set by Cumulus if you have a solar sensor - though it is not recorded in the logger, so it not available during catch-up.
Easy solution then - rip out THW :D
Freddie
Image

User avatar
ConligWX
Posts: 1225
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis vPro2 Plus w/DFARS
Operating System: Ubuntu 20.04.2 LTS - NUC
Location: Bangor, NI
Contact:

Re: THW index always reads 0.0 on default site

Post by ConligWX »

mcrossley wrote:
Wed 07 Apr 2021 10:58 am
OK, a mini mystery. The value for THW is not set anywhere in the Cumulus MX code!
Nor is it defined in the Davis serial protocol as being a value that can be downloaded.

I have no idea why it is there, nor why it found its way on to the default web site. :?

THSW is defined and is set by Cumulus if you have a solar sensor - though it is not recorded in the logger, so it not available during catch-up.
Interesting that no one has noticed this anomaly as yet. Guessing this was added only to the new Website Template? fact a Webtag is available makes me think its been there for sometime.
Regards Simon

https://www.conligwx.org - @conligwx
Davis Vantage Pro2 Plus with Daytime FARS • WeatherLink Live • Davis AirLink • PurpleAir PA-II-SD • CumulusMX •

sfws
Posts: 979
Joined: Fri 27 Jul 2012 11:29 am
Weather Station: Combination Mix of FO stations
Operating System: R Pi OS

Re: THW index always reads 0.0 on default site

Post by sfws »

mcrossley wrote:
Wed 07 Apr 2021 10:58 am
I have no idea why it is there, nor why it found its way on to the default web site
ConligWX wrote:
Wed 07 Apr 2021 11:47 am
Guessing this was added only to the new Website Template? fact a Webtag is available makes me think its been there for sometime.
It would be a good idea if people were to read the documentation, before designing new web pages for MX.

Davis web tags are explained at https://cumuluswiki.org/a/Webtags#Davis.

If you look at the page history, it was on 5 October 2011, that "mcrossley" added that "Davis" section into the webtags page of the Wiki. I guess his text came from the "webtags beta" page, and I imagine that beta page had used text from a build announcement by Steve Loft.

I amended it on 13 April 2015 to record at which version Steve Loft added the tags (I have tried hard to make the Wiki useful for people who have not upgraded as well as those using latest release). The terminology explanation I added to the documentation (taken directly from explanatory text written by Steve Loft in the support forum) clearly stated that THW is read from the Davis DLL. The Davis DLL is used only for the legacy Cumulus 1.9.4. If you look at the table at https://cumuluswiki.org/a/Webtags#Davis, you will see I actually added a column headed "Applicability", it clearly shows that THW index is not applicable to MX.

I did make further changes to this wiki page on 12 July 2020, adding what Mark had said in his release announcements about new web tags for Davis and Davis WLL, but I know these were later "fixed" by Mark, and now I avoid Wiki updates re functionality that I do not use.

Perhaps somebody who uses a Davis can spend some time creating/amending other pages in the Wiki, because I am sure there is a lot to document/update.

User avatar
ConligWX
Posts: 1225
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis vPro2 Plus w/DFARS
Operating System: Ubuntu 20.04.2 LTS - NUC
Location: Bangor, NI
Contact:

Re: THW index always reads 0.0 on default site

Post by ConligWX »

What, read documentation, what a sacrilege! :lol: :lol:

I do have a Davis Vantage Pro2 using WLL, however the WebTag creation via "ListWebTags=1" creates a tag called THWindex so it is hard coded into CumulusMX v3.1x. there maybe some work around for this to either be removed or adjust who sees this tag value at all.
Regards Simon

https://www.conligwx.org - @conligwx
Davis Vantage Pro2 Plus with Daytime FARS • WeatherLink Live • Davis AirLink • PurpleAir PA-II-SD • CumulusMX •

User avatar
mcrossley
Posts: 8210
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: THW index always reads 0.0 on default site

Post by mcrossley »

I will remove all trace of THW Index from the next release - the simplest option!

freddie
Posts: 1233
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2
Operating System: GNU/Linux Ubuntu 20.04 LXC
Location: Alcaston, Shropshire, UK
Contact:

Re: THW index always reads 0.0 on default site

Post by freddie »

mcrossley wrote:
Thu 08 Apr 2021 3:54 pm
I will remove all trace of THW Index from the next release - the simplest option!
:D
Freddie
Image

User avatar
ConligWX
Posts: 1225
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis vPro2 Plus w/DFARS
Operating System: Ubuntu 20.04.2 LTS - NUC
Location: Bangor, NI
Contact:

Re: THW index always reads 0.0 on default site

Post by ConligWX »

:clap:
Regards Simon

https://www.conligwx.org - @conligwx
Davis Vantage Pro2 Plus with Daytime FARS • WeatherLink Live • Davis AirLink • PurpleAir PA-II-SD • CumulusMX •

Post Reply