Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.9.0 (build 3095) - 09 October 2020 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this Wiki link to Download the Software (Cumulus MX / Cumulus 1 and other related items).

MQTT issue

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

Post Reply
picca
Posts: 5
Joined: Mon 02 Jan 2012 4:35 pm
Weather Station: WMR 180 | Oregon
Operating System: Windows 7
Location: Valdisotto

MQTT issue

Post by picca »

Hi,

I've successfully configured MQTT in Cumlulus (v. 3.8.3) but it only worked for a few hours. Now, no more communications between Cumulus and the MQTT broker/server (installed on the same machine) and no errors displayed in MXdiags log (no errors in MQTT broker log). The MQTT broker still works fine with other services. Also tryed with another MQTT on different machine with no success.

Any suggestions?


Have a good one,
Davide

picca
Posts: 5
Joined: Mon 02 Jan 2012 4:35 pm
Weather Station: WMR 180 | Oregon
Operating System: Windows 7
Location: Valdisotto

Re: MQTT issue

Post by picca »

The problem was caused by the fact that I'd changed the address of the MQTT server using the IP instead of the hostname. Going back in the changes (after a Cumulus reboot) everything's back to normal.


Edit - of tipic:
I made a suggestion for "retained message" here:
viewtopic.php?f=36&p=146460#p146460

Post Reply