Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.2.3 build 3059 - 04 December 2019.
    Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

    See the Wiki for downloading either version.

    steelseries not working

    Discussion of Mark Crossley's HTML5/Javascript gauges

    Moderator: mcrossley

    Thunderstorm
    Posts: 29
    Joined: Tue 26 Mar 2019 8:49 am
    Weather Station: Davis Vantage Pro
    Operating System: Win10

    Re: steelseries not working

    Post by Thunderstorm » Fri 29 Mar 2019 5:30 pm

    Hi,
    I have copied all web folders from template 2.7.3. I can`t believe it, the gauges are working. :D

    http://stuermers-marktplatz.de/cumulus/ ... -basic.htm

    Sadly the background image is not showing. And it is not possible to get the gauges by the console. But this are bagatelles.

    Thunderstorm

    Thunderstorm
    Posts: 29
    Joined: Tue 26 Mar 2019 8:49 am
    Weather Station: Davis Vantage Pro
    Operating System: Win10

    Re: steelseries not working

    Post by Thunderstorm » Wed 16 Oct 2019 8:17 am

    Hi,
    I have created a new homepage and now the representation of the instruments does not work, if I want to embed them on my page via iframe. Only a few parts of the text are reproduced.https://odenwald-wetter.de/instrumente/
    The presentation on the Internet is correct, see http://odenwald-wetter.de/cumulus/gauges-ss-basic.htm. The console can be perfectly displayed with iframe. My new page is accessible at https: //, the old page was just http: //. What could it be? Can you please help me again ?

    Best regards
    thunderstorm

    Thunderstorm
    Posts: 29
    Joined: Tue 26 Mar 2019 8:49 am
    Weather Station: Davis Vantage Pro
    Operating System: Win10

    Re: steelseries not working

    Post by Thunderstorm » Wed 23 Oct 2019 9:31 am

    Hi,
    Can nobody really help me? :( :?

    Best wishes
    thunderstorm

    water01
    Posts: 1558
    Joined: Sat 13 Aug 2011 9:33 am
    Weather Station: WH1081
    Operating System: Windows 7 64bit HP SP1
    Location: Somewhere in the USA
    Contact:

    Re: steelseries not working

    Post by water01 » Wed 23 Oct 2019 1:14 pm

    Looking at the two pages realtimegauges.txt is being uploaded to

    http://odenwald-wetter.de/cumulus/

    But not to

    https://odenwald-wetter.de/instrumente/

    You either have to change gauges.js to reflect that realtimegauges.txt is in http://odenwald-wetter.de/cumulus/ or upload it twice to both positions.

    User avatar
    Frank G
    Posts: 28
    Joined: Wed 25 Sep 2013 5:03 pm
    Weather Station: WH1080 SE
    Operating System: Linux raspberrypi (4.9.59-v7+)
    Location: Germany

    Re: steelseries not working

    Post by Frank G » Thu 24 Oct 2019 8:23 am

    It could be a "https"-problem. Please doublcheck the php-sourcepage that links to needed sources are not refer to a "http"-site.

    Frank
    Image
    Weather at Buchenau/Germany: http://wetter.buchenau-net.de

    Thunderstorm
    Posts: 29
    Joined: Tue 26 Mar 2019 8:49 am
    Weather Station: Davis Vantage Pro
    Operating System: Win10

    Re: steelseries not working

    Post by Thunderstorm » Fri 25 Oct 2019 3:57 pm

    Hi,
    many thanks for the answer. I have tried a few variants, with the result that now the instruments are no longer displayed. The web folder lib / steelseries / script contains the file gauges.js. What settings do I have to make here, that steelseeries works again?
    Best regards
    thunderstorm

    water01
    Posts: 1558
    Joined: Sat 13 Aug 2011 9:33 am
    Weather Station: WH1081
    Operating System: Windows 7 64bit HP SP1
    Location: Somewhere in the USA
    Contact:

    Re: steelseries not working

    Post by water01 » Fri 25 Oct 2019 8:51 pm

    As per the installation instructions https://cumuluswiki.wxforum.net/a/SteelSeries_Gauges you need to alter gauges.js to point to where you uploading realtimegauges.txt on your website.
    As I pointed out to you in my previous post realtimegauges.txt is being uploaded to

    http://odenwald-wetter.de/cumulus/

    But not to

    https://odenwald-wetter.de/instrumente/

    hence why it is working in one page and not the other.

    Thunderstorm
    Posts: 29
    Joined: Tue 26 Mar 2019 8:49 am
    Weather Station: Davis Vantage Pro
    Operating System: Win10

    Re: steelseries not working

    Post by Thunderstorm » Sat 26 Oct 2019 6:24 pm

    Hi, :)
    finally it worked, because all instruments are running on my webseite. I am happy! Yes, it was an https-issue with an old gauges.js version. Thank you David and Frank for your help and special greetings to the neighboring weather station on the Lahn. But now I want to improve two things:
    1. I would like to customize the background image and
    2. change the text in the title
    In which file do I have to make the changes? I have all the files through and I'm afraid that I'll break everything again.
    Best regards and a nice weekend from
    Thunderstorm

    User avatar
    Frank G
    Posts: 28
    Joined: Wed 25 Sep 2013 5:03 pm
    Weather Station: WH1080 SE
    Operating System: Linux raspberrypi (4.9.59-v7+)
    Location: Germany

    Re: steelseries not working

    Post by Frank G » Sun 27 Oct 2019 1:03 pm

    special greetings to the neighboring weather station on the Lahn
    Grüße zurück aus dem schönen Hinterland/Hessen :)
    To your questions:
    1. I would like to customize the background image
    On your web server go to Cumulus root-folder/images and exchange the file "picture.jpg" against your picture. Leave the filename like it is and you have to change nothing in your web files (so far).
    2. change the text in the title
    Open your Dashboard (CMx 3.x) or open the Cumulus software (CM 1.9x), open Settings (or Configuration)/Stations Settings, go to "Location" and change or insert the value for "Name" and "Description" (see picture for CMx 3.x).

    Frank
    You do not have the required permissions to view the files attached to this post.
    Image
    Weather at Buchenau/Germany: http://wetter.buchenau-net.de

    Thunderstorm
    Posts: 29
    Joined: Tue 26 Mar 2019 8:49 am
    Weather Station: Davis Vantage Pro
    Operating System: Win10

    Re: steelseries not working

    Post by Thunderstorm » Mon 28 Oct 2019 5:10 pm

    Hi Frank,
    thank you for the great tips. Now a little fine tuning, then it should fit. Unfortunately I noticed too late, that the version Cumulus 1.94 from 2020 will not be released anymore. Let's see when I upgrade to CMX3.xx.

    tunderstorm

    User avatar
    mcrossley
    Posts: 5798
    Joined: Thu 07 Jan 2010 9:44 pm
    Weather Station: Davis VP2
    Operating System: Stretch Lite rPi
    Location: Wilmslow, Cheshire, UK
    Contact:

    Re: steelseries not working

    Post by mcrossley » Wed 30 Oct 2019 12:05 pm

    There is a patched version of Cumulus 1 that now supports dates beyond 2020 - see the downloads page.

    Post Reply