Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.0 build 3050 - 1 May 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

1.9.4 to 3.0.0 Migration

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

Moderator: mcrossley

Post Reply
noravalley
Posts: 14
Joined: Mon 09 Jul 2018 10:48 pm
Weather Station: VP2 pro
Operating System: Win 7

1.9.4 to 3.0.0 Migration

Post by noravalley » Tue 29 Jan 2019 8:57 pm

Hi All,

I recently did the move from 1.9.4 to MX 3.0.0, only reason for the move was the after year 2020 issue with 1.9.4.
I have been using it for a few days now and it works fine most of the time but for some reason it just stops sending data to my upload sites (WU, WC etc..) Cumulus is receiving the data from my weather station. (MX interface shows the data there)

When I checked the MXdiags it appears this last "crash" happened after the hour changed to 4? Coincidence perhaps?
Previously is has been at random times.

2019-01-30 03:59:00.625 Writing today.ini, LastUpdateTime = 30/01/2019 03:59:00 raindaystart = 13.8 rain counter = 13.8
2019-01-30 04:00:00.451 Hour changed:4
2019-01-30 04:00:00.451 Calculating sunrise and sunset times
2019-01-30 04:00:00.451 Sunrise: 05:20:31
2019-01-30 04:00:00.451 Sunset : 18:41:57
2019-01-30 04:00:00.451 Tomorrow sunrise: 05:21:18
2019-01-30 04:00:00.451 Tomorrow sunset : 18:41:29
2019-01-30 04:00:00.453 *** Data input appears to have stopped
2019-01-30 04:01:00.278 *** Data input appears to have stopped


Am I missing something or done something wrong? If i can't resolve this I will have to roll back to 1.9.4
Any help would be much appreciated!

User avatar
mcrossley
Posts: 5595
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: 1.9.4 to 3.0.0 Migration

Post by mcrossley » Tue 29 Jan 2019 10:18 pm

Please switch on "Debug logging" and "Data logging" under Station settings | Options.

If it happens again zip up your MXdiags folder and post it.

noravalley
Posts: 14
Joined: Mon 09 Jul 2018 10:48 pm
Weather Station: VP2 pro
Operating System: Win 7

Re: 1.9.4 to 3.0.0 Migration

Post by noravalley » Tue 29 Jan 2019 10:33 pm

mcrossley wrote:
Tue 29 Jan 2019 10:18 pm
Please switch on "Debug logging" and "Data logging" under Station settings | Options.

If it happens again zip up your MXdiags folder and post it.
Thanks Mark, I have turned them on.
Since the change over on the 25th it has dropped out twice, on the 27th and 30th. If it follows that trend I should be able to post in the next few days.
Thanks for the quick response, much appreciated!

noravalley
Posts: 14
Joined: Mon 09 Jul 2018 10:48 pm
Weather Station: VP2 pro
Operating System: Win 7

Re: 1.9.4 to 3.0.0 Migration

Post by noravalley » Sun 10 Feb 2019 11:30 pm

Hi Mark,

I have had the issue again unfortunately.
I had it logging for over 10 days which has resulted in a 152mb file so I have copied part of the log where I believe it started to have errors.
I have also attached screenshots of WU graphs and Cumulus graphs, it appears Cumulus is still receiving the data from the weather station during this time but for some reason is not sending that same data? Any idea what is causing this?
Would really like to stay with MX but if I keep having issues I will have to roll back, is the year 2020 issue the only thing that wont work on 1.9.4 in the future? Many thanks in advance.
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 5595
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: 1.9.4 to 3.0.0 Migration

Post by mcrossley » Mon 11 Feb 2019 6:38 pm

Is this a Davis IP logger or something else? I can't see that Cumulus is uploading to WU at all.

noravalley
Posts: 14
Joined: Mon 09 Jul 2018 10:48 pm
Weather Station: VP2 pro
Operating System: Win 7

Re: 1.9.4 to 3.0.0 Migration

Post by noravalley » Mon 11 Feb 2019 8:20 pm

mcrossley wrote:
Mon 11 Feb 2019 6:38 pm
Is this a Davis IP logger or something else? I can't see that Cumulus is uploading to WU at all.
Davis IP logger, could that be the issue?
I've attached more logs, it happened again yesterday afternoon.
You do not have the required permissions to view the files attached to this post.

User avatar
PaulMy
Posts: 1920
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: 1.9.4 to 3.0.0 Migration

Post by PaulMy » Mon 11 Feb 2019 9:06 pm

Davis IP logger, could that be the issue?
What is the disconnect period in your settings?

Paul

User avatar
mcrossley
Posts: 5595
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: 1.9.4 to 3.0.0 Migration

Post by mcrossley » Mon 11 Feb 2019 9:07 pm

OK, two of the logs show MX still doing catch up when it was stopped. The third does show a "data appears to have stopped" error, but there is no debug logging on :(

noravalley
Posts: 14
Joined: Mon 09 Jul 2018 10:48 pm
Weather Station: VP2 pro
Operating System: Win 7

Re: 1.9.4 to 3.0.0 Migration

Post by noravalley » Tue 12 Feb 2019 12:48 am

I have decided to roll back to 1.9.4 for now.
I never had one issue using 1.9.4, it was extremely stable.
Only reason for the change was the menu not displaying years beyond 2020.
PaulMy wrote:
Mon 11 Feb 2019 9:06 pm
Davis IP logger, could that be the issue?
What is the disconnect period in your settings?

Paul
I had been playing with this as data was missing at WL, between 10-15s
mcrossley wrote:
Mon 11 Feb 2019 9:07 pm
OK, two of the logs show MX still doing catch up when it was stopped. The third does show a "data appears to have stopped" error, but there is no debug logging on :(
Okay, in layman terms what does that mean?

User avatar
mcrossley
Posts: 5595
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: 1.9.4 to 3.0.0 Migration

Post by mcrossley » Tue 12 Feb 2019 10:48 pm

The logs don't really show me anything useful, you need to turn on the debug logging option to capture extra details that may be helpful.

Post Reply