Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - 28 November 2014
Latest Cumulus MX release v3.0.0 build 3046 - 02 January 2019. See the Wiki for download

RS232 data logger recognition

Discussion and questions about Cumulus weather station software version 1. This section and its subforums are the main place to get help with Cumulus. Anything which is not specific to the type of weather station goes in here; for anything specific to a type of weather station, please use the appropriate subforum. Use the 'website development' section for any questions relating to creating or running a web site for Cumulus data. Discussion of the stations themselves in these sections is fine.
Post Reply
Herefordian
Posts: 14
Joined: Mon 25 Nov 2013 5:35 pm
Weather Station: Instromet Climatica
Operating System: Windows 10
Location: Llandegla,Denbighshire UK

RS232 data logger recognition

Post by Herefordian » Wed 09 Jan 2019 5:49 pm

Dear all,
I have recently updated to Windows 10 and am experiencing a problem with the downloading of weather data from my Instromet data logger using Cumulus Software. The serial port is COM2 and is correctly figured. Drivers are up to date. The connection is direct and not via a USB adaptor.

All was working perfectly with W7. I have tried the following:

Disconnecting the RS232 when Windows 10 loading and then reconnecting before next boot up.
Updating Cumulus Software to latest version.
Disconnecting the RS232 before boot up and connecting during boot up.

Without success. My printer wasn't recognised when I upgraded but a clean install of my printer software solved that.

Would a clean install be of use? If so how do I uninstall Cumulus.

I have read Steve's re date/time;regional settings posts but regret I cannot make head nor tail of it. My question is How do I do that? I would be grateful for any help in a not too technical language.
Herefordian

User avatar
mcrossley
Posts: 5315
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: RS232 data logger recognition

Post by mcrossley » Wed 09 Jan 2019 5:53 pm

At what speed does your logger operate?
And have you got the correct version of Cumulus for that speed? - https://cumuluswiki.wxforum.net/a/Software

Herefordian
Posts: 14
Joined: Mon 25 Nov 2013 5:35 pm
Weather Station: Instromet Climatica
Operating System: Windows 10
Location: Llandegla,Denbighshire UK

Re: RS232 data logger recognition

Post by Herefordian » Thu 10 Jan 2019 5:24 pm

Mark, Thank you. The configuration of port COM2 is
Bits per second = 115,200
Data bits = 8; Parity = none; Stop bits = 1; Flow control = none.
In an attempt to solve this problem I updated from v1.9.4 (build 1085) to v1.9.4(build 1099).
The reply to your second question is 'I don't know'.
Until I updated to W10 I hadn't realised that I was in build 1085!!
I hadn't even considered updating to Cummulus MX but I suppose I should.

Early on in the W10/non recognition datalogger episode I was given this error message. I complied, to no effect.
APC - 2018.12.27 16.23 - 001.3d.jpg
I did not know what else to do.

Hope this makes sense.
Tony
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 5315
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: RS232 data logger recognition

Post by mcrossley » Thu 10 Jan 2019 5:37 pm

So build 1100 is the latest Cumulus 1 for your Instroment, but I do not think that is your problem.

You have configured COM2 in Cumulus, but what COM ports do you have listed in Device Manager?

Herefordian
Posts: 14
Joined: Mon 25 Nov 2013 5:35 pm
Weather Station: Instromet Climatica
Operating System: Windows 10
Location: Llandegla,Denbighshire UK

Re: RS232 data logger recognition

Post by Herefordian » Fri 11 Jan 2019 3:31 pm

Mark, There are two COM ports listed and 1 LPT

COM1 PCI Serial Port.
COM2 Communcations Port.
LPT1 Printer Port.
Tony

User avatar
mcrossley
Posts: 5315
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: RS232 data logger recognition

Post by mcrossley » Fri 11 Jan 2019 4:23 pm

The only other suggestion I have at the moment... is there another copy of Cumulus running in the background? Does task manager show anything?

Herefordian
Posts: 14
Joined: Mon 25 Nov 2013 5:35 pm
Weather Station: Instromet Climatica
Operating System: Windows 10
Location: Llandegla,Denbighshire UK

Re: RS232 data logger recognition

Post by Herefordian » Mon 14 Jan 2019 5:06 pm

Mark, Thank you for the suggestion.
Device manager shows one Cumulus 1 running.
I have since tried uncoupling the RS232 cable,powering the down datalogger, reconnecting the cable to the serial port then powering up the data logger. Regret unsuccessful.
Would uninstalling Cumulus 1 and then doing a clean install be effective? Perhaps upgrading to Cumulus MX?
Having said that....the real problem is the inability of the data to download from the data logger in Windows 10.

The MSTech Forum suggested creating a new COM port and numbering it out of sequence naming it COM11. That didn't work either.
I don't really want to revert to W7 for obvious reasons.
Tony

User avatar
mcrossley
Posts: 5315
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: RS232 data logger recognition

Post by mcrossley » Mon 14 Jan 2019 7:34 pm

I very much doubt reinstalling Cumulus or changing to MX would change anything.

Can you connect a terminal program to the comm port and see if there is any response?

Do Instromet have a test program you could try?

Long shot - try running Cumulus as an Admin?

Post Reply