Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.7.0 (build 3089) - 28 July 2020 (please see important announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this link to Download the Software (Cumulus MX / Cumulus 1 and other related items). Software

USB stop responding

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

stef942
Posts: 20
Joined: Mon 19 Oct 2009 8:17 pm
Weather Station: WMR200
Operating System: raspi3
Location: France-oise

USB stop responding

Post by stef942 »

Hi,

My WMR200 stops sending data to my pi3 several times every day or the pi doesnt received data from the station i dont know but i have to reboot it 2.3.4 times a day. what can i do to find the problem?

thanks for your help
My weather station at Ver sur Launette - France (live) : http://stef942.free.fr/CumulusMX/gauges.htm

User avatar
ConligWX
Posts: 795
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis vPro2 Plus +DFARS
Operating System: Ubuntu / Windows 10
Location: Bangor, NI
Contact:

Re: USB stop responding

Post by ConligWX »

I'm not sure if the same thing applies to the WMR200 but I know fine Offset devices lock up from time to time. some fixes are to either add Ferrite cores to the ends of the USB console cable, or to plug in a Powered USB Hub between the Rasbpi and your Weather Station Console. Also using a shielded USB cable can help too.

are you sharing the USB port on the Rasbpi with anything else?
Regards Simon

https://www.conligwx.org - @conligwx
• Davis Vantage Pro2 Plus + DFARS • WeatherLink Live • CumulusMX • Saratoga Templates •

stef942
Posts: 20
Joined: Mon 19 Oct 2009 8:17 pm
Weather Station: WMR200
Operating System: raspi3
Location: France-oise

Re: USB stop responding

Post by stef942 »

thanks for your reply, there is nothing else connected to the pi only the station, the usb cable has ferrite cores on both ends, i will try an usb hub to see if it change something .
My weather station at Ver sur Launette - France (live) : http://stef942.free.fr/CumulusMX/gauges.htm

sutne
Posts: 81
Joined: Sun 14 Oct 2012 4:23 pm
Weather Station: Oregon Scientific WMR100
Operating System: Raspbian Buster
Location: Rjoanddalen, Voss, Norway

Re: USB stop responding

Post by sutne »

I had problems with the USBconnection between my WMR100 and the Raspberry3.
After I installed a powered hub between them last year, I have had no problems.

stef942
Posts: 20
Joined: Mon 19 Oct 2009 8:17 pm
Weather Station: WMR200
Operating System: raspi3
Location: France-oise

Re: USB stop responding

Post by stef942 »

hi, so 1 week later, i use now this hub :

Image

and it's really better but not perfect as i still have some cut around once a day.
My weather station at Ver sur Launette - France (live) : http://stef942.free.fr/CumulusMX/gauges.htm

User avatar
ConligWX
Posts: 795
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis vPro2 Plus +DFARS
Operating System: Ubuntu / Windows 10
Location: Bangor, NI
Contact:

Re: USB stop responding

Post by ConligWX »

stef942 wrote:hi, so 1 week later, i use now this hub :

Image

and it's really better but not perfect as i still have some cut around once a day.
and is it powered by mains electric?
Regards Simon

https://www.conligwx.org - @conligwx
• Davis Vantage Pro2 Plus + DFARS • WeatherLink Live • CumulusMX • Saratoga Templates •

water01
Posts: 1943
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 10 64bit
Location: Burnham-on-Sea
Contact:

Re: USB stop responding

Post by water01 »

I can answer for him since I have one yes it is.
David
Image

stef942
Posts: 20
Joined: Mon 19 Oct 2009 8:17 pm
Weather Station: WMR200
Operating System: raspi3
Location: France-oise

Re: USB stop responding

Post by stef942 »

despite hub, i still have random cuts several times a day :roll:

i have this error in mxdiag report :

Code: Select all

2018-08-20 09:11:08.359 09:11:08 Calling Read
2018-08-20 09:11:08.359 09:11:08 numBytes = 9
2018-08-20 09:11:08.359 09:11:08 01 0B 60 01 00 00 00 00
2018-08-20 09:11:08.359 Data read loop: Array index is out of range.
2018-08-20 09:11:08.359 09:11:08 Calling Read
2018-08-20 09:11:08.359 09:11:08 numBytes = 9
2018-08-20 09:11:08.359 09:11:08 01 09 60 01 00 00 00 00
2018-08-20 09:11:08.360 Data read loop: Array index is out of range.
2018-08-20 09:11:08.360 09:11:08 Calling Read
2018-08-20 09:11:08.360 09:11:08 numBytes = 9
2018-08-20 09:11:08.360 09:11:08 01 14 60 01 00 00 00 00
2018-08-20 09:11:08.360 Data read loop: Array index is out of range.
2018-08-20 09:11:08.361 09:11:08 Calling Read
2018-08-20 09:11:08.361 09:11:08 numBytes = 9
2018-08-20 09:11:08.361 09:11:08 01 08 60 01 00 00 00 00
2018-08-20 09:11:08.361 Data read loop: Array index is out of range.
2018-08-20 09:11:08.361 09:11:08 Calling Read
2018-08-20 09:11:08.361 09:11:08 numBytes = 9
2018-08-20 09:11:08.361 09:11:08 01 12 60 01 00 00 00 00
2018-08-20 09:11:08.362 Data read loop: Array index is out of range.
2018-08-20 09:11:08.362 09:11:08 Calling Read
2018-08-20 09:11:08.362 09:11:08 numBytes = 9
2018-08-20 09:11:08.362 09:11:08 01 00 60 01 00 00 00 00
2018-08-20 09:11:08.362 Data read loop: Array index is out of range.
2018-08-20 09:11:08.362 09:11:08 Calling Read
2018-08-20 09:11:08.362 09:11:08 numBytes = 9
2018-08-20 09:11:08.363 09:11:08 01 E8 60 01 00 00 00 00
2018-08-20 09:11:08.363 Data read loop: Array index is out of range.
2018-08-20 09:11:08.363 09:11:08 Calling Read
2018-08-20 09:11:08.363 09:11:08 numBytes = 9
2018-08-20 09:11:08.363 09:11:08 01 00 60 01 00 00 00 00
2018-08-20 09:11:08.363 Data read loop: Array index is out of range.
2018-08-20 09:11:08.364 09:11:08 Calling Read
2018-08-20 09:11:08.364 09:11:08 numBytes = 9
2018-08-20 09:11:08.364 09:11:08 01 3B 60 01 00 00 00 00
2018-08-20 09:11:08.364 Data read loop: Array index is out of range.
2018-08-20 09:11:08.364 09:11:08 Calling Read
2018-08-20 09:11:08.364 09:11:08 numBytes = 9
2018-08-20 09:11:08.365 09:11:08 01 96 60 01 00 00 00 00
2018-08-20 09:11:08.365 Data read loop: Array index is out of range.
2018-08-20 09:11:08.365 09:11:08 Calling Read
2018-08-20 09:11:08.365 09:11:08 numBytes = 9
2018-08-20 09:11:08.365 09:11:08 01 00 60 01 00 00 00 00
2018-08-20 09:11:08.365 Data read loop: Array index is out of range.
2018-08-20 09:11:08.365 09:11:08 Calling Read
2018-08-20 09:11:08.366 09:11:08 numBytes = 9
2018-08-20 09:11:08.366 09:11:08 01 00 60 01 00 00 00 00
2018-08-20 09:11:08.366 Data read loop: Array index is out of range.
2018-08-20 09:11:08.366 09:11:08 Calling Read
2018-08-20 09:11:08.366 09:11:08 numBytes = 9
2018-08-20 09:11:08.366 09:11:08 01 E2 60 01 00 00 00 00
2018-08-20 09:11:08.366 Data read loop: Array index is out of range.
2018-08-20 09:11:08.367 09:11:08 Calling Read
2018-08-20 09:11:08.367 09:11:08 numBytes = 9
2018-08-20 09:11:08.367 09:11:08 01 02 60 01 00 00 00 00
2018-08-20 09:11:08.367 Data read loop: Array index is out of range.
2018-08-20 09:11:08.367 09:11:08 Calling Read
2018-08-20 09:11:11.367 Data read loop: The operation has timed-out.
etc....
:roll:
My weather station at Ver sur Launette - France (live) : http://stef942.free.fr/CumulusMX/gauges.htm

User avatar
steve
Cumulus Author
Posts: 26702
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: USB stop responding

Post by steve »

You'll always get lots of messages of that kind while reading data from this type of station because of the way MX reads the data; they are not indications of a problem and don't help with diagnosing the problem, unfortunately.
Steve

ExperiMentor
Posts: 199
Joined: Tue 24 Nov 2015 11:30 pm
Weather Station: Fine Offset & Davis Vantage Vue
Operating System: Windows 10; Raspbian Buster
Location: Switzerland

Re: USB stop responding

Post by ExperiMentor »

I don't have the same equipment, but here are some thoughts.

Can you tell if either the Pi or Weather Station is 'crashing' & rebooting? or do both stay running with failed data collection?

There are suggestions that adding USB hub helps some people. The hub should not do much except ensure that the weather station receives sufficient power all the time (certainly Fine Offset stations take power from the USB port [ie Raspberry Pi] once plugged in, rather than using their internal batteries. And Raspberry Pi's are known to need a sturdy power supply especially if you have powered devices attached to their USB hub. So make sure the Pi's PSU is a good one, especially if you are using a Pi3 or 2 rather than a Pi Zero W.

While on subject of power, have you checked that your weather station has good batteries?

And I see you live in France. Is it rural? Do you suffer the typical French momentary power glitches? You could try adding a USB power pack between the Pi's PSU and the Pi (to act as a UPS - uninterruptible power supply - power pack permanently on charge and available to power the Pi during any glitches).

At least those are the kinds of things I'd be checking up on ...

stef942
Posts: 20
Joined: Mon 19 Oct 2009 8:17 pm
Weather Station: WMR200
Operating System: raspi3
Location: France-oise

Re: USB stop responding

Post by stef942 »

Hello, thanks for your help

1/ station and pi keep running but data are not send/received, i don't know

2/ the station is powered with adequate power supply and batteries are fine, usb hub is powered too.

3/ typical French momentary power glitches ? :lol:
My weather station at Ver sur Launette - France (live) : http://stef942.free.fr/CumulusMX/gauges.htm

hillyjd
Posts: 29
Joined: Sun 23 Apr 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Re: USB stop responding

Post by hillyjd »

I've been having a similar problem with increasing frequency. CumulusMX locks up and I get this error in the diagnostics file:

System.IO.IOException: Input/output error
at System.IO.Ports.SerialPortStream.ThrowIOException () [0x00000] in <filename unknown>:0
at System.IO.Ports.SerialPortStream.DiscardInBuffer () [0x00000] in <filename unknown>:0
at System.IO.Ports.SerialPort.DiscardInBuffer () [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.IO.Ports.SerialPort:DiscardInBuffer ()
at CumulusMX.DavisStation.SendLoopCommand (System.IO.Ports.SerialPort serialPort, System.String commandString) [0x00000] in <filename unknown>:0
at CumulusMX.DavisStation.Start () [0x00000] in <filename unknown>:0
at System.Threading.Thread.StartInternal () [0x00000] in <filename unknown>:0
**** An error has occurred - please zip up the MXdiags folder and post it in the forum ****
Press Enter to terminate

Any ideas?

r/
Jim

hillyjd
Posts: 29
Joined: Sun 23 Apr 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Re: USB stop responding

Post by hillyjd »

One other thing I should mention. When Cumulus hangs up and I get the error and I hit "Enter" to terminate the program, it will not restart. When I type in the commands, I get a "Cannot connect to station" error. I must reboot the system entirely to get it to work again. Not sure it's related, but it's a feature.

r/
Jim

User avatar
ConligWX
Posts: 795
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis vPro2 Plus +DFARS
Operating System: Ubuntu / Windows 10
Location: Bangor, NI
Contact:

Re: USB stop responding

Post by ConligWX »

hillyjd wrote:**** An error has occurred - please zip up the MXdiags folder and post it in the forum ****
Press Enter to terminate

Any ideas?

r/
Jim
Did you attach the MXDiags folder to your post? Sorry but I don't see it.
Regards Simon

https://www.conligwx.org - @conligwx
• Davis Vantage Pro2 Plus + DFARS • WeatherLink Live • CumulusMX • Saratoga Templates •

hillyjd
Posts: 29
Joined: Sun 23 Apr 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Re: USB stop responding

Post by hillyjd »

No, I just posted the error text from the diagnostics. Here's the entire file. This is actually the diagnostic file from latest lockup from yesterday.

r/
Jim
You do not have the required permissions to view the files attached to this post.

Post Reply