Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

WH1080 raspbian stretch?

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
Post Reply
maddinthebrain
Posts: 33
Joined: Mon 07 Aug 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

WH1080 raspbian stretch?

Post by maddinthebrain » Fri 02 Mar 2018 11:46 am

Hello everybody,

I have a Fineoffset WH1080 connected to a Raspi3 with Raspian.

First I ran CumulusMX under Jessie and mono 4.0.2.5, but now I update to Stretch due to imcompatibilities of PHP7.0 which I need for other stuff. Doing the upgrade to Stretch mono was upgraded to 4.6.2.7. And now CumulusMX will not start anymore. Does anybody know a way for Cumulus and Stretch?

Thx in advance.

Martin

User avatar
ConligWX
Posts: 728
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: WH1080 raspbian stretch?

Post by ConligWX » Fri 02 Mar 2018 1:05 pm

there are numerous post on Mono/Stretch issues here. you must run Mono 4.0.x OR LOWER with stretch with a fine offset Weather station. running it with a higher version of mono will not work with your Station.

you will need to remove Mono totally, then change the source for mono to a compatible version (3.2.8-4.0.2.5) in /etc/apt/sources.list save the .list file and then reinstall Mono again.

Plenty of guides to do this on the net.
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS Templates

Post Reply