Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.2.4 build 3060 - 10 December 2019.
    Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

    See the Wiki for downloading either version.

    Catching up with missing data with the VantageVue logger

    Discussion specific to Davis weather stations
    Post Reply
    david3
    Posts: 55
    Joined: Sat 28 Jan 2012 4:03 pm
    Weather Station: Davis Vantage Vue
    Operating System: Raspbian Stretch
    Location: Philippines
    Contact:

    Catching up with missing data with the VantageVue logger

    Post by david3 » Thu 28 Apr 2016 12:27 pm

    I have a Davis VantageVue running with Cumulus, and the logger interval is set to 10 minutes on both the VantageVue and in Cumulus.

    Today my PC's power supply stopped working, so it was down for about 5 hours.

    When I started Cumulus up again, I expected it would read the archive data from the logger and catch up, but when I looked at the graphs, it seemed to be missing data. Also the "Archive records read" count at the bottom of the screen was 0.

    So I checked the "apr16log.txt" file, and sure enough there's a 5 hour gap from 10:30 to 15:00

    Code: Select all

    28/04/16,10:20,32.9,67,25.9,3.2,8.0,290,0.0,0.0,1010.54,1.3,25.1,39,0.0,32.9,41.9,0.0,0,0.00,0.00,39.3,972,0.0,298,0.0,0.0
    28/04/16,15:10,33.2,63,25.2,3.2,12.9,2,0.0,0.0,1008.91,1.3,25.3,46,6.4,33.2,41.2,0.0,0,0.00,0.00,39.1,670,0.0,345,0.0,0.0
    I checked the diags folder, and found where I think it should have been loading the archive data:

    Code: Select all

    4/28/2016 15:06:19.006 : Loading last N hour data from data logs: 4/28/2016 10:20:00 AM
    4/28/2016 15:06:19.045 : Loaded 7 entries to last hour data list
    4/28/2016 15:06:19.074 : Loaded 19 entries to last 3 hour data list
    4/28/2016 15:06:19.103 : Loaded 145 entries to last 24 hour data list
    4/28/2016 15:06:19.144 : Loaded 1009 entries to recent data list
    4/28/2016 15:06:20.052 : VP2: Setting raintotal from current station value: 1.26999998092651
    4/28/2016 15:06:20.052 : Current rain counter: 1.270
    4/28/2016 15:06:20.052 : Start of day counter: 1.300
    4/28/2016 15:06:20.052 : Rain today so far: 0.000
    4/28/2016 15:06:20.052 : Rain multiplier = 1.000
    4/28/2016 15:06:20.075 : Writing today.ini, LastUpdateTime = 4/28/2016 10:20:00 AM raindaystart = 1.29999995231628 rain counter = 1.26999998092651
    4/28/2016 15:06:20.076 : VP2: End of history download
    That looks like it read the data, but not sure what happened. I also tried a test where I shut down Cumulus just before the 10 minute mark and started it back up just after. No archive records read and a missing data record in "apr16log.txt" file.

    Also, I found other areas in the log file where I shut Cumulus down and restarted it, where there seems to be more information in the log when it's reading the logger that was missing earlier.

    Code: Select all

    4/28/2016 16:34:08.778 : Loading last N hour data from data logs: 4/28/2016 4:30:00 PM
    4/28/2016 16:34:08.809 : Loaded 7 entries to last hour data list
    4/28/2016 16:34:08.840 : Loaded 9 entries to last 3 hour data list
    4/28/2016 16:34:08.871 : Loaded 117 entries to last 24 hour data list
    4/28/2016 16:34:08.914 : Loaded 981 entries to recent data list
    4/28/2016 16:34:08.914 : Last update time = 16:30
    4/28/2016 16:34:08.914 : Log interval = 10
    4/28/2016 16:34:08.914 : After rounding = 16:30
    4/28/2016 16:34:08.926 : VP2: Downloading history from 4/28/2016 4:30:00 PM
    4/28/2016 16:34:08.926 : y=2016 m=4 d=28 h=16 m=30
    4/28/2016 16:34:12.656 : VP2: DownloadData_V = 0
    4/28/2016 16:34:12.656 : VP2: GetNumberOfArchiveRecords_V = -1
    4/28/2016 16:34:12.656 : VP2: No history records to process
    4/28/2016 16:34:13.559 : VP2: Setting raintotal from current station value: 1.26999998092651
    4/28/2016 16:34:13.559 : Current rain counter: 1.270
    4/28/2016 16:34:13.559 : Start of day counter: 1.300
    4/28/2016 16:34:13.559 : Rain today so far: 0.000
    4/28/2016 16:34:13.560 : Rain multiplier = 1.000
    4/28/2016 16:34:13.582 : Writing today.ini, LastUpdateTime = 4/28/2016 4:30:00 PM raindaystart = 1.29999995231628 rain counter = 1.26999998092651
    4/28/2016 16:34:13.583 : VP2: End of history download
    Any ideas?

    I did upgrade from Windows 7 to Windows 10 last year, so not sure if that could have anything to do with it.
    Image

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Catching up with missing data with the VantageVue logger

    Post by steve » Thu 28 Apr 2016 1:01 pm

    I can't tell what's happened from the snippets you've posted. Please zip up the diags folder and attach it.

    Note that the Davis DLL never downloads the most recent logger entry, so if you shut down for 10 minutes (in your case), there will be no entries to download.
    Steve

    david3
    Posts: 55
    Joined: Sat 28 Jan 2012 4:03 pm
    Weather Station: Davis Vantage Vue
    Operating System: Raspbian Stretch
    Location: Philippines
    Contact:

    Re: Catching up with missing data with the VantageVue logger

    Post by david3 » Thu 28 Apr 2016 1:35 pm

    Here's the diags folder zipped.
    You do not have the required permissions to view the files attached to this post.
    Image

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Catching up with missing data with the VantageVue logger

    Post by steve » Thu 28 Apr 2016 3:17 pm

    When you started it up at 15:05, you used the station settings screen before it had got started properly - to change the com port, I think. It looks like this confused it into thinking that this was the first time it had started up, so it deliberately didn't attempt to download the logger data. I can understand why you had to do this, it's just unfortunate that it handled it like a new installation. For future reference, it would be safer to edit cumulus.ini to change the com port setting before you start Cumulus up.

    You can 'rewind' and get it download the missing data, by copying the files from the backup folder it created at that time:

    4/28/2016 15:05:56.774 : Creating backup folder C:\Cumulus\backup\20160428150556\

    With Cumulus stopped, copy all of the files from that folder into the data folder, and then start it up.
    Steve

    david3
    Posts: 55
    Joined: Sat 28 Jan 2012 4:03 pm
    Weather Station: Davis Vantage Vue
    Operating System: Raspbian Stretch
    Location: Philippines
    Contact:

    Re: Catching up with missing data with the VantageVue logger

    Post by david3 » Thu 28 Apr 2016 3:33 pm

    Yes, I must have connected the cables in a different order after replacing the power supply so I had to change the com port setting.

    Thanks for the info, and for looking at the logs. I'll try to remember to change the com port setting in the cumulus.ini file in the future.

    I copied the backup data and restarted Cumulus, and success, Archive records read: 77.
    Image

    Post Reply