Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.2.3 build 3059 - 04 December 2019.
    Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

    See the Wiki for downloading either version.

    Windows 10 - Cumulus Crash

    Discussion and questions about Cumulus weather station software version 1. This section and its subforums are the main place to get help with Cumulus. Anything which is not specific to the type of weather station goes in here; for anything specific to a type of weather station, please use the appropriate subforum. Use the 'website development' section for any questions relating to creating or running a web site for Cumulus data. Discussion of the stations themselves in these sections is fine.
    mma
    Posts: 3
    Joined: Thu 30 Jul 2015 11:02 am
    Weather Station: Aercus WS3083
    Operating System: Windows 10
    Location: Wellington

    Windows 10 - Cumulus Crash

    Post by mma » Thu 30 Jul 2015 11:07 am

    Hi there - have just updated to Windows 10 and now the application crashes. Interestingly it is fine on my laptop (not what I connect the weather receiver to). I attach a bug report, any help appreciated. Thanks, Myles
    You do not have the required permissions to view the files attached to this post.

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Windows 10 - Cumulus Crash

    Post by steve » Thu 30 Jul 2015 11:29 am

    It looks like your system date format has changed, so Windows no longer recognises the timestamp in today.ini as a valid. I can't say for certain that's what the problem is, as you're using an out-of-date version of Cumulus, so the line numbers don't tie up with the current code, but that's what it looks like.
    Steve

    DerekH
    Posts: 1
    Joined: Thu 30 Jul 2015 9:14 pm
    Weather Station: Davis VP2
    Operating System: Windows 10
    Location: Waitakere, NZ
    Contact:

    Re: Windows 10 - Cumulus Crash

    Post by DerekH » Thu 30 Jul 2015 9:23 pm

    Yes it is because the update to Windows 10 changed your date and time formats - I resolved this on my upgrade here yesterday.
    You must get the formats dead right - see attached image

    I had to use UK regional settings to get mine sorted. Also needed to go to the Additional Settings box and change the AM / PM designation to a.m. and p.m. (they can be overwritten)

    Cheers - Derek
    You do not have the required permissions to view the files attached to this post.

    mma
    Posts: 3
    Joined: Thu 30 Jul 2015 11:02 am
    Weather Station: Aercus WS3083
    Operating System: Windows 10
    Location: Wellington

    Re: Windows 10 - Cumulus Crash

    Post by mma » Fri 31 Jul 2015 10:48 am

    Guys - thanks so much. Dead right...the AM/PM to a.m./p.m. was the bit I was missing after seemingly doing the rest. Much appreciated.

    M

    barclay
    Posts: 2
    Joined: Tue 04 Aug 2015 2:51 am
    Weather Station: WS3083
    Operating System: Win10
    Location: New Zealand

    Re: Windows 10 - Cumulus Crash

    Post by barclay » Tue 04 Aug 2015 4:23 am

    Hi Guys I'm having the same trouble after installing Win10 I have changed the time and date as described also the am pm but still get the same bugreport attached any help greatly appreciated
    bugreport.txt
    You do not have the required permissions to view the files attached to this post.

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Windows 10 - Cumulus Crash

    Post by steve » Tue 04 Aug 2015 6:35 am

    You are using Cumulus 1.9.2, which is ancient and obsolete, and I'm afraid I can't give any support for that version. You need to make sure that the date and time format you are using now is the same as the one you were using before your Windows upgrade - or at least that it is in a format such that Windows can still recognise the old format as valid. If you would like me to help, you will need to install the latest version of Cumulus - currently 1.9.4 build 1099. If you still have the problem with that version, please zip up the diags folder and attach it, together with your today.ini file and a screen shot of your date and time formats settings from Windows.
    Steve

    barclay
    Posts: 2
    Joined: Tue 04 Aug 2015 2:51 am
    Weather Station: WS3083
    Operating System: Win10
    Location: New Zealand

    Re: Windows 10 - Cumulus Crash

    Post by barclay » Wed 05 Aug 2015 2:45 am

    Thanks Steve, I'll probably wait a bit, my first station packed up after 2 yrs outside and this one is very close to that time...shame to lose all that data though!! :groan:

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Windows 10 - Cumulus Crash

    Post by steve » Wed 05 Aug 2015 6:59 am

    Sorry, I don't understand what you're saying. What is it that you are going to "wait a bit" for? Why will you lose all of your data? Have you made sure your date and time format is now the same as it was before?
    Steve

    bgo
    Posts: 4
    Joined: Wed 05 Aug 2015 5:01 pm
    Weather Station: WMR100
    Operating System: Win10
    Location: Denmark

    Re: Windows 10 - Cumulus Crash

    Post by bgo » Wed 05 Aug 2015 5:17 pm

    Where do I find the settings window in the screenshot?

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Windows 10 - Cumulus Crash

    Post by steve » Wed 05 Aug 2015 5:31 pm

    The quickest way is to type intl.cpl into the search box.
    Steve

    monksie
    Posts: 7
    Joined: Wed 05 Aug 2015 11:18 pm
    Weather Station: Fine Offeset
    Operating System: Windows 10
    Location: Dublin

    Re: Windows 10 - Cumulus Crash

    Post by monksie » Wed 05 Aug 2015 11:24 pm

    Hi Guys!!

    Installed Windows 10, I am getting errors and I have changed time properly (i think) however I am getting error messages like this....

    06/08/2015 00:15:27 : Error at line 1 of C:\Cumulus\data\Aug15log.txt : List index out of bounds (1

    I can also not view any historical data and Climatological reports...very frustated!

    Hope someone can help please :|

    Thanks JP

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Windows 10 - Cumulus Crash

    Post by steve » Thu 06 Aug 2015 7:06 am

    Please zip up the diags folder and attach it, together with your August log file.
    Steve

    bgo
    Posts: 4
    Joined: Wed 05 Aug 2015 5:01 pm
    Weather Station: WMR100
    Operating System: Win10
    Location: Denmark

    Re: Windows 10 - Cumulus Crash

    Post by bgo » Thu 06 Aug 2015 7:27 pm

    Thanks.

    Tried the changes but it didn't help. I'll try to install the latest stable version tomorrow and see if that helps. Seems like the same problem arose with Weather Display (I use both programs) - I can see that the computer IS receiving data, but Cumulus errors with wrong date format message and Weather Display just doesn't update the data.

    I'll tell you how it goes tomorrow.

    bgo
    Posts: 4
    Joined: Wed 05 Aug 2015 5:01 pm
    Weather Station: WMR100
    Operating System: Win10
    Location: Denmark

    Re: Windows 10 - Cumulus Crash

    Post by bgo » Fri 07 Aug 2015 10:29 am

    Ok, I uninstalled the old Cumulus, removed any remaining files and installed the latest stable version. Selected my station (wmr100), and noticed that there was no USB selection option (don't know if that had any effect before but I selected it anyway).

    Now nothing at all happens. No error, debug log says nothing. After a while gauges for battery appear with the shine animation on them.

    bgo
    Posts: 4
    Joined: Wed 05 Aug 2015 5:01 pm
    Weather Station: WMR100
    Operating System: Win10
    Location: Denmark

    Re: Windows 10 - Cumulus Crash

    Post by bgo » Fri 07 Aug 2015 11:43 am

    Solved :clap:

    I have another PC which had also been upgraded, so I decided to try to installed the software on that one to see if it would work there. Both worked right out of the box :shock:

    So I re-connected the station to the first PC and what happens? Both worked there as well :?: How the &%&%#&/¤ was I supposed to now that all I needed was to unplug and then replug the USB :bash:

    Well, anyway. For anyone who might run into the same problem, here's a solution to try out ;)

    Happy weather data gathering :D

    Post Reply