Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.6.4 (build 3080) - 26 May 2020 (please see important announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

See the Wiki to download the software or click on the Downloads link in the Forum Banner.

Anyone using MX with a Weatherlink IP logger?

Topics about the Beta trials up to Build 3043, the last build by Cumulus's founder Steve Loft. It was by this time way out of Beta but Steve wanted to keep it that way until he made a decision on his and Cumulus's future.

Moderator: mcrossley

User avatar
steve
Cumulus Author
Posts: 26704
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Anyone using MX with a Weatherlink IP logger?

Post by steve »

Is anyone successfully using Cumulus MX with a 'real' Davis IP logger, driving it directly?
Steve

BCJKiwi
Posts: 945
Joined: Mon 09 Jul 2012 8:40 pm
Weather Station: Davis VP2 Cabled with Solar
Operating System: Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: Anyone using MX with a Weatherlink IP logger?

Post by BCJKiwi »

This post prompted me to test my oddball setup for your info - was going to wait until the morning when I was fresh rather than 11:30 pm - too many late nights these days!

Unfortunately still not fully functional diag attached.
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26704
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Anyone using MX with a Weatherlink IP logger?

Post by steve »

I was really hoping for a response from someone with a more 'standard' setup. But I can't remember what your setup actually is, and I can't find your original thread now that you've posted in this one instead. The log doesn't show anything, but I'm adding more logging of the data. I think there may be an issue with CRC checking, but why that should only affect TCP/IP connections (and not all the time) I have no idea.
Steve

BCJKiwi
Posts: 945
Joined: Mon 09 Jul 2012 8:40 pm
Weather Station: Davis VP2 Cabled with Solar
Operating System: Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: Anyone using MX with a Weatherlink IP logger?

Post by BCJKiwi »

Original thread here:-
https://cumulus.hosiene.co.uk/viewtopic.php?f=27&t=13219
My config uses a 'WiFly' wifi to serial module attached to the logger - so IP/Ethernet over WiFi to the logger.

It should be transparent to CumulusMX as a regular IP logger (as it is for Cumulus1).

Interestingly after closing CumulusMX.exe in the normal fashion when ending the IP logger session on the last two occasions, the Cumulus.ini file has been empty as in blank as in no lines whatsoever. Fortunately I have a backup copy of each significant change to the .ini file. Just wondering if it might be useful to add Cumulus.ini to the backup folder?

User avatar
steve
Cumulus Author
Posts: 26704
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Anyone using MX with a Weatherlink IP logger?

Post by steve »

BCJKiwi wrote:It should be transparent to CumulusMX as a regular IP logger (as it is for Cumulus1).
But the whole point of this thread was to ask for someone who was using an actual Davis IP logger. Are you using a Davis IP logger?
Steve

BCJKiwi
Posts: 945
Joined: Mon 09 Jul 2012 8:40 pm
Weather Station: Davis VP2 Cabled with Solar
Operating System: Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: Anyone using MX with a Weatherlink IP logger?

Post by BCJKiwi »

No it is not a Davis IP logger - they don't make a WiFi logger.
I should not have posted in this thread - was trying to help by letting you know b3017 did not work for me.

User avatar
MackerelSky
Posts: 141
Joined: Fri 01 Apr 2011 8:14 pm
Weather Station: Davis VP2 w/FARS
Operating System: Toshiba Laptop Windows 7 x64
Location: Smethport, Pa.
Contact:

Re: Anyone using MX with a Weatherlink IP logger?

Post by MackerelSky »

steve wrote:Is anyone successfully using Cumulus MX with a 'real' Davis IP logger, driving it directly?
I would imagine you are taking a well deserved/earned break from the grind.

Hope things are well.

I will be installing MX sometime next week on the same machine C1 is operating on.
Win7 with the required 4.5

I'm currently using the WLIPdatalogger that came with my package 4 yrs ago, both the computer and the logger are plugged into my router and using the TCP/IP setting 22222 to communicate.

Everything is working great and I've read thru the entire forum for installation/setup.

Is there something in particular that you are aware of with the WL logger, something I should do a little different?

Anyways, no rush on this end, just wanted to let you know that I have the logger.

Brad
Davis VP2/FARS
Cumulus 1.9.4(1092)

McKean Weather
'cause not everyone lives at the airport

Image

User avatar
steve
Cumulus Author
Posts: 26704
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Anyone using MX with a Weatherlink IP logger?

Post by steve »

I really just wanted to know that it works OK, since there is apparently an issue when using MX and TCP/IP with the 'pass through' facility of Meteobridge. You shouldn't need to do anything different.
Steve

User avatar
MackerelSky
Posts: 141
Joined: Fri 01 Apr 2011 8:14 pm
Weather Station: Davis VP2 w/FARS
Operating System: Toshiba Laptop Windows 7 x64
Location: Smethport, Pa.
Contact:

Re: Anyone using MX with a Weatherlink IP logger?

Post by MackerelSky »

steve wrote:I really just wanted to know that it works OK, since there is apparently an issue when using MX and TCP/IP with the 'pass through' facility of Meteobridge. You shouldn't need to do anything different.
Very good, I'll let you know how I make out later this week.
Davis VP2/FARS
Cumulus 1.9.4(1092)

McKean Weather
'cause not everyone lives at the airport

Image

Bjarne
Posts: 5
Joined: Wed 31 Dec 2008 2:35 pm

Re: Anyone using MX with a Weatherlink IP logger?

Post by Bjarne »

Hi Steve,
I am using Cumulus MX with a Weatherlink IP logger, and I can't get it to Work. I connect directly to the Weatherlogger but Cumulus MX does not get any data from it. I copied the cumulus.ini file from my Cumulus 1.9.4 installation where it Works perfectly. When I then try to go to Settings, the system crashes.

System is:
Davis Vantage Pro2 with Weatherlink IP logger
Cumulus MX is running on Windows 8.1 64Bit

Below is the output from the Logfile.

Regards,
Bjarne

2015-02-21 13:23:49.889 ========================== Cumulus MX starting ==========================
2015-02-21 13:23:49.889 Command line: "C:\CumulusMX\CumulusMX.exe"
2015-02-21 13:23:49.889 Cumulus MX v.3.0.0 build 3020
2015-02-21 13:23:49.892 Platform: Win32NT
2015-02-21 13:23:49.892 OS version: Microsoft Windows NT 6.2.9200.0
2015-02-21 13:23:49.892 Current culture: Danish (Denmark)
2015-02-21 13:23:49.892 21-02-2015 13:23:49
2015-02-21 13:23:49.892 Data path = data\
2015-02-21 13:23:49.892 Creating backup folder backup\20150221132349\
2015-02-21 13:23:49.919 Reading Cumulus.ini file
2015-02-21 13:23:49.925 ASM=10 AST=00:10:00
2015-02-21 13:23:49.928 Cumulus start date: 25-12-2008
2015-02-21 13:23:49.949 Station type: Davis Vantage Pro2
2015-02-21 13:23:49.949 WindUnit=m/s RainUnit=mm TempUnit=°C PressureUnit=hPa
2015-02-21 13:23:49.949 YTDRain=0,000 Year=2012
2015-02-21 13:23:49.949 RainDayThreshold=-1,000
2015-02-21 13:23:49.949 Offsets and Multipliers:
2015-02-21 13:23:49.949 PO=0,000 TO=0,000 HO=0 WDO=0 ITO=0,000 UVO=0,000
2015-02-21 13:23:49.949 WSM=107000005245209,000 WGM=107000005245209,000 TM=1,000 TM2=1,000 HM=1,000 RM=1,000 UVM=1,000
2015-02-21 13:23:49.949 Spike removal:
2015-02-21 13:23:49.949 TD=999,000 GD=999,000 WD=999,000 HD=999,000 PD=999,000
2015-02-21 13:23:49.952 MR=999,000 MH=999,000
2015-02-21 13:23:49.952 Cumulus Starting
2015-02-21 13:23:49.952 Opening station
2015-02-21 13:23:49.964 Last update time from today.ini: 21-02-2015 09:30:00
2015-02-21 13:23:49.967 Read today file: Date = 21-02-2015, LastUpdateTime = 21-02-2015 09:30:00, Month = 2
2015-02-21 13:23:49.967 ReadTodayfile: set notraininit false
C:\CumulusMX\data\alltime.ini
Alltime.ini file read
MonthlyAlltime.ini file read
Month.ini file read
Year.ini file read
2015-02-21 13:23:49.985 Finding raintoday from logfile data\feb15log.txt
2015-02-21 13:23:49.985 Expecting listsep=; decimal=,
Midnight rain found in the following entry:
21-02-15;00:00;2,2;95;1,4;0,0;0,0;0;0,0;0,0;1000,31;114,3;18,8;35;0,0;2,2;2,2;0,0;0;0,20;17,68;0,4;0;0,0;171;0,0;0,0
Setting raintoday from logfile = 7,9
Calculating rain counter = 114300003051766
Midnight rain found = 114,3
Getting rain totals, rain season start = 1
2015-02-21 13:23:50.072 Rainthismonth from dayfile.txt: 16,8
2015-02-21 13:23:50.072 Rainthisyear from dayfile.txt: 99,3
2015-02-21 13:23:50.099 Station type = Davis
2015-02-21 13:23:50.099 LOOP2 disabled
2015-02-21 13:23:50.099 IP address = 192.168.1.231 Port = 22222
2015-02-21 13:23:50.105 Connected OK
2015-02-21 13:23:50.105 Flushing input stream
2015-02-21 13:23:50.307 Reading firmware version
2015-02-21 13:23:51.313 FW version = ???
2015-02-21 13:23:51.313 Reading reception stats
2015-02-21 13:23:52.320 1.90



OK

683 21 0 41 0

2015-02-21 13:23:52.320 Last update time = 21-02-2015 09:30:00
2015-02-21 13:23:52.320 Setting console time
2015-02-21 13:23:53.326 Received 0x0A
2015-02-21 13:23:53.326 Received 0x0D
2015-02-21 13:23:53.326 No ACK
2015-02-21 13:23:53.326 Reading console time
2015-02-21 13:23:54.032 Received 0x06
2015-02-21 13:23:54.032 ACK received
2015-02-21 13:23:54.032 00-00-00-00-00-00-00-00
2015-02-21 13:23:54.032 Expected 8 bytes, got 0
2015-02-21 13:23:54.032 Start reading archive data
2015-02-21 13:23:54.032 Reading archive data
2015-02-21 13:23:54.032 Loading last N hour data from data logs: 21-02-2015 09:30:00
2015-02-21 13:23:54.077 Loaded 7 entries to last hour data list
2015-02-21 13:23:54.122 Loaded 19 entries to last 3 hour data list
2015-02-21 13:23:54.173 Loaded 145 entries to last 24 hour data list
2015-02-21 13:23:54.254 Loaded 1009 entries to recent data list
2015-02-21 13:23:54.260 Get Archive Data
2015-02-21 13:23:54.260 Rollover hour = 0
2015-02-21 13:23:54.260 Last Archive Date: 21-02-2015 09:30:00
2015-02-21 13:23:54.260 Date: 7765
2015-02-21 13:23:54.260 Time: 930
2015-02-21 13:23:54.278 624 web tags initialised
2015-02-21 13:23:54.296 HTML root path = C:\CumulusMX\interface
2015-02-21 13:23:54.320 Starting web socket server on port 8002
2015-02-21 13:23:55.268 Received response to DMPAFT, sending date and time
2015-02-21 13:23:55.268 55-1E-A2-03-DA-63
2015-02-21 13:23:55.769 No ACK
2015-02-21 13:23:55.769 Updating highs and lows
2015-02-21 13:23:55.772 Start normal reading loop
2015-02-21 13:23:55.781 Start Timers
2015-02-21 13:23:55.781 Starting 1-minute timer
2015-02-21 13:23:55.781 Starting Realtime timer, interval = 2000ms
System.InvalidOperationException: Cannot close stream until all bytes are written.
at System.Net.HttpResponseStream.Dispose(Boolean disposing)
at System.IO.Stream.Close()
at Unosquare.Labs.EmbedIO.WebServer.<Run>b__2(Object contextState)
at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
at System.Threading.ThreadPoolWorkQueue.Dispatch()
at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

User avatar
steve
Cumulus Author
Posts: 26704
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Anyone using MX with a Weatherlink IP logger?

Post by steve »

Bjarne wrote:I copied the cumulus.ini file from my Cumulus 1.9.4 installation where it Works perfectly.
As you use decimal commas, the first thing you need to do is edit Cumulus.ini to chaneg the commas to decimal points, as described at the start of the 'known issues' thread.

Then, please add the lines

Logging=1
DavisInitWaitTime=5000

to the [Station] section of Cumulus.ini and try again. Please attach the MXdiags file here. I may need to add some extra logging of the responses from the console.
Steve

Bjarne
Posts: 5
Joined: Wed 31 Dec 2008 2:35 pm

Re: Anyone using MX with a Weatherlink IP logger?

Post by Bjarne »

Edited all the Ini files and changed , to .
Added the two entries to the Cumulus.ini file and restarted the program. Still same result, no data seems to be transfered from the IP logger.

Tried to go various menues but Again when I hit the Settings menu, the program crashes.

Attached is the logfile.

Bjarne
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26704
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Anyone using MX with a Weatherlink IP logger?

Post by steve »

It looks like the logger is quite slow to respond, so MX re-sends commands and then all the responses come back together. I could try increasing the delay where it waits for a response.

The crash is because something unexpected is being sent across the web sockets interface. Perhaps there is still something invalid in your Cumulus.ini file? I can see that your calibration settings are wrong.
Steve

Bjarne
Posts: 5
Joined: Wed 31 Dec 2008 2:35 pm

Re: Anyone using MX with a Weatherlink IP logger?

Post by Bjarne »

Hi Again,
I now deleted the cumulus.ini file and all data in the data directory. Restartet the program and did all the settings from scratch. First of all there was no longer a crash when entering settings, so there must be something in my original file that makes it crash.

Anyway, after doing this, I still did not get any data after restarting the program. I then restartet Again, and suddenly I had communication and got valid data from the station. Unfortunately after a new restart it does not Work anymore. I have attached the inifile and the two logfiles. The one with the oldest date is the one time I got it working

Bjarne
You do not have the required permissions to view the files attached to this post.
Last edited by steve on Sat 21 Feb 2015 2:20 pm, edited 1 time in total.
Reason: Files with passwords removed

Unit-53
Posts: 25
Joined: Tue 23 Dec 2014 8:48 pm
Weather Station: Davis - Vantage Vue
Operating System: Windows 8.0
Location: United States
Contact:

Re: Anyone using MX with a Weatherlink IP logger?

Post by Unit-53 »

Hello, I was just wondering where the two text files you upload the full files?
I ask this because I did not find the following lines:

2015-02-20 14:51:32.477 LOOP2 enabled
2015-02-20 14:51:32.477 Serial device = COM3

Have you setup your com port?

I have MX and WeatherLink serial to USB .

Win 8.1 64 bit

And I have no problems.
Bill,
Image

Post Reply