Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.0 build 3050 - 1 May 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

FTP Error Code 10060

Discussion specific to Davis weather stations
Post Reply
Marny
Posts: 22
Joined: Sun 29 Apr 2012 6:37 pm
Weather Station: Davis VP2
Operating System: Windows 10
Location: Peebles

FTP Error Code 10060

Post by Marny » Mon 18 Mar 2019 11:39 am

I recently transferred Cumulus version 1.9.4 to a new PC running Windows 10. Whilst it appears everything was moved across successfully and is working - http://www.nwm1.co.uk - I've noticed quite a number of the same error code - FTP Connect Error code 10060. Has anyone come across this same issue?

I should add that as part of the transfer and setup on the new PC I'm using a Brainboxes USB to serial convertor. The original output from the Davis Pro console is fitted with a serial port connection. I'm unsure if the introduction of the USB to serial convertor is a cause of the ftp error.

Many thanks, Neil

freddie
Posts: 437
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2
Operating System: GNU/Linux (Ubuntu 18.04)
Location: Dorrington, Shropshire
Contact:

Re: FTP Error Code 10060

Post by freddie » Mon 18 Mar 2019 2:35 pm

10060 is a timeout error code, so your PC is having difficulty passing data to the server via FTP. It must be intermittent, as I just looked at your site and it looks up-to-date. So it looks like an intermittent network problem.

I doubt that the usb-to-serial converter is the culprit. Note that you would've already had a usb-to-serial driver installed when you first set up your weather station. It is from Silicon labs, and is the CP210x UART bridge. See https://www.silabs.com/products/develop ... cp-drivers
Freddie
Image

Marny
Posts: 22
Joined: Sun 29 Apr 2012 6:37 pm
Weather Station: Davis VP2
Operating System: Windows 10
Location: Peebles

Re: FTP Error Code 10060

Post by Marny » Mon 18 Mar 2019 3:38 pm

Hi Freddie,

Many thanks for your comments. Its a strange one to me, but in light of the fact my site is updating correctly, then I'll just keep a watch on it.
I'm wondering if when I've restored the Cumulus files from my backup disc to the new pc that I've made mistake!! The error logs states Cumulus is trying to connect when in fact its connected is the puzzling part.

Just one other thing, In the move to my new PC I've noticed I've lost my SteelSeries gauges. These had been working fine on the old setup. Do you think Cumulus could be looking for data associated with these?

Again, thank you for your help.
Kind regards, Neil

User avatar
PaulMy
Posts: 1891
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: FTP Error Code 10060

Post by PaulMy » Mon 18 Mar 2019 4:06 pm

Just one other thing, In the move to my new PC I've noticed I've lost my SteelSeries gauges. These had been working fine on the old setup. Do you think Cumulus could be looking for data associated with these?
Perhaps you have found and fixed the problem as they seem to be working now http://nwm1.co.uk/gauges-ss.htm
and also updating http://nwm1.co.uk/realtimegauges.txt

Enjoy,
Paul

freddie
Posts: 437
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2
Operating System: GNU/Linux (Ubuntu 18.04)
Location: Dorrington, Shropshire
Contact:

Re: FTP Error Code 10060

Post by freddie » Mon 18 Mar 2019 4:08 pm

Marny wrote:
Mon 18 Mar 2019 3:38 pm
The error logs states Cumulus is trying to connect when in fact its connected is the puzzling part.
This is because the connection has been made, but files can't be sent/retrieved at that moment. The 10060 error is a timeout error not a connection error, so maybe the error message is a bit misleading.
Marny wrote:
Mon 18 Mar 2019 3:38 pm
Just one other thing, In the move to my new PC I've noticed I've lost my SteelSeries gauges. These had been working fine on the old setup.
SteelSeries gauges are generated from the realtimegauges.txt file. Possibly that file isn't being sent. You should double-check that this file is being sent to your web server.
Freddie
Image

Marny
Posts: 22
Joined: Sun 29 Apr 2012 6:37 pm
Weather Station: Davis VP2
Operating System: Windows 10
Location: Peebles

Re: FTP Error Code 10060

Post by Marny » Mon 18 Mar 2019 5:56 pm

PaulMy wrote:
Mon 18 Mar 2019 4:06 pm
Just one other thing, In the move to my new PC I've noticed I've lost my SteelSeries gauges. These had been working fine on the old setup. Do you think Cumulus could be looking for data associated with these?
Perhaps you have found and fixed the problem as they seem to be working now http://nwm1.co.uk/gauges-ss.htm
and also updating http://nwm1.co.uk/realtimegauges.txt

Enjoy,
Paul


Thanks for the comments, much appreciated.

Marny
Posts: 22
Joined: Sun 29 Apr 2012 6:37 pm
Weather Station: Davis VP2
Operating System: Windows 10
Location: Peebles

Re: FTP Error Code 10060

Post by Marny » Mon 18 Mar 2019 6:01 pm

freddie wrote:
Mon 18 Mar 2019 4:08 pm
Marny wrote:
Mon 18 Mar 2019 3:38 pm
The error logs states Cumulus is trying to connect when in fact its connected is the puzzling part.
This is because the connection has been made, but files can't be sent/retrieved at that moment. The 10060 error is a timeout error not a connection error, so maybe the error message is a bit misleading.
Marny wrote:
Mon 18 Mar 2019 3:38 pm
Just one other thing, In the move to my new PC I've noticed I've lost my SteelSeries gauges. These had been working fine on the old setup.
SteelSeries gauges are generated from the realtimegauges.txt file. Possibly that file isn't being sent. You should double-check that this file is being sent to your web server.
Freddie, thank you. I feel you are correct about the realtimegauges.txt file perhaps isn't being sent. I'll need to look at it later when I've more time. Appreciate your support and that of PaulMy.

Kind regards, Neil

Post Reply