Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

Rain discrepancy in log and uploads

Discussion specific to Davis weather stations
Post Reply
User avatar
PaulMy
Posts: 1714
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Rain discrepancy in log and uploads

Post by PaulMy » Mon 06 Aug 2018 6:40 pm

We had a short downpour in the past hour and when I looked at the Cumulus 1 console, no rain was showing - Cumulus is connected to Envoy/usb logger.
I checked my VP2 console (stand alone) and it showed 11.8 mm.
Checked the Vue console which is connected to WiFiLogger and it showed 11.8 mm.

Checked my upload sites and they all were showing 11.8 mm, including PWS, WU, WOW, AWEKAS, WOW and WC which are all updated by Cumulus 1.
All the sites being uploaded by the WiFiLogger were also updated with the 11.8 mm.

Shortly after the main downpour a 0.2 mm rain was shown by Cumulus 1 and all its uploaded sites. Likely a final bucket tip.

Checked the Aug18log file and only the 0.2 mm is shown and nothing prior.
The Cumulus standard template site http://www.komokaweather.com did not show any of the first 11.8 mm rain but did show the later 0.2 mm. The same for my Saratoga site http://www.komokaweather.ca

About a week ago I had a similar rain event were nothing showed on Cumulus 1 console and though it was a Davis ISS problem so during the rain went to the station and checked the rain gauge and moving the tipping bucket seemed ok and that tipping did show in Cumulus 1. I didn't check any of the uploads at the time and thought just one of those things.

Any thought what could cause Cumulus 1 to have recognized the rain and update the external sites but not record it in the logs and in the webtags for upload? Yet about a half hour later it did get the next rain data and that all went ok.
I should mention that during this downpour there were a couple flickering of power interruption in the house (split second). But the computer with Cumulus is on UPS and consoles/Envoy are on power and batteries.

I have a CoCoRaHS manual gauge which shows 16.8 mm so the Davis VP2 seems to have missed some rain.

Paul

User avatar
mcrossley
Posts: 5210
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Rain discrepancy in log and uploads

Post by mcrossley » Mon 06 Aug 2018 6:46 pm

Might need to see the diags folder for that one Paul!

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Rain discrepancy in log and uploads

Post by steve » Mon 06 Aug 2018 6:48 pm

The diags file should show anything unusual happening with the rainfall counter.
Steve

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Rain discrepancy in log and uploads

Post by steve » Mon 06 Aug 2018 6:52 pm

Looking at your rainfall graph, today's total did go up to just under 11.8 but then went back to zero, so it looks like the counter apparently reset (or did something else unexpected) and Cumulus tried to cater for that - the diags file will confirm. You can use the today's rain editor to correct it to 12 mm.
Steve

User avatar
PaulMy
Posts: 1714
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: Rain discrepancy in log and uploads

Post by PaulMy » Mon 06 Aug 2018 8:09 pm

Last 3 diags zipped.
I see a 32701 error and a restart at about 13:36 which would have been close to the power flickering. I don't recall shutting down or restart Cumulus for a couple of days.

Thanks,
Paul
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Rain discrepancy in log and uploads

Post by steve » Mon 06 Aug 2018 8:36 pm

It's not clear why it restarted, if you didn't do it yourself. Prior to the restart, the annual rain total as reported by the station had reached 459.2:

06/08/2018 13:30:01.135 : Writing today.ini, LastUpdateTime = 06/08/2018 1:30:00 PM raindaystart = 447.399993896484 rain counter = 459.200012207031

After the restart, the station was apparently reporting the annual rain total as 447.4, which meant that the calculation for today's rain gave zero.

06/08/2018 13:36:19.312 : VP2: Setting raintotal from current station value: 447.399993896484

06/08/2018 13:40:00.225 : Writing today.ini, LastUpdateTime = 06/08/2018 1:40:00 PM raindaystart = 447.399993896484 rain counter = 447.399993896484

Shortly afterwards, the annual total increased to 447.6, giving 0.2 for the day:

2018 14:00:00.659 : Writing today.ini, LastUpdateTime = 06/08/2018 2:00:00 PM raindaystart = 447.399993896484 rain counter = 447.600006103516
Steve

User avatar
PaulMy
Posts: 1714
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: Rain discrepancy in log and uploads

Post by PaulMy » Mon 06 Aug 2018 9:31 pm

Again thanks for the replies.
I forgot to mention that during the downpour and when I had the power flickering there was a lighting strike here in the village and maybe that had an affect.

I did see the 447.4 start of day rain in Diags and that surprised me as the Cumulus console had "Rainfall this year 452.2" at the end of yesterday (I keep a manual log for comparing my CoCoRaHS) and it still says 452.2 now. In the [Edit] Today's rain the fields are:
Current rain counter: 448.000(which is the 447.4 plus 0.6 so far today)
Start of day rain counter: 447.400
Multiplier: 1.000
Today rain so far: ???
Should I enter the 12.4 mm (which is the missed 11.8 plus recorded 0.6)
or 17.2 which would set the total to 464.6 (being Cumulus console Rainfall this year of 452.2 plus today's 12.4)
or is there another way to match the Start of day rain and the Rainfall this year, or does it even matter?

Next time, it there is a next time, I'll check the Diags first.

Paul

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Rain discrepancy in log and uploads

Post by steve » Tue 07 Aug 2018 9:02 am

Probably too late now (so you'll need to edit dayfile.txt if you didn't correct the figure yesterday), but you should set it to the correct value for today, and then restart after the next log entry has been written. Cumulus will then recalculate the annual total. It doesn't matter that the station apparently forgot to add that 11.8 to its own annual total.
Steve

Post Reply