Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.2 build 3052 - 13 September 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Cumulus dont read archive data

Discussion specific to Davis weather stations
Post Reply
Shamy
Posts: 5
Joined: Sat 07 Nov 2015 7:53 pm
Weather Station: Vantage Vue
Operating System: Windows 7
Location: Krotoszyn

Cumulus dont read archive data

Post by Shamy » Mon 09 Nov 2015 3:17 am

Hi,
Sorry for my bad english ;( I buy the Vantage Vue station, and i set the logger time to 5 minutes in WL and 1 min in Cumulus. I must restart my computer, and after start Cumulus I saw: "Archive records read: 0".... Next I turn off Cumulus on 30 minutes, and start and again "Archive records read: 0".

Whats happend? In old station (WH1090) all works great

In attachment file from Diags directory
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Cumulus dont read archive data

Post by steve » Mon 09 Nov 2015 8:08 am

The station said there were no archive records available for the period between 03:39 and 04:14. Are you sure you have set the station interval to 5 minutes? Does WL download the logger data, with intervals at 5 minute intervals?

You need to set Cumulus and the station to the same logger interval, as described in the readme.txt and the FAQ. It is possible that this is the cause of your problem - normally if they are different, the station would send all of the contents of the memory; perhaps yours behaves differently and doesn't send any.
Steve

Shamy
Posts: 5
Joined: Sat 07 Nov 2015 7:53 pm
Weather Station: Vantage Vue
Operating System: Windows 7
Location: Krotoszyn

Re: Cumulus dont read archive data

Post by Shamy » Mon 09 Nov 2015 3:42 pm

I set in Cumulus 5 minutes, and in Weather Link set now in 5 minutes, then I off Cumulus on 10 mins and run after this time, and again zero archives records read. Weather Link read all data (5 mins intervals)

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Cumulus dont read archive data

Post by steve » Mon 09 Nov 2015 4:32 pm

Try leaving it for longer. The Davis DLL which Cumulus uses doesn't download the latest logger entry.
Steve

Shamy
Posts: 5
Joined: Sat 07 Nov 2015 7:53 pm
Weather Station: Vantage Vue
Operating System: Windows 7
Location: Krotoszyn

Re: Cumulus dont read archive data

Post by Shamy » Mon 09 Nov 2015 4:51 pm

Default in WL is 30 mins yes? In night it was 30 mins off and too :(
Lack of energy = no data (WL is very primitive) :(

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Cumulus dont read archive data

Post by steve » Mon 09 Nov 2015 5:14 pm

Shamy wrote:Default in WL is 30 mins yes?
I'm not sure - I was going to say that the default was 30 minutes, but then I thought perhaps it was 10 minutes. I can't remember.
In night it was 30 mins off and too :(
Lack of energy = no data (WL is very primitive) :(
Sorry, I don't understand.
Steve

Shamy
Posts: 5
Joined: Sat 07 Nov 2015 7:53 pm
Weather Station: Vantage Vue
Operating System: Windows 7
Location: Krotoszyn

Re: Cumulus dont read archive data

Post by Shamy » Mon 09 Nov 2015 5:17 pm

steve wrote:
Shamy wrote:Default in WL is 30 mins yes?
Lack of energy = no data (WL is very primitive) :(
Sorry, I don't understand.[/quote]

Lost of electric energy when computer must be off

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Cumulus dont read archive data

Post by steve » Mon 09 Nov 2015 5:27 pm

If you have definitely set your station logger AND Cumulus to 5 minutes, and your console clock is correct, and you have then run Cumulus for at least 10 minutes and then stopped it for at least 30 minutes, and it still doesn't download the missing data (apart from the last logger entry) when you start it again, then I don't know what the problem is, sorry. You must have an unusual logger that doesn't work with the Davis DLL which Cumulus uses.
Steve

Shamy
Posts: 5
Joined: Sat 07 Nov 2015 7:53 pm
Weather Station: Vantage Vue
Operating System: Windows 7
Location: Krotoszyn

Re: Cumulus dont read archive data

Post by Shamy » Mon 09 Nov 2015 11:30 pm

Station clock is +/- 1 minute error to computer time.
Image - computer is off.

So Im alone with problem?

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Cumulus dont read archive data

Post by steve » Tue 10 Nov 2015 7:22 am

I don't know of anyone else with this problem. If you zip up the diags folder and attach it, I'll take another look to see if I can see anything. But if the Davis DLL says it can't download any archive entries, there's nothing I can do.
Steve

orfeo
Posts: 11
Joined: Wed 08 Jul 2015 4:13 pm
Weather Station: Davis VP2+
Operating System: Linux Mint / Windows 7
Location: Toronto Canada

Re: Cumulus dont read archive data

Post by orfeo » Mon 07 Oct 2019 2:01 pm

Hi Steve

Resuscitating this thread. I believe i have had the same problem with a Davis VP2+. We had a power outage over the weekend but the Davis consol should have run on battery power. Which i powered the PC back up on Monday i find that the log has jumped straight to monday with zero archive recorded. I've zipped the MXdiag file from today. I believe i see some lines which seem to say it found past data. But doesn't log it. Seems like there may be an issues with there being no response to the time that is sent to the station ? "No ACK in response to sending date and time ". I'm running Linux Mint 19 Cinnamon 3.8.9

thanks in advance.

orfeo



2019-10-07 13:35:59.228 Last update time = 2019-10-04 8:45:00 PM
2019-10-07 13:35:59.228 Reading console time
2019-10-07 13:35:59.829 Console clock: 2019-10-07 1:36:00 PM
2019-10-07 13:35:59.830 Reading history data from log files
2019-10-07 13:35:59.830 Loading last N hour data from data logs: 2019-10-04 8:45:00 PM
2019-10-07 13:35:59.851 Loaded 13 entries to last hour data list
2019-10-07 13:35:59.867 Loaded 37 entries to last 3 hour data list
2019-10-07 13:35:59.884 Loaded 289 entries to graph data list
2019-10-07 13:36:00.052 Loaded 2017 entries to recent data list
2019-10-07 13:36:00.061 Loaded 29 entries to daily data list
2019-10-07 13:36:00.061 Reading archive data from logger
2019-10-07 13:36:00.068 Get Archive Data
2019-10-07 13:36:00.068 Rollover hour = 0
2019-10-07 13:36:00.068 Last Archive Date: 2019-10-04 8:45:00 PM
2019-10-07 13:36:00.068 Date: 10052
2019-10-07 13:36:00.068 Time: 2045
2019-10-07 13:36:00.083 629 web tags initialised
2019-10-07 13:36:00.092 HTML root path = /home/User/Documents/CumulusMX/interface
2019-10-07 13:36:00.469 Sending DMPAFT
2019-10-07 13:36:00.669 Received response to DMPAFT, sending start date and time
2019-10-07 13:36:00.669 Sending: 44-27-FD-07-B2-41
2019-10-07 13:36:00.870 No ACK in response to sending date and time
2019-10-07 13:36:00.870 Get Archive Data
2019-10-07 13:36:00.870 Rollover hour = 0
2019-10-07 13:36:00.870 Last Archive Date: 2019-10-04 8:45:00 PM
2019-10-07 13:36:00.870 Date: 10052
2019-10-07 13:36:00.870 Time: 2045
2019-10-07 13:36:02.871 Sending DMPAFT
2019-10-07 13:36:03.071 Received response to DMPAFT, sending start date and time
2019-10-07 13:36:03.071 Sending: 44-27-FD-07-B2-41
2019-10-07 13:36:03.271 No ACK in response to sending date and time
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 5685
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Cumulus dont read archive data

Post by mcrossley » Mon 07 Oct 2019 3:41 pm

You need to upgrade to b3052 - I improved the VP2 serial protocol handing to try and avoid these sorts of issues.

Post Reply