Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.1.2 build 3055 - 4 November 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Incorrect Reporting to PWS

Discussion specific to Davis weather stations
GiveToLive
Posts: 18
Joined: Tue 26 Mar 2013 5:49 pm
Weather Station: Davis Vantage Pro2
Operating System: Win 7
Location: Alvarado, TX USA
Contact:

Re: Incorrect Reporting to PWS

Post by GiveToLive » Mon 01 Dec 2014 6:11 pm

Ok, I will give it some time to settle down.

Thanks again.
Glenn

To give is to live.

www.give2live.info/Weather/

User avatar
mcrossley
Posts: 5738
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Incorrect Reporting to PWS

Post by mcrossley » Tue 02 Dec 2014 9:34 am

And it ran OK until about 1.30am your local time, when suddenly a second upload started with static stale data. (same on PWS as well).
Capture.PNG
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Incorrect Reporting to PWS

Post by steve » Tue 02 Dec 2014 9:52 am

Perhaps it's not a second instance; perhaps a single instance is alternately getting correct and incorrect data from somewhere. It looks like you have WU rapid fire turned on again?

If you have a debug.log file in the Cumulus folder, delete it. Then turn on debug logging. Wait 20 minutes, and then turn the debug log off. Zip up the diags folder, add the debug.log file to the zip file, and then attach it here. I'll see if I can work out what's going on.

What type of logger do you have (serial/USB/IP)? You're not running any other software with the station at the same time as Cumulus, e.g. Weatherlink?
Steve

User avatar
mcrossley
Posts: 5738
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Incorrect Reporting to PWS

Post by mcrossley » Tue 02 Dec 2014 10:02 am

Looking at this more carefully, the change happened at midnight. The temp suddenly jumped from 4.8 to 0.8, the 'second' reading has varied (0.8 - 0.9) so your theory of locking on to another ISS looks plausible. At 1:45 it got an 'original' reading again.

User avatar
mcrossley
Posts: 5738
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Incorrect Reporting to PWS

Post by mcrossley » Tue 02 Dec 2014 10:32 am

Nope wrong! The PWS data is more detailed, the 'static' reading is the 4.8 °C one, that kicked in at around 4pm on the 1st.

Code: Select all

	01:00 PM	5.3°C	-4.0°C	51%	17.7 kmh 29.0 kmh	1030.1 mb
	01:15 PM	5.3°C	-4.6°C	49%	19.3 kmh 32.2 kmh	1030.1 mb
	01:30 PM	5.4°C	-4.4°C	49%	19.3 kmh 35.4 kmh	1030.1 mb
	01:45 PM	5.3°C	-5.2°C	47%	19.3 kmh 29.0 kmh	1030.1 mb
	02:00 PM	5.6°C	-4.8°C	47%	20.9 kmh 35.4 kmh	1029.8 mb
	02:15 PM	5.7°C	-4.8°C	47%	17.7 kmh 30.6 kmh	1029.8 mb
	02:30 PM	5.6°C	-4.8°C	47%	19.3 kmh 29.0 kmh	1029.8 mb
	02:45 PM	5.4°C	-4.7°C	48%	19.3 kmh 33.8 kmh	1029.8 mb
	03:00 PM	5.2°C	-4.9°C	48%	16.1 kmh 27.4 kmh	1029.8 mb
	03:15 PM	5.1°C	-5.1°C	48%	19.3 kmh 32.2 kmh	1030.1 mb
	03:30 PM	4.8°C	-5.3°C	48%	19.3 kmh 30.6 kmh	1029.8 mb
>	04:00 PM	4.8°C	-5.3°C	48%	16.1 kmh 20.9 kmh	1030.1 mb
>	04:15 PM	4.8°C	-5.3°C	48%	16.1 kmh 20.9 kmh	1030.1 mb
	04:30 PM	4.2°C	-5.6°C	49%	17.7 kmh 29.0 kmh	1031.2 mb
>	04:45 PM	4.8°C	-5.3°C	48%	16.1 kmh 20.9 kmh	1030.1 mb
>	05:00 PM	4.8°C	-5.3°C	48%	16.1 kmh 20.9 kmh	1030.1 mb
	05:15 PM	3.8°C	-5.4°C	51%	12.9 kmh 24.1 kmh	1031.2 mb
	05:30 PM	3.6°C	-5.3°C	52%	11.3 kmh 20.9 kmh	1031.2 mb
	05:45 PM	3.5°C	-5.4°C	52%	12.9 kmh 24.1 kmh	1031.2 mb
	06:00 PM	3.4°C	-5.6°C	52%	14.5 kmh 22.5 kmh	1031.2 mb
	06:15 PM	3.3°C	-5.7°C	52%	14.5 kmh 24.1 kmh	1031.2 mb
	06:30 PM	3.2°C	-5.8°C	52%	11.3 kmh 22.5 kmh	1031.5 mb
	06:45 PM	2.5°C	-5.9°C	54%	8.0 kmh N16.1 kmh	1031.5 mb
>	07:00 PM	4.8°C	-5.3°C	48%	16.1 kmh 20.9 kmh	1030.1 mb
>	07:15 PM	4.8°C	-5.3°C	48%	16.1 kmh 20.9 kmh	1030.1 mb
	07:30 PM	1.9°C	-5.7°C	57%	9.7 kmh 17.7 kmh	1031.8 mb
	07:45 PM	2.2°C	-5.7°C	56%	11.3 kmh 22.5 kmh	1031.8 mb
	08:00 PM	2.1°C	-5.8°C	56%	12.9 kmh 22.5 kmh	1031.8 mb
	08:15 PM	2.1°C	-6.1°C	55%	12.9 kmh 22.5 kmh	1031.8 mb
	08:30 PM	2.0°C	-5.9°C	56%	12.9 kmh 20.9 kmh	1031.8 mb
	08:45 PM	1.9°C	-5.7°C	57%	12.9 kmh 20.9 kmh	1031.8 mb
>	09:00 PM	4.8°C	-5.3°C	48%	16.1 kmh 20.9 kmh	1030.1 mb
	09:15 PM	1.6°C	-5.8°C	58%	11.3 kmh 20.9 kmh	1032.2 mb
>	09:30 PM	4.8°C	-5.3°C	48%	16.1 kmh 20.9 kmh	1030.1 mb
>	09:45 PM	4.8°C	-5.3°C	48%	16.1 kmh 20.9 kmh	1030.1 mb
	10:00 PM	1.3°C	-6.3°C	57%	12.9 kmh 22.5 kmh	1031.8 mb
	10:15 PM	1.3°C	-6.3°C	57%	11.3 kmh 17.7 kmh	1031.8 mb
	10:30 PM	1.2°C	-6.4°C	57%	12.9 kmh 22.5 kmh	1031.8 mb
>	10:45 PM	4.8°C	-5.3°C	48%	16.1 kmh 20.9 kmh	1030.1 mb
>	11:00 PM	4.8°C	-5.3°C	48%	16.1 kmh 20.9 kmh	1030.1 mb
	11:15 PM	0.9°C	-6.6°C	57%	11.3 kmh 19.3 kmh	1031.8 mb
	11:30 PM	0.9°C	-6.7°C	57%	12.9 kmh 20.9 kmh	1031.8 mb
	11:45 PM	0.8°C	-6.7°C	57%	11.3 kmh 24.1 kmh	1031.8 mb

GiveToLive
Posts: 18
Joined: Tue 26 Mar 2013 5:49 pm
Weather Station: Davis Vantage Pro2
Operating System: Win 7
Location: Alvarado, TX USA
Contact:

Re: Incorrect Reporting to PWS

Post by GiveToLive » Wed 03 Dec 2014 3:08 am

I decided to backup the data files, delete everything, scrub the registry and do a clean install, then restore data. Seems to be working now.
Glenn

To give is to live.

www.give2live.info/Weather/

Post Reply