Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.4.0 (build 3064) - 19 February 2020.
    Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

    See the Wiki for downloading either version.

    Cumulus crashing after a few days offline

    Discussion specific to Oregon Scientific weather stations
    Post Reply
    johndavidson
    Posts: 17
    Joined: Tue 21 Aug 2012 1:35 am
    Weather Station: WMR200
    Operating System: Windows 7
    Location: New Norfolk, Tasmania, Australia
    Contact:

    Cumulus crashing after a few days offline

    Post by johndavidson » Tue 09 Apr 2013 12:51 pm

    I've had cumulus offline for a few days while I moved sensors, station, computer, etc. The WMR200 station has kept logging during this period.

    Today I restarted Cumulus. Everything appeared to be OK, and Cumulus started downloading the historical data. However, at a certain point it crashed. The bugreport file is attached.

    Restarting Cumulus and restarting the PC has not helped. Cumulus continues to crash while reading the historical data.

    I have downloaded and installed a new copy of Cumulus (I was already running the latest stable version), but the problem persists.
    You do not have the required permissions to view the files attached to this post.

    johndavidson
    Posts: 17
    Joined: Tue 21 Aug 2012 1:35 am
    Weather Station: WMR200
    Operating System: Windows 7
    Location: New Norfolk, Tasmania, Australia
    Contact:

    Re: Cumulus crashing after a few days offline

    Post by johndavidson » Tue 09 Apr 2013 1:05 pm

    Some additional information:

    I've installed the latest beta, and the problem persists.

    However, I have thought of something. The historical download stops at data with the time stamp "2013-04-07 07:42". This is the morning after the change over from daylight savings, and may correspond to the time I changed the station's time back one hour for the end of daylight savings. Could this have caused the problem?

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Cumulus crashing after a few days offline

    Post by steve » Tue 09 Apr 2013 1:13 pm

    It's crashing in a library routine I use which converts 'station' pressure to 'altimeter' pressure. It's presumably getting an odd pressure reading which causes an exception in the mathematical routines. Unfortunately I can't think of a work around for you, I'll need to add code to 1.9.4 to trap the exception. It shouldn't take long.
    Steve

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Cumulus crashing after a few days offline

    Post by steve » Tue 09 Apr 2013 2:23 pm

    I've uploaded a new build of 1.9.4 which should stop the crash. I imagine you'll have a bad pressure reading to clean up. I'm interested to know what it turns out to be, so perhaps I can filter it out in future.
    Steve

    johndavidson
    Posts: 17
    Joined: Tue 21 Aug 2012 1:35 am
    Weather Station: WMR200
    Operating System: Windows 7
    Location: New Norfolk, Tasmania, Australia
    Contact:

    Re: Cumulus crashing after a few days offline

    Post by johndavidson » Tue 09 Apr 2013 2:30 pm

    Thanks for the quick fix Steve. This seems to have worked. Cumulus is downloading the historical data now. I'll have a look at the pressure readings once it is complete and let you know what I see.

    johndavidson
    Posts: 17
    Joined: Tue 21 Aug 2012 1:35 am
    Weather Station: WMR200
    Operating System: Windows 7
    Location: New Norfolk, Tasmania, Australia
    Contact:

    Re: Cumulus crashing after a few days offline

    Post by johndavidson » Tue 09 Apr 2013 3:48 pm

    I've got a gap in the data 07:32 to 07:44 on the 7th, which is where the data upload stopped before at 07:42.

    Apart from that, all looks good.

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Cumulus crashing after a few days offline

    Post by steve » Tue 09 Apr 2013 4:00 pm

    You have a bogus low pressure reading of 832 hPa at 07:44 on the 7th April.
    Steve

    Post Reply