Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.14.0 (build 3159) - 04 December 2021

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

If you are interested in supporting Cumulus then maybe you would like to contribute to the maintenance of the Wiki? This need not take hours of your time - just a half hour here and there can make a big difference, particularly if many people are doing this. Any contributions are very welcome, whether they involve new content or editing of existing content. It will be very helpful to current and future users of Cumulus software if the Wiki is kept well-maintained and current. If you are interested then please contact forum user saratogaWX and ask for a Wiki account.

CUtils v673

Discussion of the Cumulusutils tool and website generator.

Moderator: HansR

Post Reply
AndyKF650
Posts: 167
Joined: Thu 20 Aug 2020 8:35 am
Weather Station: Davis VP2 Plus
Operating System: RPiv4 Debian Bullseye Windows 11
Location: Jersey Channel Islands
Contact:

CUtils v673

Post by AndyKF650 »

Hi Hans

A quick note to say the new version was loaded and works after a bit of a fiddle.

Usually a new version just requires the download and extract to the utils folder and then run the Website upgrade. This time when I looked at my website, after the initial download and run, the programme was not working.

To get the system running I stopped CMX and rebooted the RPi restarted CMX and reran the Website update, this then left everything running perfectly. :)

As an aside surely since Windows 7 is so out of date and Microsoft are not supporting it why is it taking up your valuable development time?

User avatar
HansR
Posts: 2661
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Buster/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: CUtils v673

Post by HansR »

OK, thanks for the warning but it is a bit of a surprise to see that on an RPi (I did not have that issue). But I do not regard it as a real problem because apparently it worked after the reboot (fortunately... pfff...). I assume that if you say you extract to the utils directory that also the bin and the other dirs get overwritten?

And yes, Windows 7 is out of date but apparently it is still working and - very important - CMX itself is still running on that platform, so for now it must be accepted.
For version 7 (coming up in near future depending on a lot of things so timing unknown) it may be another story, but if CMX runs on a system, CUtils must be able to run as well.
Hans

https://meteo-wagenborgen.nl
https://meteo-wagenborgen.nl/CMX4/index.html
Cumulus build 3149 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspbian 5.10.52-v7+ ● Mono 6.12.0.122

User avatar
PaulMy
Posts: 2834
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: CUtils v673

Post by PaulMy »

EDIT... had referred to wrong version:
Updated to v673 v674 and all fine on Windows 10.
I had not done the moon settings to true in doing the manual website run, but have now edited cumulusutils.ini and the next run will be with the UseCMXMoonImage=true

Enjoy,
Paul
Last edited by PaulMy on Mon 22 Nov 2021 3:42 pm, edited 1 time in total.

AndyKF650
Posts: 167
Joined: Thu 20 Aug 2020 8:35 am
Weather Station: Davis VP2 Plus
Operating System: RPiv4 Debian Bullseye Windows 11
Location: Jersey Channel Islands
Contact:

Re: CUtils v673

Post by AndyKF650 »

Have just run the upgrade v674 and all is good.

The moon image has been set to CMXMoonimage=true and my previous work around for the moon image removed from CUsermenu. The appropriate panel in cumulusutils.ini needs to have Panelxx=LunarDisc. Re running the Website update gets the appropriate panel with a CMX Moon Image.

Great job Hans much better than my effort :clap:

Post Reply