Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.10.2 (build 3117) - 02 March 2021 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this Wiki link to Download the Software (Cumulus MX / Cumulus 1 and other related items).

Trying to set up cumulusutils

Discussion of the Cumulusutils tool and website generator.

Moderator: HansR

Post Reply
rich_c
Posts: 37
Joined: Wed 15 Oct 2008 5:35 am
Location: Ilfracombe UK
Contact:

Trying to set up cumulusutils

Post by rich_c »

Having trouble running the command
The command when cumulusutils.exe is in the CumulusMX directory is:
.\cumulusutils.exe
The command when cumulusutils.exe is in the utils\bin directory is:
utils\bin\cumulusutils.exe
Screenshot 2021-02-11 183330.png
have followed the instruction up to the above. Tried running on pi and within windows with the same result
Cumulusmx is up and running on my pi with no problems not sure where to go from here as i am new to using pi software
have tried running each command separately only showing both option in the command attachment so you can see
Thanks
You do not have the required permissions to view the files attached to this post.
Last edited by rich_c on Thu 11 Feb 2021 7:08 pm, edited 1 time in total.

freddie
Posts: 1147
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2
Operating System: GNU/Linux Ubuntu 20.04 LXC
Location: Alcaston, Shropshire, UK
Contact:

Re: Trying to set up cumulusutils

Post by freddie »

You look like you are doing the commands in /home/pi. You need to cd to the directory where CumulusMX is installed - and then run the commands.
Freddie
Image

sutne
Posts: 145
Joined: Sun 14 Oct 2012 4:23 pm
Weather Station: Oregon Scientific WMR100
Operating System: Raspbian Buster
Location: Rjoanddalen, Voss, Norway
Contact:

Re: Trying to set up cumulusutils

Post by sutne »

And in linux you must use slash / not the backslash:

In the CumulusMX directory type

utils/bin/cumulusutils.exe All

rich_c
Posts: 37
Joined: Wed 15 Oct 2008 5:35 am
Location: Ilfracombe UK
Contact:

Re: Trying to set up cumulusutils

Post by rich_c »

thanks to you both for helping i am now getting the following

pi@raspberrypi:~/CumulusMX $ cd ~/CumulusMX
pi@raspberrypi:~/CumulusMX $ utils/bin/cumulusutils.exe All
bash: utils/bin/cumulusutils.exe: Permission denied
pi@raspberrypi:~/CumulusMX $


Thanks

sutne
Posts: 145
Joined: Sun 14 Oct 2012 4:23 pm
Weather Station: Oregon Scientific WMR100
Operating System: Raspbian Buster
Location: Rjoanddalen, Voss, Norway
Contact:

Re: Trying to set up cumulusutils

Post by sutne »

The file does not have execute permission
From CumuluxMX directory type

sudo chmod 755 utils/bin/cumulusutils.exe

rich_c
Posts: 37
Joined: Wed 15 Oct 2008 5:35 am
Location: Ilfracombe UK
Contact:

Re: Trying to set up cumulusutils

Post by rich_c »

Thanks its now running

User avatar
HansR
Posts: 1874
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Trying to set up cumulusutils

Post by HansR »

@rich_c: Are you getting anywhere? If I may give some advice: as a beginner it is best to either start with only one module (e.g. top10) and see how that works out (it is less confusing because there is only one output) or start with the website with automated FTP because that gives you immediate visual feedback of how good things are going.

Do check the logfile and possibly feedback here.
Hans

https://meteo-wagenborgen.nl
Cumulus build 3116 ● Davis Vantage Pro 2+ ● RPi 3B+ ● Raspbian 5.10.11-v7+ ● 5.18.0.240 (Debian 5.18.0.240)

rich_c
Posts: 37
Joined: Wed 15 Oct 2008 5:35 am
Location: Ilfracombe UK
Contact:

Re: Trying to set up cumulusutils

Post by rich_c »

Hans thanks working my way through the setup

rich

Post Reply