Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.9.1 (build 3096) - 31 October 2020 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this Wiki link to Download the Software (Cumulus MX / Cumulus 1 and other related items).

Version 4.7.0 error

Discussion of the Cumulusutils tool and website generator.

Moderator: HansR

User avatar
HansR
Posts: 1536
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Version 4.7.0 error

Post by HansR »

@JUMAVISA:
You are in the correct thread because of a side effect of what was happening with 4.7.0
I will release 4.6.3 to correct all that.
https://meteo-wagenborgen.nl / Cumulus 3.9.1 (build: 3096)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Buster / 5.4.51-v7+ armv7l
Mono JIT compiler version 6.12.0.90 (tarball Fri Sep 4 14:21:54 UTC 2020)

JUMAVISA
Posts: 11
Joined: Tue 26 May 2020 10:24 pm
Weather Station: Davis Vantage Vue
Operating System: Windows 10 Pro

Re: Version 4.7.0 error

Post by JUMAVISA »

I have tried to install the new version of cumulusUtils (4.6.3)

But an error occurs and the application is suspended:

Code: Select all

[Window Title]
Unhandled Exception: System.IO.FileLoadException: Could not load file or assembly 'FluentFTP, Version = 33.0.2.0, Culture = neutral, PublicKeyToken = f4af092b1d8df44f' or one of its dependencies. The assembly manifest definition does not match the reference to the assembly. (Exception from HRESULT: 0x80131040)
    in CumulusUtils.CMXutils. <Main> d__143.MoveNext ()
    at System.Runtime.CompilerServices.AsyncTaskMethodBuilder.Start [TStateMachine] (TStateMachine & stateMachine)
    in CumulusUtils.CMXutils.Main (String [] args)
    in CumulusUtils.CMXutils. <Main> (String [] args)
No new log file produced

User avatar
HansR
Posts: 1536
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Version 4.7.0 error

Post by HansR »

Yes. Correction is online. Try again please.
Let me know if successful.
https://meteo-wagenborgen.nl / Cumulus 3.9.1 (build: 3096)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Buster / 5.4.51-v7+ armv7l
Mono JIT compiler version 6.12.0.90 (tarball Fri Sep 4 14:21:54 UTC 2020)

User avatar
HansR
Posts: 1536
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Version 4.7.0 error

Post by HansR »

Any other results from 4.6.3?
https://meteo-wagenborgen.nl / Cumulus 3.9.1 (build: 3096)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Buster / 5.4.51-v7+ armv7l
Mono JIT compiler version 6.12.0.90 (tarball Fri Sep 4 14:21:54 UTC 2020)

User avatar
kocher
Posts: 211
Joined: Sat 19 Apr 2014 7:57 pm
Weather Station: Davis Vantage Pro2+
Operating System: Windows 10
Location: San Sebastian - Spain
Contact:

Re: Version 4.7.0 error

Post by kocher »

I just installed version 4.6.3 and everything seems to work fine. :clap:

Even the FWI (it had stopped yesterday) seems to work:

http://kocher.es/cumulusMX/FWI/

I think everything is fine

I attach the log file
You do not have the required permissions to view the files attached to this post.
Image

JUMAVISA
Posts: 11
Joined: Tue 26 May 2020 10:24 pm
Weather Station: Davis Vantage Vue
Operating System: Windows 10 Pro

Re: Version 4.7.0 error

Post by JUMAVISA »

Good afternoon Hans, I just downloaded this version 4.6.3 and it has worked very well, I have not appreciated any errors, I am very grateful for the great attention given.
Thanks a lot

User avatar
HansR
Posts: 1536
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Version 4.7.0 error

Post by HansR »

Well, @kocher, @JUMAVISA, that makes me happy. Thanks :D
But not totally happy because apparently it does not work in Poland. :groan:

Until everybody has a working version it continues...
https://meteo-wagenborgen.nl / Cumulus 3.9.1 (build: 3096)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Buster / 5.4.51-v7+ armv7l
Mono JIT compiler version 6.12.0.90 (tarball Fri Sep 4 14:21:54 UTC 2020)

User avatar
PaulMy
Posts: 2295
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: Version 4.7.0 error

Post by PaulMy »

v4.6.3 is working for me in Edge, also in FF and Chrome www.komokaweather.com/cumulusmxwll/index.html

Enjoy,
Paul

User avatar
HansR
Posts: 1536
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Version 4.7.0 error

Post by HansR »

Thank you Paul, this brings back some confidence ;)
https://meteo-wagenborgen.nl / Cumulus 3.9.1 (build: 3096)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Buster / 5.4.51-v7+ armv7l
Mono JIT compiler version 6.12.0.90 (tarball Fri Sep 4 14:21:54 UTC 2020)

User avatar
rogerthn
Posts: 311
Joined: Thu 11 Apr 2013 6:31 pm
Weather Station: Ecowitt GW1000/GW1003
Operating System: Raspberry Pi OS Lite Buster
Location: Trollhättan Sweden
Contact:

Re: Version 4.7.0 error

Post by rogerthn »

Version 4.7.0 is working after update in cumulusutils.ini as below

Code: Select all

diff cumulusutils.ini cumulusutils.ini_2020-11-13
17c17
< UploadDir=cumulusutils
---
> UploadDir=/cumulusutils
Version 4.6.3 needs to have the leading /
Image

User avatar
HansR
Posts: 1536
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Version 4.7.0 error

Post by HansR »

Now I am confused.
Can you send me the log and the inifile? Thnx.
https://meteo-wagenborgen.nl / Cumulus 3.9.1 (build: 3096)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Buster / 5.4.51-v7+ armv7l
Mono JIT compiler version 6.12.0.90 (tarball Fri Sep 4 14:21:54 UTC 2020)

User avatar
rogerthn
Posts: 311
Joined: Thu 11 Apr 2013 6:31 pm
Weather Station: Ecowitt GW1000/GW1003
Operating System: Raspberry Pi OS Lite Buster
Location: Trollhättan Sweden
Contact:

Re: Version 4.7.0 error

Post by rogerthn »

HansR wrote:
Sat 14 Nov 2020 9:21 am
Now I am confused.
Can you send me the log and the inifile? Thnx.
PM under way
Image

User avatar
HansR
Posts: 1536
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Version 4.7.0 error

Post by HansR »

OK. I can't fully explain it but afaiac it is problem solved.
Apparently I did something and forgot in the turmoil of the FTP modifications. Anyway, I'll add it to the release notes and I'll the check manual to make sure this is clear.

The great thing is that RPis where`the user runs its own Apache server this is no longer a problem. 8-)
https://meteo-wagenborgen.nl / Cumulus 3.9.1 (build: 3096)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Buster / 5.4.51-v7+ armv7l
Mono JIT compiler version 6.12.0.90 (tarball Fri Sep 4 14:21:54 UTC 2020)

User avatar
HansR
Posts: 1536
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Version 4.7.0 error

Post by HansR »

The other name for FTP is Pandora's Box.

The new 4.7.0 version is OK but there seems to be an issue with the following two points:
  1. FTPS may not work on some servers. Especially from windows where you can get the message "A call to SSPI failed, see inner exception." I am investigating but if it occurs to you, please notify and use fall back to plain old FTP.
  2. In some situations when waiting for a lock file, the new provider returns another than expected answer (other relative to the previous provider). I am investigating. If it occurs to you please notify and I will manually repair and investigate.
  3. And I can add, that with the current configuration it is very likely that Windows 7 installations will fail while creating the map because the fetch of the Maps database from https://meteo-wagenborgen can not be handled. It is unknown if there exists a .NET update for Win 7 which solves this issue.
https://meteo-wagenborgen.nl / Cumulus 3.9.1 (build: 3096)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Buster / 5.4.51-v7+ armv7l
Mono JIT compiler version 6.12.0.90 (tarball Fri Sep 4 14:21:54 UTC 2020)

sutne
Posts: 112
Joined: Sun 14 Oct 2012 4:23 pm
Weather Station: Oregon Scientific WMR100
Operating System: Raspbian Buster
Location: Rjoanddalen, Voss, Norway
Contact:

Re: Version 4.7.0 error

Post by sutne »

Version 4.7.0 installed.
Plain old FTP, so no problems.

http://www.rjoandveret.no/utils/index.html

Post Reply