Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.9.1 (build 3096) - 31 October 2020 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this Wiki link to Download the Software (Cumulus MX / Cumulus 1 and other related items).

Cumulusutils with latest CumulusMX v3.9.1

Discussion of the Cumulusutils tool and website generator.

Moderator: HansR

Post Reply
User avatar
PaulMy
Posts: 2292
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Cumulusutils with latest CumulusMX v3.9.1

Post by PaulMy »

@Hans in another thread you commented
Deleting the Newtonsoft.Json.dll was advised but I sincerely hope it is not a requirement because CumulusUtils still depends on it.
Just want to tell you that latest Cumulusutils v4.5.5 does work fine with latest CumulusMX v3.9.1 which still has the Newtonsoft.Json.dll file in CumulusMX folder.
I usually do a full new version copy-in overtop of existing, except \Reports and \web folders, and then check file dates to see which are updated, or not updated, so in the latest v3.9.1 update the old Newtonsoft.Json.dll was left intact. I presume for new installation not including the Newtonsoft.Json.dll may then cause an issue for Cumulusutils.

As an additional comment I see that now after our change from daylight savings to standard time my Cumulusutils page Station time as an hour ahead and Browser time correct. Have I forgotten a setting somewhere in Cumulusutils?

Enjoy,
Paul

User avatar
HansR
Posts: 1536
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Cumulusutils with latest CumulusMX v3.9.1

Post by HansR »

@PaulMy: You actually make two points here so I split the answer in two ;)
  1. On Newtonsoft.Json.dll
    Yes, that, beside the comment you point at, I also made a note in the release thread. So yes, if the Newtonsoft dll is not present CumulusUtils will not run. If you leave it where it is (or copy it to the new install) you will not have a problem. It will be resolved in the future as I plan too catch up with CMX to use the new JSON library (but I am not in a hurry here, some other things I am working on right now). In general I intend to use the same libraries CMX uses to minimise pollution of the CMX directory.
  2. On the Clocks
    I did notice an issue with the clocks which caused me to release 4.5.5 in the first place. That issue was caused by an apparent difference in implementation in Windows .NET and Mono on the RPi of two system calls regarding time differences. I described the issue extensively in the the release post. After 4.5.5 it seems to be running OK everywhere.
    Now for your system, if I look at it from my place, through my browser, I see a GMT-5 time of 11h39 versus 17h39 of my local (browser) time and UTC being 16h39. I think that is correct. So the question is what is wrong when all other machines I can see are displaying correct times now. What does your computer time say? Is the GMT-5 correct? Could you post a screenshot of the clocks section (possibly with the computer clock on the bar in it)? Are you sure you did a CTRL-F5 for a cache refresh?
https://meteo-wagenborgen.nl / Cumulus 3.9.1 (build: 3096)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Buster / 5.4.51-v7+ armv7l
Mono JIT compiler version 6.12.0.90 (tarball Fri Sep 4 14:21:54 UTC 2020)

User avatar
PaulMy
Posts: 2292
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: Cumulusutils with latest CumulusMX v3.9.1

Post by PaulMy »

Thanks Hans,
I had noticed it yesterday as well. I know caching can be an issue and I usually open the website with komokaweather.com/cumulusutils/index.html?yyyymmddtttt to overcome the caching (F5 or Ctrl F5 most of the time doesn't work) and then check the pwsFWI report to see if the dates are correct. However, sometimes one just needs to walk away and give the gremlins time to go away as well... After being away for a few hours I just did a new website run, and times are now correct and no more issue. We are now UTC -5.

Enjoy,
Paul

User avatar
HansR
Posts: 1536
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Cumulusutils with latest CumulusMX v3.9.1

Post by HansR »

Uff... :roll:
I was already afraid of something else I had overlooked with those clocks.
https://meteo-wagenborgen.nl / Cumulus 3.9.1 (build: 3096)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Buster / 5.4.51-v7+ armv7l
Mono JIT compiler version 6.12.0.90 (tarball Fri Sep 4 14:21:54 UTC 2020)

Post Reply