Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.6.10 (build 3086) - 24 June 2020 (please see important announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

See the Wiki to download the software or click on the Downloads link in the Forum Banner.

Installation

Discussion of the Cumulusutils tool and website generator.

Moderator: HansR

User avatar
kocher
Posts: 181
Joined: Sat 19 Apr 2014 7:57 pm
Weather Station: Davis Vantage Pro2+
Operating System: Windows 10
Location: San Sebastian - Spain
Contact:

Re: Installation

Post by kocher »

Greetings Hans

I have installed version 370.

Since I have the WXSIM forecast system, I have tried to add it to the template; but since i have done so, the template has stopped updating and working:

http://kocher.es/cumulusMX/FWI/

The changes I have made to the "cumulusutils.ini" file are as follows:
[Forecasts]
SevenDayPredictionURL = http://api.yourweather.co.uk/index.php? Api_lang = en & locality = 3921 & affiliate_id = xxxxxxxxxxxx
ForecastSystem = WXSIM
NorwegianURL =
WXsimURL = http://kocher.es/wxsim_3en1/meteograma.php
I don't know what I've done wrong :groan:
Image

User avatar
kocher
Posts: 181
Joined: Sat 19 Apr 2014 7:57 pm
Weather Station: Davis Vantage Pro2+
Operating System: Windows 10
Location: San Sebastian - Spain
Contact:

Re: Installation

Post by kocher »

Perhaps this update causes the error.

I thought back to the previous version V369
Image

User avatar
HansR
Posts: 1090
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Installation

Post by HansR »

Hi Javier, I can't imagine the WXSIM forecast causes an error. It actually only creates an iframe in the forecast.txt file with the url you supply. So that would be:

Code: Select all

<iframe src="http://kocher.es/wxsim_3en1/meteograma.php" width='1000' height='700' frameborder='0'></iframe>
Can't image that stopping the system.
So, because you took yours off-line, let's see what the others say.
Well, my neighbour 't Zandt is running it and so is Segur le Chateau. Maybe you should try again.
https://meteo-wagenborgen.nl / Cumulus 3.6.8 (build: 3084)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Linux 10 (buster) / 4.19.118-v7+ armv7l
Mono JIT compiler version 6.8.0.123 (tarball Tue May 12 15:31:43 UTC 2020)

User avatar
meteo19
Posts: 23
Joined: Tue 03 May 2016 8:13 pm
Weather Station: Davis VP2
Operating System: Microsoft Windows 7 Pro
Location: Ségur-Le-Château, France
Contact:

Re: Installation

Post by meteo19 »

Hi Hans and Javier, I think the problem and MX 3.6.4 (build 3080) I had the same problem I just went back to 3079 and everything is back in order. The thread on the subject(viewtopic.php?f=40&t=18139). Sorry for my English .

Patrick
http://www.meteosegur.fr/CU_MX/utils/index.html
Image

User avatar
HansR
Posts: 1090
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Installation

Post by HansR »

Aha... thanks Patrick.
We have to wait for a solution there then before I start staring in a black hole.
https://meteo-wagenborgen.nl / Cumulus 3.6.8 (build: 3084)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Linux 10 (buster) / 4.19.118-v7+ armv7l
Mono JIT compiler version 6.8.0.123 (tarball Tue May 12 15:31:43 UTC 2020)

User avatar
kocher
Posts: 181
Joined: Sat 19 Apr 2014 7:57 pm
Weather Station: Davis Vantage Pro2+
Operating System: Windows 10
Location: San Sebastian - Spain
Contact:

Re: Installation

Post by kocher »

Greetings Patrick

Thank you very much for your timely explanation.
I did indeed update cumulsMX to version 3080 yesterday, but it had not touched any problems.
Marka is already studying the matter.

@Hans, sorry for attributing the problem to your application :oops:

Javier
Image

User avatar
kocher
Posts: 181
Joined: Sat 19 Apr 2014 7:57 pm
Weather Station: Davis Vantage Pro2+
Operating System: Windows 10
Location: San Sebastian - Spain
Contact:

Re: Installation

Post by kocher »

Good morning Hans :)

A new enthusiast has joined us, as you can see on the map; This is Juan María, who has his station located in Sabadel Badalona (Catalonia, Spain).

Well, I have tried to help you as much as I can but, despite the fact that the data is updated perfectly, this does not happen with gauges. Since the realtime files are in the same location, I can't figure out what's wrong.
I just instructed you (hopefully it will soon) to disable on cumulusMX:
- Include Standard files
- Include Moon Image file

and to activate:
- Include graph data files
- UTF-8 encoding
- Enable Realtime
- Enable realtime FTP
- Enable Realtime.txt FTP
- Enable Realtimegauges.txt FTP

Reading his instructions I have also seen the possible "Caching" problem and I can not think of anything else. :bash:

What do you think?
Last edited by kocher on Sun 31 May 2020 11:23 am, edited 2 times in total.
Image

User avatar
HansR
Posts: 1090
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Installation

Post by HansR »

Good morning Javier,

Thanks very much for being ambassador for CumulusUtils :clap: :D and welcome to Juan María :!:
I know that area around Barcelona pretty well, lived just north of the Pyrenees for 11 years.

The installation looks good and I don't think there is an error in that but it is related to the modification of the gauges which I just introduced.
I just put out version 3.7.3 and I suggest to install that (copy all files to the utils directory and CumulusUtils to the cumulus directory, and run Website without thrifty).
If the problem persists - that would be unexpected - please send me the cumulusutils.ini and the logfile of the complete run (notice the logfile system has changed recently).

Your instructions to Juan Maria are correct.
I'll follow progress and can partially debug from here.

Does he speak English and can we contact directly? Or will you be the intermediate?
https://meteo-wagenborgen.nl / Cumulus 3.6.8 (build: 3084)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Linux 10 (buster) / 4.19.118-v7+ armv7l
Mono JIT compiler version 6.8.0.123 (tarball Tue May 12 15:31:43 UTC 2020)

User avatar
kocher
Posts: 181
Joined: Sat 19 Apr 2014 7:57 pm
Weather Station: Davis Vantage Pro2+
Operating System: Windows 10
Location: San Sebastian - Spain
Contact:

Re: Installation

Post by kocher »

Thank you very much for answering Hans

(Today has been very good weather in my area and we have taken the opportunity to go on a motorcycle through the small towns of the region). :D

Agree; I will get what you ask for and I will send it to you by email.

I think that Jose mari (diminutive of Jose María) does not speak English, although he defends himself with written English. I will gladly act as an intermediary (I do not speak English either, but I defend myself in technical written English.
I will talk to him and provide you with the information you need.

Thank you

Javier
Image

User avatar
kocher
Posts: 181
Joined: Sat 19 Apr 2014 7:57 pm
Weather Station: Davis Vantage Pro2+
Operating System: Windows 10
Location: San Sebastian - Spain
Contact:

Re: Installation

Post by kocher »

Hans

I think Juan Mari (and you) have achieved success:

http://www.meteobadalonaprogres.com/CumulusMX/nova/

Now there are only a few fringes left to leave everything nickel plated :clap: :clap: :clap: :clap:
Image

User avatar
HansR
Posts: 1090
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Installation

Post by HansR »

Hi Javier, it looks good, but really, unfortunately the correct gauges.js is not installed, so something went wrong.
I can see it in the debugger.
https://meteo-wagenborgen.nl / Cumulus 3.6.8 (build: 3084)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Linux 10 (buster) / 4.19.118-v7+ armv7l
Mono JIT compiler version 6.8.0.123 (tarball Tue May 12 15:31:43 UTC 2020)

User avatar
kocher
Posts: 181
Joined: Sat 19 Apr 2014 7:57 pm
Weather Station: Davis Vantage Pro2+
Operating System: Windows 10
Location: San Sebastian - Spain
Contact:

Re: Installation

Post by kocher »

Saludos Hans

Parece que sí está instalado el gauges.js:

http://www.meteobadalonaprogres.com/Cum ... /gauges.js
Image

User avatar
HansR
Posts: 1090
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Installation

Post by HansR »

Buenos dias Javier. En mi mejor español: si todo se ve bien, entonces es bueno :D
(gracias a Google ;) )
https://meteo-wagenborgen.nl / Cumulus 3.6.8 (build: 3084)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Linux 10 (buster) / 4.19.118-v7+ armv7l
Mono JIT compiler version 6.8.0.123 (tarball Tue May 12 15:31:43 UTC 2020)

User avatar
kocher
Posts: 181
Joined: Sat 19 Apr 2014 7:57 pm
Weather Station: Davis Vantage Pro2+
Operating System: Windows 10
Location: San Sebastian - Spain
Contact:

Re: Installation

Post by kocher »

:clap: :clap: :clap: :clap:
Image

User avatar
kocher
Posts: 181
Joined: Sat 19 Apr 2014 7:57 pm
Weather Station: Davis Vantage Pro2+
Operating System: Windows 10
Location: San Sebastian - Spain
Contact:

Re: Installation

Post by kocher »

Saludos a todos

I wanted to notify some curiosity, without major importance, that I see on my page:

1) changing the control panel shows the 12 gauges scattered: this occurs with the Chrome browser but not with Edge

2) In the 2 browsers, some gauges indicators are continuously oscillating between close values; for example the values of:
- Humidity
- Cloud height
- Solar radiation
- UV index
Image

Post Reply