Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.17.0 (build 3184) - 23 May 2022

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

If you are interested in supporting Cumulus then maybe you would like to contribute to the maintenance of the Wiki? This need not take hours of your time - just a half hour here and there can make a big difference, particularly if many people are doing this. Any contributions are very welcome, whether they involve new content or editing of existing content. It will be very helpful to current and future users of Cumulus software if the Wiki is kept well-maintained and current. If you are interested then please contact forum user saratogaWX and ask for a Wiki account.

CUtlsCharts definition error

Discussion of the Cumulusutils tool and website generator.

Moderator: HansR

Post Reply
AndyKF650
Posts: 303
Joined: Thu 20 Aug 2020 8:35 am
Weather Station: Davis VP2 Plus
Operating System: RPiv4 Debian Bullseye Windows 11
Location: Jersey Channel Islands
Contact:

CUtlsCharts definition error

Post by AndyKF650 »

Hi Hans

I am currently having issues with the chart definition using a Column rather than a SPline.

Initially I found it when I rebuilt my utils portion of my RPi and noticed that the Chart AllWindRun did not behave as expected and produced a single line on the RHS of the chart, a similar error was seen on all charts which used columns rather than SPlines. I changed the column definition to SPline and all charts worked fine but not what I wanted!

To check that the basic CUtils software was working I reinstalled the current version, ran the website update, changed a column to a SPline and ran the compileonly update and that did not solve the problem. Is this something you have noticed or is it just me changing my system again.

I have attached a copy of the CUtilsCharts.def file so that you can see where I am at the moment.
You do not have the required permissions to view the files attached to this post.
User avatar
HansR
Posts: 3326
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: CUtlsCharts definition error

Post by HansR »

Hi Andy,

I assume it is the following chart you are discussing:

Code: Select all

Chart AllWindrun Title All Windrun
  PLOT ALL Windrun As Column Colour #0D6D9D zindex 100 Opacity 0.4
EndChart
(you only need to post the problematic chart).

I added this chart to my test site (currently CMX4). You find it as the last of the Home-charts.
You say : and produced a single line on the RHS of the chart which I assume is what you see as problematic.

I assume you mean the chart only produces a Y-axis on the RHS (with the labels on the inside and without a unit), that I think is not as it should be, but is the same for the column version and the SPline version of the chart. The Y-axis should be on the left side (and maybe duplicated on the right side for a single line chart).
If you mean something different could you add a screenshot and an explanation?

So far I see this only happen with the WindRun chart (I assume it has to do with the distance unit).
I will have to look at it in detail but as I will be out of the loop for 5 days from tomorrow that will be somewhere next week.

Apart from the above I notice that suddenly your whole site goes wrong: the dashboard does not carry the gauges and the chart does not initialise correctly. The console says Highcharts and jQuery are double included. That is surprising and has to do with the inifile parameters GeneratejQueryInclude and DoLibraryIncludes. You will have to look at that.
Hans

https://meteo-wagenborgen.nl
https://meteo-wagenborgen.nl/CMX4
CMX build 3182 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspberry OS 5.10.103 ● Mono 6.12.0.122
CMX build 40xx ● Ecowitt GW1100/WS80/WH40 ● RPi 4B ● Raspberry OS 5.15.32 ● .NET 6.0.1
AndyKF650
Posts: 303
Joined: Thu 20 Aug 2020 8:35 am
Weather Station: Davis VP2 Plus
Operating System: RPiv4 Debian Bullseye Windows 11
Location: Jersey Channel Islands
Contact:

Re: CUtlsCharts definition error

Post by AndyKF650 »

Hi Hans

Thanks so much for the advice which is correct as ever.

Sorting out the two .ini file parameters s GeneratejQueryInclude and DoLibraryIncludes to make them both false has made the charts work with columns again and I think made the website dashboard much more stable :D

There is no need to think about columns in charts next week!!

I am note sure how I picked up faulty .ini file but as they say ..it happens.
User avatar
HansR
Posts: 3326
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: CUtlsCharts definition error

Post by HansR »

:D OK

Have to check out the y-axis though
Hans

https://meteo-wagenborgen.nl
https://meteo-wagenborgen.nl/CMX4
CMX build 3182 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspberry OS 5.10.103 ● Mono 6.12.0.122
CMX build 40xx ● Ecowitt GW1100/WS80/WH40 ● RPi 4B ● Raspberry OS 5.15.32 ● .NET 6.0.1
Post Reply