Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.11.4 (build 3133) - 25 May 2021 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

Measurements records updated but no log files.

GW1000 WiFi gateway
Post Reply
zoomx
Posts: 48
Joined: Sat 15 Mar 2014 4:50 pm
Weather Station: Froggit GW1000
Operating System: Windows-Linux
Location: Italy

Measurements records updated but no log files.

Post by zoomx »

Hello,

I noticed that my CumulusMX, that is connected to an Ecowitt1000, does not display any graph and does not record any log data.
In the data directory there are only these files

Code: Select all

-rw-r--r-- 1 root root    1929 Mar 21 17:42 alltime.ini
-rw-r--r-- 1 root root  331902 Mar 21 17:42 alltimelog.txt
-rw-r--r-- 1 root root   12288 Oct 12 09:31 cumulusmx.db
-rw-r--r-- 1 root root   42211 Mar 21 00:00 dayfile.txt
-rw-r--r-- 1 root root   12288 Oct 12 09:31 diary.db
-rw-r--r-- 1 root root    1356 Nov  1 00:00 month202010.ini
-rw-r--r-- 1 root root    1410 Dec  1 00:00 month202011.ini
-rw-r--r-- 1 root root    1381 Jan  1 00:00 month202012.ini
-rw-r--r-- 1 root root    1383 Feb  1 00:00 month202101.ini
-rw-r--r-- 1 root root    1394 Mar  1 00:00 month202102.ini
-rw-r--r-- 1 root root    1422 Mar 21 17:42 month.ini
-rw-r--r-- 1 root root   21376 Mar 21 17:42 monthlyalltime.ini
-rw-r--r-- 1 root root 1072945 Mar 21 17:42 monthlyalltimelog.txt
-rw-r--r-- 1 root root    1404 Mar 21 15:21 today.ini
-rw-r--r-- 1 root root    1443 Jan  1 00:00 year2020.ini
-rw-r--r-- 1 root root    1486 Mar 21 17:42 year.ini
-rw-r--r-- 1 root root     874 Mar 21 00:00 yesterday.ini
All measurements records are updated, Noaa files are builded but no log files.

Where am I wrong?

I added my ini file.

I Suspect that there is a silly permissions problem since CumulusMX was not able to update the inifile so I changed permission to 664
data has 777 permissions
CumulusMX should be running as root sinche is started as service and in the service there is
[Service]
User=root
Group=root
You do not have the required permissions to view the files attached to this post.

freddie
Posts: 1327
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2
Operating System: GNU/Linux Ubuntu 20.04 LXC
Location: Alcaston, Shropshire, UK
Contact:

Re: Measurements records updated but no log files.

Post by freddie »

Log files are in the MXdiags folder of your installation.
Freddie
Image

User avatar
HansR
Posts: 2145
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Measurements records updated but no log files.

Post by HansR »

I think he means there are no monthly data files
Hans

https://meteo-wagenborgen.nl
Cumulus build 3132 ● Davis Vantage Pro 2+ ● RPi 3B+ ● Raspbian 5.10.17-v7+ ● Mono 5.18.0.240

zoomx
Posts: 48
Joined: Sat 15 Mar 2014 4:50 pm
Weather Station: Froggit GW1000
Operating System: Windows-Linux
Location: Italy

Re: Measurements records updated but no log files.

Post by zoomx »

HansR wrote:
Sun 21 Mar 2021 6:22 pm
I think he means there are no monthly data files
Right!

User avatar
mcrossley
Posts: 8473
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Measurements records updated but no log files.

Post by mcrossley »

It sounds like you have a missing primary sensor, so MX does not log. The log file would confirm though.

zoomx
Posts: 48
Joined: Sat 15 Mar 2014 4:50 pm
Weather Station: Froggit GW1000
Operating System: Windows-Linux
Location: Italy

Re: Measurements records updated but no log files.

Post by zoomx »

What is a "primary sensor"? I have an WH32 as primary thermoigrometer. I don't have an anemometer but a pluviometer a few others sensors.

I found in the diagnostics log this line near the beginning

2021-03-22 13:25:00.060 Finding raintoday from logfile data/Oct20log.txt

But the file Oct20log.txt does not exist!

Edit: the first start of this CumulusMX was in October 2020
from the INI file
StartDate=Monday, October 12, 2020

User avatar
mcrossley
Posts: 8473
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Measurements records updated but no log files.

Post by mcrossley »

There is a bug in v3.10.3 for GW1000 stations, please update to v.3.10.4

zoomx
Posts: 48
Joined: Sat 15 Mar 2014 4:50 pm
Weather Station: Froggit GW1000
Operating System: Windows-Linux
Location: Italy

Re: Measurements records updated but no log files.

Post by zoomx »

Done!

zoomx
Posts: 48
Joined: Sat 15 Mar 2014 4:50 pm
Weather Station: Froggit GW1000
Operating System: Windows-Linux
Location: Italy

Re: Measurements records updated but no log files.

Post by zoomx »

I found my fault.
I don't have an Ecowitt wind sensor since I live among buildings.
I haven't checked this
No sensor check
Make Cumulus MX run even if you do not have the minimum sensors required (temp, press, wind)
Now it's cheched and I have all logs!

Post Reply