Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.13.8 (build 3154) - 09 November 2021

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

If you are interested in supporting Cumulus then maybe you would like to contribute to the maintenance of the Wiki? This need not take hours of your time - just a half hour here and there can make a big difference, particularly if many people are doing this. Any contributions are very welcome, whether they involve new content or editing of existing content. It will be very helpful to current and future users of Cumulus software if the Wiki is kept well-maintained and current. If you are interested then please contact forum user saratogaWX and ask for a Wiki account.

incorrect rain data on some pages

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

Post Reply
draqwerty
Posts: 10
Joined: Mon 15 Mar 2021 12:32 am
Weather Station: Weatherflow Tempest
Operating System: Windows 10

incorrect rain data on some pages

Post by draqwerty »

Good morning.

Day in question is the 3rd November, and we had 29.8mm rain.

I have an issue where rain doesn't appear on some pages but appears on others.

The historic graph shows the amount graphically, however when I hover the mouse over the line it shows 0.0 whereas it should be showing 29.8.
rain_graph.png
NOAA yearly looks to be correct; NOAA monthly displays 0.0; Dayfile shows correctly.

Where does the graph and NOAA monthly gets its data from?

Attached are screenshots.

Thank you.


Regards
Jason
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 9169
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: incorrect rain data on some pages

Post by mcrossley »

Both the NOAA year and month report read the dayfile.txt to get the rainfall for each day.

The chart is weird. That is a produced by third party product, the graphic and the mouse-over are generated from the same data set that is passed to it!

Is this on the dashboard interface or the web site?

Can you regenerate your monthly report, note the time, and then post the latest MXdiags file please?

draqwerty
Posts: 10
Joined: Mon 15 Mar 2021 12:32 am
Weather Station: Weatherflow Tempest
Operating System: Windows 10

Re: incorrect rain data on some pages

Post by draqwerty »

Hi Mark

This is on the dashboard. I have recreated the monthly report at 8:33:49.

In the MXdiags file I found this:
2021-11-25 08:33:49.279 Creating NOAA monthly report
2021-11-25 08:33:49.279 Duplicate entry at line 291 of dayfile.txt: 03/11/21. Please correct this by editing the file
2021-11-25 08:33:49.310 Saving monthly NOAA report as Reports\NOAAMO1121.txt

I assume this is the cause of my problem and we did have an extended power outage on the 3/11 which I think has attributed to this.

I have attached the dayfile.txt as well.

Thank you.


Regards
Jason

PS: Sorry for the slow reply, work has been crazy this week.
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 9169
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: incorrect rain data on some pages

Post by mcrossley »

You have a duplicate line for 03/11/21 on line 69 of the dayfile - after 23/03/21!

Delete that and it should fix everything.

draqwerty
Posts: 10
Joined: Mon 15 Mar 2021 12:32 am
Weather Station: Weatherflow Tempest
Operating System: Windows 10

Re: incorrect rain data on some pages

Post by draqwerty »

Hi Mark

Thank you for your assistance. Deleted line and looks good again including the graph.


Regards
Jason

Post Reply