Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.11.4 (build 3133) - 25 May 2021 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

Problem after update to b3131

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

Post Reply
griffo42
Posts: 102
Joined: Thu 10 Dec 2015 6:41 am
Weather Station: Davis Vantage Pro2
Operating System: Win 10
Location: Brisbane, Queensland, Australia
Contact:

Problem after update to b3131

Post by griffo42 »

I upgraded to b3131 today and now have noted a problem with temperature data on the today page (confirmed by the 2 graph pages and temperature on 17May at 0640 of 8.6degC) as shown below:
Screenshot 2021-05-17 today.jpg
Screenshot 2021-05-17 temperature chart.jpg
Screenshot 2021-05-17temp trends.jpg
What have I done or not done to cause this problem, please?

My URLs are:
kstwx.net/index.php
kstwx.net/cumx/today.htm
kstwx.net/mxtestv2/index.php

Keith
You do not have the required permissions to view the files attached to this post.
Davis Vantage Pro2 Model #6152AU - CumulusMX - Win10 - Saratoga Scripts
https://www.kstwx.net/index.php
https://www.kstwx.net/cumx/index.htm
https://www.kstwx.net/mxtestv2/index.php
Image

User avatar
mcrossley
Posts: 8473
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Problem after update to b3131

Post by mcrossley »

Can you post your MXdiags file(s) for this period please.

User avatar
ConligWX
Posts: 1264
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis vPro2 Plus w/DFARS
Operating System: Ubuntu 20.04.2 LTS - NUC
Location: Bangor, NI
Contact:

Re: Problem after update to b3131

Post by ConligWX »

cant say I see this anomaly on my own site running 3.11.2 b3131. all looks good to me.
Regards Simon

https://www.conligwx.org - @conligwx
Davis Vantage Pro2 Plus with Daytime FARS • WeatherLink Live • Davis AirLink • PurpleAir PA-II-SD • CumulusMX •

BCJKiwi
Posts: 1094
Joined: Mon 09 Jul 2012 8:40 pm
Weather Station: Davis VP2 Cabled with Solar
Operating System: Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: Problem after update to b3131

Post by BCJKiwi »

Could it be because the temperature scale are different on two charts?

The traces appear to have a very similar shape but the scale range is different making one more compressed vertically than the other.

I see a similar effect on my site.

griffo42
Posts: 102
Joined: Thu 10 Dec 2015 6:41 am
Weather Station: Davis Vantage Pro2
Operating System: Win 10
Location: Brisbane, Queensland, Australia
Contact:

Re: Problem after update to b3131

Post by griffo42 »

Here are my MXDiag files for 17May 2021.

Thanks

Keith
You do not have the required permissions to view the files attached to this post.
Davis Vantage Pro2 Model #6152AU - CumulusMX - Win10 - Saratoga Scripts
https://www.kstwx.net/index.php
https://www.kstwx.net/cumx/index.htm
https://www.kstwx.net/mxtestv2/index.php
Image

griffo42
Posts: 102
Joined: Thu 10 Dec 2015 6:41 am
Weather Station: Davis Vantage Pro2
Operating System: Win 10
Location: Brisbane, Queensland, Australia
Contact:

Re: Problem after update to b3131

Post by griffo42 »

In addition to that already sent, here are the entries in the May21log.txt for 17 May 2021, in case that helps.

Keith
You do not have the required permissions to view the files attached to this post.
Davis Vantage Pro2 Model #6152AU - CumulusMX - Win10 - Saratoga Scripts
https://www.kstwx.net/index.php
https://www.kstwx.net/cumx/index.htm
https://www.kstwx.net/mxtestv2/index.php
Image

User avatar
beteljuice
Posts: 3210
Joined: Tue 09 Dec 2008 1:37 pm
Weather Station: None !
Operating System: W10 - Threadripper 16core, etc
Location: Dudley, West Midlands, UK

Re: Problem after update to b3131

Post by beteljuice »

The 'next' day (18th) appears to be OK ?

However: the erroneous low reading for 17th (current 'yesterday' table) persists with a time of @23:59

This suggests that somehow where the tables get their data from 'lost' the daily (temp) values from before when you closed Cumulus to perform the update.

The earliest table entry is Wind gust @ 10:59 - when did you restart Cumulus ?

(Although everything should be in the files you zipped ..... )
Image
......................Imagine, what you will KNOW tomorrow !

User avatar
mcrossley
Posts: 8473
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Problem after update to b3131

Post by mcrossley »

Unfortunately the logs will not reveal anything to do with the temperature.

What you could though is look in the /backup folders, and find the backups that correspond to your restarts on the 17th.

In those look in the today.ini files, the value for the days low temp is stored in there.
If the today.ini got corrupted at some point, then I think CMX would start recording the days highs/lows from the point when it started with the corrupt file.

griffo42
Posts: 102
Joined: Thu 10 Dec 2015 6:41 am
Weather Station: Davis Vantage Pro2
Operating System: Win 10
Location: Brisbane, Queensland, Australia
Contact:

Re: Problem after update to b3131

Post by griffo42 »

@mcrossley

Thanks for your reply.

When looking at the /backup folder I found the first folder for the 17th May which was timed at 0941.
mcrossley wrote:
Tue 18 May 2021 11:26 am
If the today.ini got corrupted at some point, then I think CMX would start recording the days highs/lows from the point when it started with the corrupt file.
The today.ini file in that folder has no entries for any reading in it and hence is corrupt. I did not start my update to b3131 until around midday. I can only conclude that the 0941 event was associated with a short time power outage (of which I was not aware) around that time.

I will do the appropriate edits - if any are necessary - to correct the data.

Keith
Davis Vantage Pro2 Model #6152AU - CumulusMX - Win10 - Saratoga Scripts
https://www.kstwx.net/index.php
https://www.kstwx.net/cumx/index.htm
https://www.kstwx.net/mxtestv2/index.php
Image

Post Reply