Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.11.4 (build 3133) - 25 May 2021 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

graphconfig.json does not appear

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

Post Reply
User avatar
HansR
Posts: 2159
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

graphconfig.json does not appear

Post by HansR »

In relation to a previous thread it appeared I had more or less forgotten where all files came from and where they had to be configured so I decided to delete the website and start all over again. That is a useful exercise. And there is one file I cannot trace and find back: graphconfig.json.

It appears to be configured at: Internet settings=>Web/FTP Settings=> Interval Settings=>Graph File Settings, to be uploaded at the FTP interval. In my case every 10 minutes but although all files are uploaded correctly, this one is not.

Also FTP Now! does not resolve the issue.

In the code I found:

Code: Select all

// The config files only need uploading once per change
if (GraphDataFiles[i].LocalFileName == "availabledata.json" ||
      GraphDataFiles[i].LocalFileName == "graphconfig.json")
{
    GraphDataFiles[i].FtpRequired = false;
}
So the question is: what change is required to get this file uploaded and shouldn't it upload with the FTP Now! ?

And yes, I presume a restart does the trick as well - yes it does! - but I don't get the why.
Hans

https://meteo-wagenborgen.nl
Cumulus build 3132 ● Davis Vantage Pro 2+ ● RPi 3B+ ● Raspbian 5.10.17-v7+ ● Mono 5.18.0.240

sfws
Posts: 983
Joined: Fri 27 Jul 2012 11:29 am
Weather Station: Combination Mix of FO stations
Operating System: R Pi OS

Re: graphconfig.json does not appear

Post by sfws »

HansR wrote:
Sat 15 May 2021 10:57 am
there is one file I cannot trace and find back: graphconfig.json.
That is a one-off upload. See Settings --> Web/FTP settings --> Graph file settings and tick Generate

User avatar
HansR
Posts: 2159
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: graphconfig.json does not appear

Post by HansR »

Generate and FTP upload are both ticked.
Point is that the file is never uploaded (unless restarted or maybe when I change from Celsius to Fahrenheit) and not at FTP Now!
Hans

https://meteo-wagenborgen.nl
Cumulus build 3132 ● Davis Vantage Pro 2+ ● RPi 3B+ ● Raspbian 5.10.17-v7+ ● Mono 5.18.0.240

Mapantz
Posts: 979
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 10 x64
Location: Dorset - UK
Contact:

Re: graphconfig.json does not appear

Post by Mapantz »

HansR wrote:
Sat 15 May 2021 7:11 pm
Generate and FTP upload are both ticked.
Point is that the file is never uploaded (unless restarted or maybe when I change from Celsius to Fahrenheit) and not at FTP Now!
I just tried it, it works for me.

I don't actually use it, but CMX uploaded it. I then changed a setting and hit FTP now, and it uploaded it with the changes.
Image

User avatar
HansR
Posts: 2159
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: graphconfig.json does not appear

Post by HansR »

@Mapanz: I would expect FTP Now! to send it even if I had not made a change.

Reason is that I simulated a crash by deleting all my files and that should be restored automatically.
It almost does.

But OK, it is clear now how it works, not a big point.
Hans

https://meteo-wagenborgen.nl
Cumulus build 3132 ● Davis Vantage Pro 2+ ● RPi 3B+ ● Raspbian 5.10.17-v7+ ● Mono 5.18.0.240

sfws
Posts: 983
Joined: Fri 27 Jul 2012 11:29 am
Weather Station: Combination Mix of FO stations
Operating System: R Pi OS

Re: graphconfig.json does not appear

Post by sfws »

HansR wrote:
Sat 15 May 2021 8:01 pm
I would expect FTP Now! to send it even if I had not made a change.
Your previous reply to me focussed on the "Generate" I coloured in my earlier post, so perhaps you missed that I started that post saying
sfws wrote:
Sat 15 May 2021 6:49 pm
That is a one-off upload.
Mark might need to respond if he has changed the code since the new graph design implemented, but I believe you misunderstand what "FTPNow" does.

I have seen nothing from Mark since FTPNow discussed in viewtopic.php?f=40&t=17887&p=138832&, viewtopic.php?f=40&t=17818 and viewtopic.php?f=39&t=15139
Summarising, FTPNow! is based on a Cumulus 1 feature called "Web update", it just does what next normal upload would do, therefore neither repeat any one-off upload.

User avatar
HansR
Posts: 2159
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: graphconfig.json does not appear

Post by HansR »

Thanks @sfws, i may have missed some things but not the 'one off' remark. Apparently it is this file and the available data file which do not get uploaded again unless restarted or changed.

Indeed I misinterpreted the FTP Now! button but it could also have been read as an implicit request. They are small files so who would notice in the blob of a datafile and others upload.

Anyway, as I said:
HansR wrote:
Sat 15 May 2021 8:01 pm
But OK, it is clear now how it works, not a big point.
Hans

https://meteo-wagenborgen.nl
Cumulus build 3132 ● Davis Vantage Pro 2+ ● RPi 3B+ ● Raspbian 5.10.17-v7+ ● Mono 5.18.0.240

User avatar
mcrossley
Posts: 8473
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: graphconfig.json does not appear

Post by mcrossley »

I'll add this to the list to take another look it.

Off the top of my head I think perhaps it should be uploaded either: on start (as now), on change (as now), at EOD, on FTP now.

User avatar
HansR
Posts: 2159
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: graphconfig.json does not appear

Post by HansR »

mcrossley wrote:
Sun 16 May 2021 9:33 pm
I'll add this to the list to take another look it.
Thanks, that would be nice
Hans

https://meteo-wagenborgen.nl
Cumulus build 3132 ● Davis Vantage Pro 2+ ● RPi 3B+ ● Raspbian 5.10.17-v7+ ● Mono 5.18.0.240

Post Reply