Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.11.4 (build 3133) - 25 May 2021 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

Error when trying to run the latest version 3130

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

Post Reply
User avatar
odintheterrible
Posts: 110
Joined: Wed 16 Jan 2013 8:18 am
Weather Station: Brandson 304577 & GW1000
Operating System: Windows 10 64-bit
Location: Torre-Pacheco, Murcia, Spain

Error when trying to run the latest version 3130

Post by odintheterrible »

After downloading the latest zip (3130), unzipping it and then trying to run, I get the following error message, "System.IO.FileNotFoundException: Could not load file or assembly 'Devart.Data.MySql, Version=8.3.389.0, Culture=neutral, PublicKeyToken=09af7300eec23701' or one of its dependencies. The system cannot find the file specified.
File name: 'Devart.Data.MySql, Version=8.3.389.0, Culture=neutral, PublicKeyToken=09af7300eec23701'
at CumulusMX.Cumulus..ctor(Int32 HTTPport, Boolean DebugEnabled, String startParms)
at CumulusMX.Program.RunAsAConsole(Int32 port, Boolean debug)
at CumulusMX.Program.Main(String[] args)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

**** An error has occurred - please zip up the MXdiags folder and post it in the forum ****
Press Enter to terminate
"
Since this error, I have tried to reinstall the earlier version or two but when I try to run them the same error message now appears. How do I get round this problem ???? Thanks
"Qui Custodit Ipsos Custodes ? ..."

Duct Tape is like 'The Force' ... it has a 'Light Side' AND a 'Dark Side' and it binds the Universe together !

water01
Posts: 2161
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 10 64bit
Location: Burnham-on-Sea
Contact:

Re: Error when trying to run the latest version 3130

Post by water01 »

Are you sure that you have installed 3130 correctly as the Devart version of MySQL was removed in 3129 (the previous release) as per the release notes

"MySQL: Removed Devart, replaced with MySqlConnector",

If the program is still trying to find Devart that means you have the wrong version CumulusMX installed.
David
Image

Post Reply