Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.11.4 (build 3133) - 25 May 2021 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

website issues

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

Post Reply
dahl327
Posts: 9
Joined: Wed 25 Dec 2019 3:23 am
Weather Station: vantage vue
Operating System: Linux MX

website issues

Post by dahl327 »

Hi,
trying to setup my website. I have uploaded the webfiles to my ftp page which is working fine but data from my weatherstation is not populating.
http://www.users.on.net/~dahl3272/
any help appreciated

User avatar
PaulMy
Posts: 2661
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: website issues

Post by PaulMy »

Hi,
Looks like things are working and updating - your realtimegauges.txt file is updating every minute.
Some settings still to do, i.e. set Lat and Lon.
Also you need to edit the \webfiles\js\noaarpts.js file to show the path to your NOAA Reports and then FTP
From

Code: Select all

let rptPath = '';
To

Code: Select all

let rptPath = 'NOAAReports/';
or whatever folder your NOAA reports are being uploaded to.

Enjoy,
Paul

silverview
Posts: 61
Joined: Fri 01 Jan 2010 9:40 pm
Weather Station: Davis VP2
Operating System: Windows 10
Location: Calgary, Alberta, Canada
Contact:

Re: website issues

Post by silverview »

It looks good to me. All pages contain data. The only issues I can see after a quick look are there is no lat, long, or elevation data, and the moon image is broken.

sfws
Posts: 983
Joined: Fri 27 Jul 2012 11:29 am
Weather Station: Combination Mix of FO stations
Operating System: R Pi OS

Re: website issues

Post by sfws »

Looks like you have done a good job on web site set up. It is best to work through every setting, to ensure everything is set to a valid setting. As well as what others have reported, you need to set a label to appear after "welcome to".

Yesterday's rain rate looks wrong, investigate that. If you need help, look at https://cumuluswiki.org/a/Correcting_Extremes.

dahl327
Posts: 9
Joined: Wed 25 Dec 2019 3:23 am
Weather Station: vantage vue
Operating System: Linux MX

Re: website issues

Post by dahl327 »

haha... I spoke too soon. Went to bed with no data loading to the page after trying what i thought was everything.
Woke up read the comments, checked my page and data was there!
I guess I wasn't giving enough time after making changes to see the results.

Thanks all.

User avatar
beteljuice
Posts: 3212
Joined: Tue 09 Dec 2008 1:37 pm
Weather Station: None !
Operating System: W10 - Threadripper 16core, etc
Location: Dudley, West Midlands, UK

Re: website issues

Post by beteljuice »

Your websitedata.json file is not quite right - although I can't spot any obvious error.

Most likely because of the various options you don't appear to have set yet ?
Image
......................Imagine, what you will KNOW tomorrow !

User avatar
PaulMy
Posts: 2661
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: website issues

Post by PaulMy »

I guess I wasn't giving enough time after making changes to see the results.
Yes that great feature, Caching :clap: :x :cry:

Enjoy,
Paul

User avatar
ConligWX
Posts: 1264
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis vPro2 Plus w/DFARS
Operating System: Ubuntu 20.04.2 LTS - NUC
Location: Bangor, NI
Contact:

Re: website issues

Post by ConligWX »

dahl327 wrote:
Fri 23 Apr 2021 9:05 pm
haha... I spoke too soon. Went to bed with no data loading to the page after trying what i thought was everything.
Woke up read the comments, checked my page and data was there!
I guess I wasn't giving enough time after making changes to see the results.

Thanks all.
you moon image is not found did you set it up in the settings?

Capture.JPG
You do not have the required permissions to view the files attached to this post.
Regards Simon

https://www.conligwx.org - @conligwx
Davis Vantage Pro2 Plus with Daytime FARS • WeatherLink Live • Davis AirLink • PurpleAir PA-II-SD • CumulusMX •

dahl327
Posts: 9
Joined: Wed 25 Dec 2019 3:23 am
Weather Station: vantage vue
Operating System: Linux MX

Re: website issues

Post by dahl327 »

Hi Simon,
late reply, I have to moon image sorted now.
Everything is fine now except for the gauges. I am getting updated data on the other pages on the website however on the gauges page I get the error : parsererror: SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data.
If i restart the station the error goes away and the gauges work but then the error eventually comes back.

The setup is a Raspberry Pi with the CumulusMx image at a remote location, what is the best way to access to change settings and get log files ect remotely?
Any help appreciated.

http://www.users.on.net/~dahl3272/gauges.htm

cheers,

User avatar
mcrossley
Posts: 8473
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: website issues

Post by mcrossley »

For some reason your RealtimeGauges.txt file is completely empty? That is why you are getting the syntax error.

http://www.users.on.net/~dahl3272/realtimegauges.txt

Post Reply