Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.9.1 (build 3096) - 31 October 2020 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this Wiki link to Download the Software (Cumulus MX / Cumulus 1 and other related items).

Assistance with getting the latest version of MX working

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

Post Reply
Safety
Posts: 42
Joined: Fri 09 Apr 2010 7:32 pm
Weather Station: Davis Pro
Operating System: Windows 10

Assistance with getting the latest version of MX working

Post by Safety »

Hi all,
Could I have some assistance please to get the latest version of MX working.
I decided to update from Cumulus MX v.3.6.12 build 3088 to v3.9.0 - b3095 unfortunately this version will only get to “last update” status and then it stops and only displays the flashing cursor.
I have attached the diagnostics file “Build 3095.txt” that shows an OpenTcpPort: Error.
In case it was something that I had done wrong I reverted back to build 3088 that had been previously working ok, however this time the screen would run through its start-up routine but displayed "not connected".
Checking my network Analyser program, it shows that my Davis WeatherLinkIP data logger was no longer connected to my network the only way I could get it to work was to reset my network switch.
Now build 3088 works fine I have also included the diagnostics file “Build 3088.txt” that shows the “not connected” state
I am launching both versions via the short cut method i.e. not the new service method.
Any help in getting v3.9.0 - b3095 working would be appreciated.
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 7024
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Assistance with getting the latest version of MX working

Post by mcrossley »

Neither version can connect to your IP logger.
Is the IP address still correct?

Safety
Posts: 42
Joined: Fri 09 Apr 2010 7:32 pm
Weather Station: Davis Pro
Operating System: Windows 10

Re: Assistance with getting the latest version of MX working

Post by Safety »

Hi mcrossley,

As I stated in my previous message after trying to upgrade and finding it would not go passed “last update”, I reverted back to my previously working build 3088 however this flagged "not connected".
At this point I looked at my network Analyser App to find that my logger was not being seen by my network. If my logger had changed IP the logger would still be shown and I would have noted an IP change. The only way to get the Logger to show was to power down my 8 port Network switch, once repowered the logger showed as being connected to the network and by restarting up MX again my build 3088 was back working just as it was before I tried to upgrade to Build3095.
So, my question is what do I need to do to run Build3095 so it does not present the problem described in this and my previous message.

Regards

User avatar
mcrossley
Posts: 7024
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Assistance with getting the latest version of MX working

Post by mcrossley »

Well, nothing special. Nothing has changed about how it handles Davis stations in the config.

Post Reply