Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.6.12 (build 3088) - 10 July 2020 (please see important announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this link to Download the Software (Cumulus MX / Cumulus 1 and other related items). Software

v.3.6.10 build 3086 bug ?

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

Post Reply
jlmr731
Posts: 153
Joined: Sat 27 Aug 2016 12:11 am
Weather Station: Davis vantage pro 2
Operating System: Debian
Location: Youngstown, Ohio
Contact:

v.3.6.10 build 3086 bug ?

Post by jlmr731 »

Been staying current with builds and all is well, I upgraded to 3086 and started it up, and it did not fully start it sat at flushing for about 4-5 minutes, then i cntl-c to do a restart and all went well after that, I belive this happened a few build's back to so not sure if this is a bug or just a glitch that can happen from time to time. the following is the output of diag not long so not zipping it:

Code: Select all

2020-06-27 09:09:48.442  ========================== Cumulus MX starting ==========================
2020-06-27 09:09:48.445 Command line: /home/jeff/CumulusMX/CumulusMX.exe
2020-06-27 09:09:48.445 Cumulus MX v.3.6.10 build 3086
2020-06-27 09:09:48.445 Platform: Unix
2020-06-27 09:09:48.445 OS version: Unix 4.19.0.9
2020-06-27 09:09:48.501 Mono version: 5.18.0.240 (Debian 5.18.0.240+dfsg-3 Wed Apr 17 16:37:36 UTC 2019)
2020-06-27 09:09:48.501 Current culture: English (United States)
2020-06-27 09:09:48.501 Directory separator=[/] Decimal separator=[.] List separator=[,]
2020-06-27 09:09:48.501 Date separator=[/] Time separator=[:]
2020-06-27 09:09:48.501 Standard time zone name:   EST
2020-06-27 09:09:48.501 Daylight saving time name: EDT
2020-06-27 09:09:48.501 Daylight saving time? True
2020-06-27 09:09:48.501 6/27/2020 9:09:48 AM
2020-06-27 09:09:48.513 Reading Cumulus.ini file
2020-06-27 09:09:48.525 ASM=10 AST=00:10:00
2020-06-27 09:09:48.526 Cumulus start date: 8/20/2016
2020-06-27 09:09:48.530 Data path = data/
2020-06-27 09:09:48.561 Creating backup folder backup/20200627090948/
2020-06-27 09:09:48.611 Created backup folder backup/20200627090948/
2020-06-27 09:09:48.611 Debug logging is disabled
2020-06-27 09:09:48.611 Data logging is disabled
2020-06-27 09:09:48.611 FTP logging is disabled
2020-06-27 09:09:48.611 Logging interval = 1
2020-06-27 09:09:48.611 Real time interval = 60
2020-06-27 09:09:48.611 NoSensorCheck = 0
2020-06-27 09:09:48.686 Calculating sunrise and sunset times
2020-06-27 09:09:48.689 Sunrise: 05:52:20
2020-06-27 09:09:48.689 Sunset : 20:59:24
2020-06-27 09:09:48.689 Tomorrow sunrise: 05:52:45
2020-06-27 09:09:48.689 Tomorrow sunset : 20:59:22
2020-06-27 09:09:48.739 Station type: Davis Vantage Pro2
2020-06-27 09:09:48.739 WindUnit=mph RainUnit=in TempUnit=°F PressureUnit=in
2020-06-27 09:09:48.739 YTDRain=0.000 Year=0
2020-06-27 09:09:48.739 RainDayThreshold=-1.000
2020-06-27 09:09:48.739 Offsets and Multipliers:
2020-06-27 09:09:48.739 PO=0.000 TO=0.000 HO=0 WDO=0 ITO=0.000 SO=0.000 UVO=0.000
2020-06-27 09:09:48.739 PM=1.000 WSM=1.000 WGM=1.000 TM=1.000 TM2=0.000 HM=1.000 HM2=0.000 RM=1.000 SM=1.000 UVM=1.000
2020-06-27 09:09:48.739 Spike removal:
2020-06-27 09:09:48.739 TD=999.000 GD=999.000 WD=999.000 HD=999.000 PD=999.000
2020-06-27 09:09:48.739 MR=999.000 MH=999.000
2020-06-27 09:09:48.740 Cumulus Starting
2020-06-27 09:09:48.740 Opening station
2020-06-27 09:09:48.746 Last update time from today.ini: 6/27/2020 1:20:00 AM
2020-06-27 09:09:48.746 Read today file: Date = 6/27/2020, LastUpdateTime = 6/27/2020 1:20:00 AM, Month = 6
2020-06-27 09:09:48.747 ReadTodayfile: set notraininit false
2020-06-27 09:09:48.749 /home/jeff/CumulusMX/data/alltime.ini
2020-06-27 09:09:48.749 Alltime.ini file read
2020-06-27 09:09:48.754 MonthlyAlltime.ini file read
2020-06-27 09:09:48.756 Month.ini file read
2020-06-27 09:09:48.758 Year.ini file read
2020-06-27 09:09:48.759 Finding raintoday from logfile data/Jun20log.txt
2020-06-27 09:09:48.759 Expecting listsep=, decimal=.
2020-06-27 09:09:49.301 Midnight rain found in the following entry:
2020-06-27 09:09:49.301 27/06/20,00:00,72.7,82,66.9,0.0,2.0,187,0.00,0.00,29.894,15.97,76.2,44,0.0,72.7,72.7,0.0,0,0.000,0.000,78.8,0,0.0,196,0.00,0.00,77.6
2020-06-27 09:09:49.302 Midnight rain found, setting midnight rain count = 15.97
2020-06-27 09:09:49.302 Checking rain counter = 15.97
2020-06-27 09:09:49.302 Rain counter set to = 15.97
2020-06-27 09:09:49.303 Getting rain totals, rain season start = 1
2020-06-27 09:09:49.303 Today = 27/06/20
2020-06-27 09:09:49.339 Rainthismonth from dayfile.txt: 0.55
2020-06-27 09:09:49.339 Rainthisyear from dayfile.txt: 15.97
2020-06-27 09:09:49.340 Station type = Davis
2020-06-27 09:09:49.340 LOOP2 enabled
2020-06-27 09:09:49.340 IP address = 192.168.100.13 Port = 22222
2020-06-27 09:09:49.340 periodic disconnect = 0
2020-06-27 09:09:50.349 Flushing input stream
Now another thing that has been happening for a while now and does not seem to cause any issues when closing MX is this output: the last few lines of Diag file and also appears within the term:

Code: Select all

2020-06-28 08:22:12.618 Cumulus closing
2020-06-28 08:22:12.626 Writing Cumulus.ini file
2020-06-28 08:22:12.631 Completed writing Cumulus.ini file
2020-06-28 08:22:12.631 Station stopping
2020-06-28 08:22:12.635 Closing connection
2020-06-28 08:22:12.635 Station stopped
2020-06-28 08:22:12.635 Writing today.ini file
2020-06-28 08:22:12.635 Completed writing today.ini file
2020-06-28 08:22:12.635 Station shutdown complete
Cumulus has shutdown
!!! Unhandled Exception !!!
System.ObjectDisposedException: Cannot access a disposed object.
Object name: 'System.Net.Sockets.Socket'.
  at System.Net.Sockets.Socket.ThrowIfDisposedAndClosed () [0x00021] in <a9a08e39ba304bd0a84c49bd158dfc02>:0 
  at System.Net.Sockets.Socket.get_Available () [0x00000] in <a9a08e39ba304bd0a84c49bd158dfc02>:0 
  at System.Net.Sockets.TcpClient.get_Available () [0x00000] in <a9a08e39ba304bd0a84c49bd158dfc02>:0 
  at CumulusMX.DavisStation.GetAndProcessLoopData (System.Int32 number) [0x0023d] in <4f514f1b789842559b081ec695b3c94d>:0 
  at CumulusMX.DavisStation.Start () [0x00101] in <4f514f1b789842559b081ec695b3c94d>:0 
  at System.Threading.ThreadHelper.ThreadStart_Context (System.Object state) [0x00017] in <d0e12f672b88444ab4b6d9b2ecf20142>:0 
  at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x0008d] in <d0e12f672b88444ab4b6d9b2ecf20142>:0 
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00000] in <d0e12f672b88444ab4b6d9b2ecf20142>:0 
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state) [0x00031] in <d0e12f672b88444ab4b6d9b2ecf20142>:0 
  at System.Threading.ThreadHelper.ThreadStart () [0x0000b] in <d0e12f672b88444ab4b6d9b2ecf20142>:0 

User avatar
mcrossley
Posts: 6628
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: v.3.6.10 build 3086 bug ?

Post by mcrossley »

Hi Jeff,

The first one is interesting, I've not seen that reported before. Without debug diags its a bit hard to trace but I'll take a look to see if I can see anything. Sounds like some function never returns or times out somewhere. I don't have access to a Davis IP logger so it will be a paper exercise...

The second issue - is expected, the shutdown code isn't very comprehensive at the moment, some bits get left running after the shutdown starts, and when they try and access stuff that has already been closed you get an error logged. It's nothing to worry about.

jlmr731
Posts: 153
Joined: Sat 27 Aug 2016 12:11 am
Weather Station: Davis vantage pro 2
Operating System: Debian
Location: Youngstown, Ohio
Contact:

Re: v.3.6.10 build 3086 bug ?

Post by jlmr731 »

Thanks Mark, Ill turn on debug (just gotta find out how) that way if it happens again ill try to help, but as we all know once I do that it will run perfectly :geek:

sfws
Posts: 878
Joined: Fri 27 Jul 2012 11:29 am
Weather Station: Modified Fine Offset
Operating System: Win. 10 PC
Location: The Marches, UK

Re: v.3.6.10 build 3086 bug ?

Post by sfws »

jlmr731 wrote:
Sun 28 Jun 2020 11:04 pm
I'll turn on debug (just gotta find out how)
In admin interface Settings tab, station settings, Options section, select '''debug logging''' (and if communications between weather station and MX are relevant select ''data logging''). This is number 1 in https://cumuluswiki.org/a/What_to_do_wh ... em_with_MX

The alternative to restart MX with debug parameter "sudo mono CumulusMX -debug", see https://cumuluswiki.org/a/Cumulus_MX#Pa ... _debugging might help with a problem at start-up if you knew in advance you were going to get a problem!

User avatar
mcrossley
Posts: 6628
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: v.3.6.10 build 3086 bug ?

Post by mcrossley »

I see a *possible* issue with the TCP connection. If the connection get closed by the logger immediately after opening, then the session *could, maybe* hang as the infinite timeout of write hasn't been over-ridden. All I can do is try setting both read and write timeouts and see if that improves things.

jlmr731
Posts: 153
Joined: Sat 27 Aug 2016 12:11 am
Weather Station: Davis vantage pro 2
Operating System: Debian
Location: Youngstown, Ohio
Contact:

Re: v.3.6.10 build 3086 bug ?

Post by jlmr731 »

mcrossley wrote:
Mon 29 Jun 2020 10:52 am
I see a *possible* issue with the TCP connection. If the connection get closed by the logger immediately after opening, then the session *could, maybe* hang as the infinite timeout of write hasn't been over-ridden. All I can do is try setting both read and write timeouts and see if that improves things.
This may be something, Now I am all wired so it wouldn't be a typical wifi excuse, this last time and the time before was a quick down and up, when its just a copy of the mx exe so its down for less than a minute, or might not even be MX causing an issue may be the meteobridge I use not dropping the connection. I did a quick test and the first time it did hang but using the admin console to set debugging does not stick after shutdown, so im using the debug flag, of course no issue right now but ill play with it see what happens and like i said may be no faults with this software, most of the time when cumulus goes down there is also a reboot involved.

I get the cntl-c issue and never been a problem, but i was thinking if there could be a better way to gracefully shutdown added in like q to quit, but im just a code reader not writer so not sure if thats possible or needed.
Thanks

jlmr731
Posts: 153
Joined: Sat 27 Aug 2016 12:11 am
Weather Station: Davis vantage pro 2
Operating System: Debian
Location: Youngstown, Ohio
Contact:

Re: v.3.6.10 build 3086 bug ?

Post by jlmr731 »

Ok Mark had some time to play with this, not sure what to make of it, other than it goes through all of the davis logger (or meteobridge logger, not sure how that works, if its a pass through or it store it like the davis logger)
After 6 minutes it ran fine, so is there a problem? I dont believe so seeing it did run normally, probably more on my end waiting, if I dont see normal running after a minute Im thinking something wrong. You did add in the double checking a while back and this is probably what its doing just as intended.
Attached log output and see if there is something
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 6628
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: v.3.6.10 build 3086 bug ?

Post by mcrossley »

That looks like another "interesting feature" of meteobridge. Cumulus connected to it over TCP and the first thing is does is flush any input data in the connection. But the meteobridge seems to be sending data unsolicited on this new connection. Cumulus is flushing this data for nearly 6 minutes before it stops!

Code: Select all

2020-07-04 09:06:47.950 TCP Logger Connect attempt 1
2020-07-04 09:06:48.953 TCP Logger reconnected
2020-07-04 09:06:48.953 Flushing input stream
2020-07-04 09:06:49.155 Received 0x0F
2020-07-04 09:06:49.355 Received 0xE2
....
2020-07-04 09:12:10.130 Received 0x0D
2020-07-04 09:12:10.330 Connected OK
This is not how the Davis devices work, if you make a new connection to a Davis logger it starts afresh awaiting a new command.

From that point onwards it seems to work OK.

Post Reply