Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - 28 November 2014
Latest Cumulus MX release v3.0.0 build 3046 - 02 January 2019. See the Wiki for download

Bad characters with accents in months

Discussion and questions about Cumulus weather station software version 1. This section and its subforums are the main place to get help with Cumulus. Anything which is not specific to the type of weather station goes in here; for anything specific to a type of weather station, please use the appropriate subforum. Use the 'website development' section for any questions relating to creating or running a web site for Cumulus data. Discussion of the stations themselves in these sections is fine.
Post Reply
OliII
Posts: 54
Joined: Mon 19 Mar 2012 11:47 am
Weather Station: WMR 200 by Oregon Scientific
Operating System: WinXP SP3
Location: Belgium

Bad characters with accents in months

Post by OliII » Sat 03 Nov 2012 9:24 pm

Hi !
I've some problems with french accents on months names.
Since hours, i try to find where these months are translated into the cumulus folder (ini, strings,..) but.. no solution.
My problem is that some months with accents like août, février, décembre presents bad characters.
My site use utf-8 charset.
The pages provided by cumulus presents good characters, but when i put these into my template with UTF-8 charset, accents are repaced with � or ⟢ like ao�t or ao⟢t
.
To get accents to these pages, i must use html acents style like é for é or ç for ç chars.

Also, i try to save all my templates with utf-8 sans bom (no BOM) chars but, the pages provided by Cumulus are in the AINSI mode !
I try too to change the META charset to iso-8859-1 or windows-1252.. No solution.
One page with the problem : http://www.7331.be/meteo/annee.php

If i change my Browser preferences to the iso-8859-1 chars mode, these accents are displayed, but my pages are wrong with accents...
So, how to make a change into cumulus to :
- get html pages into the utf-8 norm (without BOM)
or
- change the accents to these months
?

Thx !
Image
http://www.7331.be/meteo website based on the phpBB3 forum and template. WMR200 + UVN 800 - Cumulus 1.9.4 1062 / Windows XP Service Pack 3 build 2600 FR

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Bad characters with accents in months

Post by steve » Sat 03 Nov 2012 10:05 pm

I changed my settings to French, and generated the standard web pages. I get the accented characters:
2012-11-03 22_02_14-Test weather.png
So I'm afraid I don't know why it doesn't work on your pages.
You do not have the required permissions to view the files attached to this post.
Steve

OliII
Posts: 54
Joined: Mon 19 Mar 2012 11:47 am
Weather Station: WMR 200 by Oregon Scientific
Operating System: WinXP SP3
Location: Belgium

Re: Bad characters with accents in months

Post by OliII » Sat 03 Nov 2012 10:18 pm

Never has these problems with another sites.
The problem is these html pages are in AINSI mode, not UTF-8 ... the coding of my php and html templates.

If i change my browser settings to iso-8859-1, i can get these accents, but other accents into this page are bad...
To get this page, i include the year.htm (AINSI) page into the php template.. wich is in utf-8.
So, with normal settings :
1.gif
And with iso-8859 or another setting...
2.gif
You do not have the required permissions to view the files attached to this post.
Image
http://www.7331.be/meteo website based on the phpBB3 forum and template. WMR200 + UVN 800 - Cumulus 1.9.4 1062 / Windows XP Service Pack 3 build 2600 FR

Spider-Vice
Posts: 207
Joined: Sat 24 Sep 2011 2:46 pm
Weather Station: PCE FWS-20 (Fine Offset)
Operating System: Windows 10

Re: Bad characters with accents in months

Post by Spider-Vice » Sat 03 Nov 2012 10:45 pm

Try changing your browser into automatically detecting the encoding then, or save the HTML file with the required encoding.

OliII
Posts: 54
Joined: Mon 19 Mar 2012 11:47 am
Weather Station: WMR 200 by Oregon Scientific
Operating System: WinXP SP3
Location: Belgium

Re: Bad characters with accents in months

Post by OliII » Sat 03 Nov 2012 10:59 pm

HTML file (yearT.htm) is into the utf-8 setting. File year.htm provided by Cumulus is AINSI iso-8859 format :( Can't find why these settings changes.
My browser is on automatic detection.

So, i have a solution : i'll create a script wich send every night the Monthly and Yearly informations into my database from a CSV file created with the webtags of cumulus..
Image
http://www.7331.be/meteo website based on the phpBB3 forum and template. WMR200 + UVN 800 - Cumulus 1.9.4 1062 / Windows XP Service Pack 3 build 2600 FR

gemini06720
Posts: 1700
Joined: Mon 10 Aug 2009 10:16 pm
Weather Station: No weather station
Operating System: No operating system
Location: World...

Re: Bad characters with accents in months

Post by gemini06720 » Sun 04 Nov 2012 1:46 am

Indeed, I can confirm that the Cumulus processed templates are in the DOS/Window encoding format (a variation of ANSI) - so far, I have not been able to directly use the HTM templates within a UTF-8 script/template without prior conversion to UTF-8 format (using the PHP 'iconv' function to performs character set conversion on a string or a file).

May I recommend that, instead of using the Cumulus produced HTM templates that you use the Cumulus produced Webtags and integrate them into your phpBB - this way, you can use some PHP code to properly translate to french.

OliII
Posts: 54
Joined: Mon 19 Mar 2012 11:47 am
Weather Station: WMR 200 by Oregon Scientific
Operating System: WinXP SP3
Location: Belgium

Re: Bad characters with accents in months

Post by OliII » Sun 04 Nov 2012 9:50 am

gemini06720 wrote:Indeed, I can confirm that the Cumulus processed templates are in the DOS/Window encoding format (a variation of ANSI) - so far, I have not been able to directly use the HTM templates within a UTF-8 script/template without prior conversion to UTF-8 format (using the PHP 'iconv' function to performs character set conversion on a string or a file).
Thank you !
I'll use the cumuluswebtags.php but, another question : This file is displaying english tags... like "at 13:33 on 24 septembre 2012". Past weeks, i find a topic wich explains how to make these words in french.. but, i can't find it !
How to make a good translation for "at" and "on" , in french : "à" , "le"
Image
http://www.7331.be/meteo website based on the phpBB3 forum and template. WMR200 + UVN 800 - Cumulus 1.9.4 1062 / Windows XP Service Pack 3 build 2600 FR

sfws
Posts: 462
Joined: Fri 27 Jul 2012 11:29 am
Weather Station: Final post in top ten topic
Operating System: Tempermental Win. 10 PC
Location: Moving

Re: Bad characters with accents in months

Post by sfws » Sun 04 Nov 2012 10:22 am


OliII
Posts: 54
Joined: Mon 19 Mar 2012 11:47 am
Weather Station: WMR 200 by Oregon Scientific
Operating System: WinXP SP3
Location: Belgium

Re: Bad characters with accents in months

Post by OliII » Sun 04 Nov 2012 10:55 am

Yes ! Thx !
Everything is OK now !
Just a note,
The cumulusbebtags.php file is saved into UTF-8 format file into my web folder.. but once it has been processed by Cumulus, the file into my server is.. in DOS/windows format.
I need to use utf8_decode() function to get accents.
Thx everyone !Have a nice day
Image
http://www.7331.be/meteo website based on the phpBB3 forum and template. WMR200 + UVN 800 - Cumulus 1.9.4 1062 / Windows XP Service Pack 3 build 2600 FR

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Bad characters with accents in months

Post by steve » Sun 04 Nov 2012 11:38 am

Just to add that Cumulus can't create files in UTF-8 format because the system routines I use to create the files don't allow it. It doesn't matter what format your template is in, the processed file is not related to the template file, it's a new file created from the contents of the template and the processed web tags. Cumulus doesn't 'edit' the template to produce the output file.

As I understand it we are all supposed to be moving towards UTF-8 for web pages, so this is something I will have to address at some point.
Steve

User avatar
JacquesD
Posts: 605
Joined: Tue 27 Jul 2010 3:51 am
Weather Station: National Geographic 265nc
Operating System: XP SP3
Location: St-Ours, Québec, Canada
Contact:

Re: Bad characters with accents in months

Post by JacquesD » Sun 04 Nov 2012 11:38 pm

Hi OliII,

If you need it, I've done the job on latest templates.
You could download newest 1.9.3 webtags file alone, on this link:
http://www.weatherbyyou.com/dl.php

It include an "International" version where all strings and dates are encoded
with utf8_encode. Also, It provide a way to "standardize" date format
where you change in one place on, at, to... with your own words (le, à, au??)

Finally, an other file is included for month by month Data/Time standards
All those files are for PHP websites.

Amicalement,
JacquesD
Image

OliII
Posts: 54
Joined: Mon 19 Mar 2012 11:47 am
Weather Station: WMR 200 by Oregon Scientific
Operating System: WinXP SP3
Location: Belgium

Re: Bad characters with accents in months

Post by OliII » Tue 06 Nov 2012 5:29 pm

Thx, that's help mde a lot !
Merci ;) !
Image
http://www.7331.be/meteo website based on the phpBB3 forum and template. WMR200 + UVN 800 - Cumulus 1.9.4 1062 / Windows XP Service Pack 3 build 2600 FR

Post Reply