Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

Cumulus/Twitter

Discussion and questions about Cumulus weather station software version 1. This section and its subforums are the main place to get help with Cumulus. Anything which is not specific to the type of weather station goes in here; for anything specific to a type of weather station, please use the appropriate subforum. Use the 'website development' section for any questions relating to creating or running a web site for Cumulus data. Discussion of the stations themselves in these sections is fine.
Post Reply
User avatar
robynfali
Posts: 1075
Joined: Sat Jul 31, 2010 10:34 pm
Weather Station: Fine Offset
Operating System: Windows XP
Location: Anglesey, North Wales, UK
Contact:

Cumulus/Twitter

Post by robynfali » Wed Dec 08, 2010 6:18 pm

I have created a seperate twitter account for my station, changed the details in Cumulus, but for some reason, it is not being sent/received on twitter?

http://twitter.com/dyffynweather/
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Cumulus/Twitter

Post by steve » Wed Dec 08, 2010 6:23 pm

To change Twitter accounts, you'll need to stop Cumulus and edit the cumulus.ini file to remove the Oauthtoken and OauthTokenSecret lines, or set them to unknown:

OauthToken=unknown
OauthTokenSecret=unknown

This is unfortunately a consequence of Twitter insisting on this overly-complicated authentication process, and I haven't bothered catering for changing accounts in a 'nice' way, as I assumed it wouldn't happen very often. Removing those lines makes Cumulus go through the process of requesting the tokens for the new account.
Steve

User avatar
robynfali
Posts: 1075
Joined: Sat Jul 31, 2010 10:34 pm
Weather Station: Fine Offset
Operating System: Windows XP
Location: Anglesey, North Wales, UK
Contact:

Re: Cumulus/Twitter

Post by robynfali » Wed Dec 08, 2010 6:24 pm

forget it, stupid spelling mistake!!!

User avatar
robynfali
Posts: 1075
Joined: Sat Jul 31, 2010 10:34 pm
Weather Station: Fine Offset
Operating System: Windows XP
Location: Anglesey, North Wales, UK
Contact:

Re: Cumulus/Twitter

Post by robynfali » Wed Dec 08, 2010 6:28 pm

yeah, done that now mate, cheers, and thankfully twitter allows you to change the username too!

KBWeather
Posts: 2
Joined: Sun Nov 18, 2012 11:41 am
Weather Station: KBWeather
Operating System: XP
Location: Crab Orchard, Ky. USA

Re: Cumulus/Twitter

Post by KBWeather » Tue Nov 20, 2012 12:37 pm

I have tryed evreything... wont upload. I even started a new copy of cumulus... is there a fix or not?

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Cumulus/Twitter

Post by steve » Tue Nov 20, 2012 1:37 pm

KBWeather wrote:I have tryed evreything... wont upload. I even started a new copy of cumulus... is there a fix or not?
Perhaps you could respond to my reply to the other post you made on the same subject?

http://sandaysoft.com/forum/viewtopic.php?f=4&t=8664
Steve

starchild
Posts: 13
Joined: Sun Sep 07, 2008 8:01 am
Weather Station: Watson W8681
Location: Seer Green, Bucks

Re: Cumulus/Twitter

Post by starchild » Sun Nov 25, 2012 10:28 pm

Hi there,

I'm running Cumulus V1.9.2 build 1032 and have begun to have problems with the twitter capability for a month or so - although it was all working fine for quite a few months before that.

Basically, I am unable to post any tweets. I've tried deleting the two authorisation tokens in my cumulus.ini file (whilst Cumulus was not running) and can see that they are recreated at the next interval so I guess authorisation is working OK. I've also created a twitter.txt file in the root of the Cumulus program directory containing just "Wind <#wspeed>" in case the default tags produce too many characters.

I've turned on debugging but the log doesn't contain any references to twitter.

The only change that I can think of from around the time that this stopped working was that I had to rebuild the PC that I use to copy Cumulus backups to - but it doesn't handle any live Cumulus data so can't see how that would be connected.

Just in case it's relevant the Cumulus application is updating my webspace with html files with no problems. Also, my webtags file is called cumuluswebtags.txttmp and is found in the \cumulus\data directory.

Any help would be much appreciated.

User avatar
PaulMy
Posts: 1708
Joined: Sun Sep 28, 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: Cumulus/Twitter

Post by PaulMy » Mon Nov 26, 2012 1:35 am

Since you're still running v. 1.9.2 have you looked at the above highlighted note "Twitter stopped updating? See This post"? http://sandaysoft.com/forum/viewtopic.php?f=2&t=8428

Paul

starchild
Posts: 13
Joined: Sun Sep 07, 2008 8:01 am
Weather Station: Watson W8681
Location: Seer Green, Bucks

Re: Cumulus/Twitter

Post by starchild » Mon Nov 26, 2012 7:32 am

Many thanks for the redirection Paul - I completely missed that! :oops:

Post Reply