Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.0 build 3050 - 1 May 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

File: awekas_wl.htmtmp

Discussion and questions about Cumulus weather station software version 1. This section and its subforums are the main place to get help with Cumulus. Anything which is not specific to the type of weather station goes in here; for anything specific to a type of weather station, please use the appropriate subforum. Use the 'website development' section for any questions relating to creating or running a web site for Cumulus data. Discussion of the stations themselves in these sections is fine.
Post Reply
bigharps
Posts: 37
Joined: Sun 10 Jan 2010 12:33 pm
Weather Station: Davis Vantage Pro2
Operating System: Windows 10 Pro 64bit
Location: Prestons NSW Australia
Contact:

File: awekas_wl.htmtmp

Post by bigharps » Tue 14 May 2019 5:11 am

Advice please. I got a message from AWEKAS that my station has not uploaded data for several months.
I am running Cumulus V 1.9.4, build 1099.
I have checked a few things, but I am wondering about the awekas.htmtmp file which is in my Cumulus\web folder.
The file is empty.
I saw in an old answer from Steve that: "The 'remote filename' has to be a path and file name on your ftp server which tells Cumulus where to put the file and what to call it. "
I am wondering what other data should the file contain?
Thanks.

User avatar
PaulMy
Posts: 1854
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: File: awekas_wl.htmtmp

Post by PaulMy » Tue 14 May 2019 1:17 pm

I have checked a few things, but I am wondering about the awekas.htmtmp file which is in my Cumulus\web folder.
The file is empty.
That file is a temporary file saved by Cumulus while processing and is updated at each update. It should have the current data that will be uploaded. Is yours with the current date stamp?
Do you have the \Cumulus\web\awekas_wl.htm with webtags set in your Internet settings (cumulus.ini) to process and upload?

My AWEKAS template file in \Cumulus\web\awekas_wl.htm has the webtags for Cumulus to process and upload to my public_html/weather/ folder:
AWEKAS_Template_start<br>
<#temp><br>
<#hum><br>
<#press><br>
<#rfall><br>
<#wspeed><br>
<#bearing><br>
<#hour>:<#minute><br>
<#day>/<#month>/<#year><br>
<#presstrend><br>
-<br>
-<br>
-<br>
-<br>
-<br>
-<br>
-<br>
<#wgust><br>
<br>
<br>
<#rrate><br>
---<br>
°<#tempunit><br>
% <br>
<#windunit><br>
<#pressunit><br>
<#rainunit><br>
W/m²<br>
<#rainunit>/hr<br>
index<br>
Template_V1.5<br>


The processed file is then uploaded as www.komokaweather.com/weather/awekas_wl.htm:
AWEKAS_Template_start
7.5
70
1014.53
0.2
4.3
360
09:05
14/05/2019
Rising
-
-
-
-
-
-
-
12.9


0.0
---
°°C
%
km/h
hPa
mm
W/m²
mm/hr
index
Template_V1.5
Enjoy,
Paul

bigharps
Posts: 37
Joined: Sun 10 Jan 2010 12:33 pm
Weather Station: Davis Vantage Pro2
Operating System: Windows 10 Pro 64bit
Location: Prestons NSW Australia
Contact:

Re: File: awekas_wl.htmtmp

Post by bigharps » Fri 17 May 2019 6:16 am

Thanks for the help! You got me to search around again.
Things have been a little crazy around here the past few days, so I only got back to this about an hour ago.
I searched in ever decreasing circles for a while, slowly going bonkers - everything looked good.
Then, for some reason I started thinking, "what happened on January 19 this year?", (that was the date of the latest data displayed by AWEKAS).
Eventually, I remembered that I changed hosts in January. But because updates to my website (www.kookaburranet.com/Weather) were still being correctly uploaded, I disregarded that as a factor.
Had to be a simple answer, and it was. The old host had "public_html" as initial directory of the ftp address, the new one didn't. I had changed the address on the "Sites/Options" tab, but forgot the "Files" tab where the AWEKAS files were nominated!
I deleted "public_html/" from the front of the remote filename - no more problems - AWEKAS is now updating correctly.
I can't believe how often seem to manage to overlook one small detail somewhere, and keep missing it when I go checking!
:oops: :oops:

User avatar
PaulMy
Posts: 1854
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: File: awekas_wl.htmtmp

Post by PaulMy » Fri 17 May 2019 1:10 pm

Great that you got it working again. Yes I know about overlooking things, one can much easier spot another's mistake and completely overlook their own.

Enjoy,
Paul

Post Reply