Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.4.0 (build 3064) - 19 February 2020.
    Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

    See the Wiki for downloading either version.

    "create missing" in dayfile.txt is not working

    Discussion and questions about Cumulus weather station software version 1. This section and its subforums are the main place to get help with Cumulus. Anything which is not specific to the type of weather station goes in here; for anything specific to a type of weather station, please use the appropriate subforum. Use the 'website development' section for any questions relating to creating or running a web site for Cumulus data. Discussion of the stations themselves in these sections is fine.
    Post Reply
    User avatar
    vpokroglo
    Posts: 70
    Joined: Thu 24 Feb 2011 7:45 pm
    Weather Station: WS-2350
    Operating System: Raspberry Pi 2
    Location: Slovenija
    Contact:

    "create missing" in dayfile.txt is not working

    Post by vpokroglo » Sat 27 Oct 2018 11:33 am

    ...as subject says. I am on Cumulus MX, but i have used Cumulus 1.9 for creating missing entries in dayfile.txt sometimes. Now i have updated from win 7 to win 10 and the coolest feature doesn't work anymore. Any thoughts?
    Image

    freddie
    Posts: 531
    Joined: Wed 08 Jun 2011 11:19 am
    Weather Station: Davis Vantage Pro 2
    Operating System: GNU/Linux (Ubuntu 18.04)
    Location: Dorrington, Shropshire
    Contact:

    Re: "create missing" in dayfile.txt is not working

    Post by freddie » Sat 27 Oct 2018 11:54 am

    This might be something to do with it:
    http://sandaysoft.com/forum/viewtopic.p ... at#p110617
    Freddie
    Image

    User avatar
    vpokroglo
    Posts: 70
    Joined: Thu 24 Feb 2011 7:45 pm
    Weather Station: WS-2350
    Operating System: Raspberry Pi 2
    Location: Slovenija
    Contact:

    Re: "create missing" in dayfile.txt is not working

    Post by vpokroglo » Sat 27 Oct 2018 2:34 pm

    Thanks for your answer, but this is not a problem
    List separator is OK, and also we use 24 hour format in our country.

    When i click on "create missing", I get window "Processing log files...", which disappears after apx. 30 sec. and nothing happens.


    In bottom I can only read "Number of entries inserted: 0"
    -No error
    -dayfileeditlog.txt file is empty - 0 bytes
    Image

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: "create missing" in dayfile.txt is not working

    Post by steve » Sat 27 Oct 2018 2:53 pm

    Any errors in the diags file at that time? Or near the beginning, when Cumulus starts up?
    Steve

    User avatar
    vpokroglo
    Posts: 70
    Joined: Thu 24 Feb 2011 7:45 pm
    Weather Station: WS-2350
    Operating System: Raspberry Pi 2
    Location: Slovenija
    Contact:

    Re: "create missing" in dayfile.txt is not working

    Post by vpokroglo » Sat 27 Oct 2018 3:16 pm

    steve wrote:Any errors in the diags file at that time? Or near the beginning, when Cumulus starts up?
    no
    Image

    sfws
    Posts: 477
    Joined: Fri 27 Jul 2012 11:29 am
    Weather Station: Modified Fine Offset
    Operating System: Win. 10 PC
    Location: The Marches, UK

    Re: "create missing" in dayfile.txt is not working

    Post by sfws » Sat 27 Oct 2018 6:20 pm

    vpokroglo wrote:Any thoughts?
    Presumably it is not the simple answer that the day (or days) missing in your dayfile is (are) also missing in the detailed log file?
    Even Cumulus cannot work the miracle of adding a day when there is nothing in log files.

    (Also I presume when you moved from Cumulus 1 to Cumulus MX, you copied across past detailed log files, not just latest month).

    User avatar
    vpokroglo
    Posts: 70
    Joined: Thu 24 Feb 2011 7:45 pm
    Weather Station: WS-2350
    Operating System: Raspberry Pi 2
    Location: Slovenija
    Contact:

    Re: "create missing" in dayfile.txt is not working

    Post by vpokroglo » Sun 28 Oct 2018 8:10 am

    sfws wrote:
    vpokroglo wrote:Any thoughts?
    Presumably it is not the simple answer that the day (or days) missing in your dayfile is (are) also missing in the detailed log file?
    Even Cumulus cannot work the miracle of adding a day when there is nothing in log files.

    (Also I presume when you moved from Cumulus 1 to Cumulus MX, you copied across past detailed log files, not just latest month).
    are you kidding me?
    Image

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: "create missing" in dayfile.txt is not working

    Post by steve » Sun 28 Oct 2018 10:51 am

    I suspect that the problem is as first suggested in this thread - your date format is now different (or at least one of the formats is different). Hence Cumulus cannot find the monthly log files as they do not have the names that it is now expecting.
    Steve

    User avatar
    vpokroglo
    Posts: 70
    Joined: Thu 24 Feb 2011 7:45 pm
    Weather Station: WS-2350
    Operating System: Raspberry Pi 2
    Location: Slovenija
    Contact:

    Re: "create missing" in dayfile.txt is not working

    Post by vpokroglo » Mon 29 Oct 2018 6:15 pm

    I have lost too many hours with that problem, I have also tried different date/time formats, but no effect. Nevermind, I will go back to win7 today, because there are other problems with win10 too.
    Thanks for all your help!
    Image

    Post Reply