Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3044 7 December 2018. See the Wiki for download

Instromet Datalogger Question

Discussion and questions about Cumulus weather station software version 1. This section and its subforums are the main place to get help with Cumulus. Anything which is not specific to the type of weather station goes in here; for anything specific to a type of weather station, please use the appropriate subforum. Use the 'website development' section for any questions relating to creating or running a web site for Cumulus data. Discussion of the stations themselves in these sections is fine.
Post Reply
Chapel
Posts: 24
Joined: Mon 30 Jul 2018 10:23 am
Weather Station: Instromet
Operating System: Win10
Location: Binbrook UK
Contact:

Instromet Datalogger Question

Post by Chapel » Mon 30 Jul 2018 10:31 am

Hi,

We installed an Instromet datalogger/cables/etc over the weekend and yesterday afternoon downloaded the Cumulus software as it had been recommended. We cannot get the software to receive any data, cables/datalogger/com port/ have all been checked, software reinstalled.

What are we missing?

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Instromet Datalogger Question

Post by steve » Mon 30 Jul 2018 11:35 am

If you zip up the diags folder and attach it to a reply in this thread, I'll take a look.
Steve

Chapel
Posts: 24
Joined: Mon 30 Jul 2018 10:23 am
Weather Station: Instromet
Operating System: Win10
Location: Binbrook UK
Contact:

Re: Instromet Datalogger Question

Post by Chapel » Mon 30 Jul 2018 12:48 pm

Please find files attached. We are convinced it is a comms error however we have tried two machines and two different serial to usb adapters with no luck.
Diags.zip
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Instromet Datalogger Question

Post by steve » Mon 30 Jul 2018 12:55 pm

Yes, looks like a comms error, it seems to be rejecting everything with 'invalid checksum', which suggests some kind of corruption in the incoming data packets (but I think it may signal the same error if it wasn't getting anything at all). If you add "Logging=1" to the [Station] section in Cumulus.ini before starting Cumulus, it may log something useful to the debug.log file.
Steve

Chapel
Posts: 24
Joined: Mon 30 Jul 2018 10:23 am
Weather Station: Instromet
Operating System: Win10
Location: Binbrook UK
Contact:

Re: Instromet Datalogger Question

Post by Chapel » Mon 30 Jul 2018 1:10 pm

I ran it for a very short period, shout if you need a few more minutes of data.
debug.log
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Instromet Datalogger Question

Post by steve » Mon 30 Jul 2018 1:28 pm

Thanks, that doesn't really narrow it down (because of the way the logging works), but more wouldn't help. So all I can say is that it's apparently some kind of comms issue.
Steve

Chapel
Posts: 24
Joined: Mon 30 Jul 2018 10:23 am
Weather Station: Instromet
Operating System: Win10
Location: Binbrook UK
Contact:

Re: Instromet Datalogger Question

Post by Chapel » Sun 05 Aug 2018 7:12 pm

As an update we tried three Windows 10 machines, two serial to USB adapters before resorting to Linux, something neither of us have worked with for years and all to no avail, then this morning my wife suggested loading CumulusMX onto the original Win10 laptop and it worked instantly which is great news for us :)

I, of course have a couple more questions that I have searched the forum for with no identical hits so I will start a new post.

Thank you for your assistance.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Instromet Datalogger Question

Post by steve » Sun 05 Aug 2018 7:21 pm

Hope you find MX OK for your needs. You have reminded me that there are two current versions of 1.9.4 for Instromet users depending on which version of the logger you have, perhaps you had the wrong one. Or I may be misremembering and what I just said was rubbish.
Steve

sfws
Posts: 462
Joined: Fri 27 Jul 2012 11:29 am
Weather Station: Customised mix of Fine Offset
Operating System: Tempermental Win. 10 PC
Location: UK

Re: Instromet Datalogger Question

Post by sfws » Sun 05 Aug 2018 8:20 pm

steve wrote:You have reminded me that there are two current versions of 1.9.4 for Instromet users depending on which version of the logger you have, perhaps you had the wrong one.
Steve, your memory is right, see Wiki http://wiki.sandaysoft.com/a/Cumulus_Versions (I have not checked if download links in Wiki article still work).
The final production version of Cumulus 1 (running in Windows for all supported weather stations) can be downloaded at v1.9.4 (build 1099) - 28 Nov 2014.

If you are an Instromet user, and your logger operates at 115200 baud, you should use build 1100 at special 1.9.4 build 1100.

If you are an Instromet user, and your logger operates at 19200 baud, you should use build 1101 at special 1.9.4 build 1101.

Chapel
Posts: 24
Joined: Mon 30 Jul 2018 10:23 am
Weather Station: Instromet
Operating System: Win10
Location: Binbrook UK
Contact:

Re: Instromet Datalogger Question

Post by Chapel » Mon 06 Aug 2018 6:54 am

Yes, we tried build 1100 as our datalogger runs at 115,200 Baud rate but to no avail. It was the move to CumulusMX that resolved everything and I have no idea why, I am not convinced it was a hardware issue as we tried multiple systems including Linux. Regardless of this we are running now which is the important part and I am inclined to vaguely blame the Win platform for this :)

Post Reply