Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - 28 November 2014
Latest Cumulus MX release v3.0.0 build 3046 - 02 January 2019. See the Wiki for download

NOAA Report Issue

Discussion and questions about Cumulus weather station software version 1. This section and its subforums are the main place to get help with Cumulus. Anything which is not specific to the type of weather station goes in here; for anything specific to a type of weather station, please use the appropriate subforum. Use the 'website development' section for any questions relating to creating or running a web site for Cumulus data. Discussion of the stations themselves in these sections is fine.
Post Reply
SteveFitz1
Posts: 10
Joined: Thu 06 Oct 2011 3:20 am
Weather Station: Vantage Pro 2
Operating System: Windows 7
Location: Tyler, TX

NOAA Report Issue

Post by SteveFitz1 » Fri 08 Dec 2017 3:09 pm

I had a system crash earlier this week. Since bringing Cumulus back up, my daily NOAAMO1217.txt report shows data only for the days since the crash and not back to Dec 1. Also my NOAAYR2017.txt report displays data for only December (which is just a couple of days due to the missing days). From what I can tell, all my Cumulus data is still intact, it's just that the NOAA reports aren't pulling it all in.

Any suggestions as to what I can do to get these 2 reports to update correctly each day.

Thanks,

Steve

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: NOAA Report Issue

Post by steve » Fri 08 Dec 2017 3:13 pm

Could be that the crash has corrupted one or more data files. There will be error messages in the diags file if so (and the error light would normally flash).
Steve

SteveFitz1
Posts: 10
Joined: Thu 06 Oct 2011 3:20 am
Weather Station: Vantage Pro 2
Operating System: Windows 7
Location: Tyler, TX

Re: NOAA Report Issue

Post by SteveFitz1 » Fri 08 Dec 2017 6:39 pm

Steve,

Thanks for the pointer. I did find a corrupted line in Dec17log.txt. I removed it, saved the file, then restarted Cumulus. The flashing Error light quit flashing.

I then tried to manually create a Monthly and Yearly NOAA Report, but they did not seem to update. I clicked on 'Update Display' in each dialog, but they looked the same as before. Do I have to wait until the midnight rollover for them to change or am I missing a step to update them now. I reviewed the diag files again after bringing Cumulus back up and it shows no errors.

Thanks.

Steve

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: NOAA Report Issue

Post by steve » Fri 08 Dec 2017 7:46 pm

With any errors corrected, it should be possible to recreate the report immediately. It sounds like there is still a corruption in either the December log file or dayfile.txt, but it’s odd that no error messages are logged to the diags file.
Steve

SteveFitz1
Posts: 10
Joined: Thu 06 Oct 2011 3:20 am
Weather Station: Vantage Pro 2
Operating System: Windows 7
Location: Tyler, TX

Re: NOAA Report Issue

Post by SteveFitz1 » Fri 08 Dec 2017 8:23 pm

Steve,

There are only 2 lines in my current dayfile.txt file - one for today and one for yesterday.

Can I go back to my last backup with hundreds of lines and add the December days to it?

Steve

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: NOAA Report Issue

Post by steve » Fri 08 Dec 2017 9:18 pm

Yes, that should work.
Steve

SteveFitz1
Posts: 10
Joined: Thu 06 Oct 2011 3:20 am
Weather Station: Vantage Pro 2
Operating System: Windows 7
Location: Tyler, TX

Re: NOAA Report Issue

Post by SteveFitz1 » Fri 08 Dec 2017 9:31 pm

Got it fixed. Thanks for your help.

Steve

Mark14
Posts: 54
Joined: Thu 23 Aug 2012 8:53 pm
Weather Station: WH 2080
Operating System: Windows 7
Location: Konin, Poland

Re: NOAA Report Issue

Post by Mark14 » Mon 09 Jul 2018 9:00 pm

I have another issue related to NOAA reports. After changing server for my website, NOAA report files are not uploaded and I don't have updated a daily summary: http://serwer1823145.home.pl/wxtempdetail.php?lang=en#
Where should I correct the path/directory to restore the daily adding of measurements?

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: NOAA Report Issue

Post by steve » Tue 10 Jul 2018 5:47 am

On the NOAA Setup screen, from the Configuration menu.
Steve

Post Reply