Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.2 build 3052 - 13 September 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

List index out of bounds error after Win10 upgrade

Discussion and questions about Cumulus weather station software version 1. This section and its subforums are the main place to get help with Cumulus. Anything which is not specific to the type of weather station goes in here; for anything specific to a type of weather station, please use the appropriate subforum. Use the 'website development' section for any questions relating to creating or running a web site for Cumulus data. Discussion of the stations themselves in these sections is fine.
Post Reply
sbowness
Posts: 3
Joined: Sat 28 Dec 2013 9:39 pm
Weather Station: Fine Offset WS1081
Operating System: Windows 10
Location: Auckland, New Zealand

List index out of bounds error after Win10 upgrade

Post by sbowness » Sat 08 Aug 2015 9:45 am

I'm hoping that someone can help as this is driving me bonkers. I've just upgraded my PC to Win10. Before the upgrade, there were no problems. After the upgrade, I'm getting a long list of index errors:

8/08/2015 21:23:03 : Error plotting charts at line 589 of dayfile.txt: List index out of bounds (6)
8/08/2015 21:23:03 : Please correct the error by editing dayfile.txt
8/08/2015 21:23:03 : Error on line 1 of C:\Cumulus\data\Aug15log.txt: List index out of bounds (1)
8/08/2015 21:23:04 : Error on line 1 of C:\Cumulus\data\Aug15log.txt: List index out of bounds (1)
8/08/2015 21:23:04 : Error reading C:\Cumulus\data\Aug15log.txt at line 1: List index out of bounds (1)
8/08/2015 21:23:04 : Please stop Cumulus and edit the file to correct the error
8/08/2015 21:23:04 : Error on line 1 of C:\Cumulus\data\Aug15log.txt: List index out of bounds (1)
8/08/2015 21:23:04 : Error on line 1 of C:\Cumulus\data\Aug15log.txt: List index out of bounds (1)
8/08/2015 21:23:05 : Error on line 1 of C:\Cumulus\data\Aug15log.txt: List index out of bounds (1)

The "error plotting charts" actually starts at line 466. I've restored the files from the backup I took before the upgrade but to no avail. I've taken a look at the two files with Notepad++ but that is not showing anything obvious. I've also rolled back using the Cumulus generated back ups to 28 July and that has now created an error in the Jul15 file as well. Can someone help, please? Attached are the three files. One possible symptom is that I'm getting rainfall errors. The annual rainfall is well out. There is a new highest daily rain record of 16641.0 mm at 23:31 on 1 August 2015 and Highest Monthly Rain in August 2015 as well.
When Cumulus reacquired the data from the logger it logged this error: "8/08/2015 21:30:06 : Ignoring high hourly rain: 16640.70 mm"

Many thanks in advance
Stephen
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: List index out of bounds error after Win10 upgrade

Post by steve » Sat 08 Aug 2015 9:50 am

Your Windows list separator has changed from a comma to a semicolon - you can see this in the August log file you've attached. See the other current thread with apparently the same problem.

A general point: if rolling back to a previous month, you need to delete the log file for the current month, or new entries will get appended to the existing entries. On this occasion, it was actually useful, to confirm that's what the problem was.
Steve

sbowness
Posts: 3
Joined: Sat 28 Dec 2013 9:39 pm
Weather Station: Fine Offset WS1081
Operating System: Windows 10
Location: Auckland, New Zealand

Re: List index out of bounds error after Win10 upgrade

Post by sbowness » Sat 08 Aug 2015 10:18 am

As easy as that. Many thanks indeed, Steve. It's interesting that the regional settings changed between Win8.1 and Win10. I wonder whether they apply a temporary region during the upgrade.

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: List index out of bounds error after Win10 upgrade

Post by steve » Sat 08 Aug 2015 10:26 am

There does seem to be an issue that particularly affects New Zealand.
Steve

Quentin
Posts: 1
Joined: Wed 19 Aug 2015 7:59 am
Weather Station: Fine Offset WS1081
Operating System: Windows 10
Location: Kapiti Coast, New Zealand

Re: List index out of bounds error after Win10 upgrade

Post by Quentin » Wed 19 Aug 2015 8:13 am

I found changing the separator in the regional settings from ; to , and doing a search and replace in the August log file worked.

Click on the clock in the task bar =>Date and time settings => Region and language =>Additional date, time, and regional settings => change date, time, or number formats =>additional settings =>List separator. Change the separator from ; to , and apply it.
2015-08-19_20-07-24.jpg
Then open the august log file and simply do a search and replace.
2015-08-19_20-10-23.jpg
I restarted Cumulus, and it all worked again
You do not have the required permissions to view the files attached to this post.

sbowness
Posts: 3
Joined: Sat 28 Dec 2013 9:39 pm
Weather Station: Fine Offset WS1081
Operating System: Windows 10
Location: Auckland, New Zealand

Re: List index out of bounds error after Win10 upgrade

Post by sbowness » Sat 22 Aug 2015 12:51 am

Thanks Quentin.

In the end I had to do a rollback as some of the broken data and my other attempts to fix it had stuffed up my records and it was easier to make Cumulus do all of the hard work.

User avatar
Super-T
Posts: 816
Joined: Tue 09 Sep 2008 3:37 am
Weather Station: wh-1081
Operating System: Weather Laptop - Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: List index out of bounds error after Win10 upgrade

Post by Super-T » Sat 22 Aug 2015 10:40 am

Can someone post a copy of the NZ settings for dates and times etc. as I have a problem with Cumulus crashing after W10 upgrade.

See here. http://sandaysoft.com/forum/viewtopic.php?f=6&t=14147

Raybnz
Posts: 1
Joined: Sat 05 Jul 2014 4:05 am
Weather Station: Cumulus WS1093
Operating System: windows 7
Location: Hamilton

Re: List index out of bounds error after Win10 upgrade

Post by Raybnz » Sun 06 Sep 2015 5:10 am

steve wrote:There does seem to be an issue that particularly affects New Zealand.
Yeap and its driving me mad. I cannot get this windows 10 to work with Cumulus. Perhaps if I download it again.

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: List index out of bounds error after Win10 upgrade

Post by steve » Sun 06 Sep 2015 9:07 am

It looks like the actual date and time format settings haven't changed in Windows 10, but they have changed the am/pm indicator. Here are the settings for NZ for Windows 10:
Windows10.png
and here are the settings for Windows 7:
Windows7.png
While the format strings are the same, the am/pm symbols are not. So, as mentioned by Derek in this thread - http://sandaysoft.com/forum/viewtopic.php?f=4&t=14104 - you have to go into 'additional settings' and change the am/pm symbols on the 'time' tab back to a.m. and p.m. (you can just type in the boxes):
additional.png
If you then click OK, the settings are now as they were in Windows 7:
Win10corrected.png
Note that you should also make sure that your decimal separator is still '.' (period) and your list separator is ',' (comma).
You do not have the required permissions to view the files attached to this post.
Steve

Post Reply