Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

Icumulus wiki link broken

Discussion and questions about Cumulus weather station software version 1. This section and its subforums are the main place to get help with Cumulus. Anything which is not specific to the type of weather station goes in here; for anything specific to a type of weather station, please use the appropriate subforum. Use the 'website development' section for any questions relating to creating or running a web site for Cumulus data. Discussion of the stations themselves in these sections is fine.
Post Reply
TRR
Posts: 9
Joined: Mon Aug 26, 2013 1:25 am
Weather Station: WM-918
Operating System: Windows 8
Location: Alaska

Icumulus wiki link broken

Post by TRR » Wed Sep 17, 2014 6:44 pm

Hello everyone I was working on adding the Icumulus to my website but the link to download the zip seems to be broken. I have Safari, Chrome, and firefox. I wanted to try the top 3 before posting here. Can someone share the file with me?

User avatar
steve
Cumulus Author
Posts: 26713
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Icumulus wiki link broken

Post by steve » Wed Sep 17, 2014 6:50 pm

I have a copy here - I don't know if it was the latest version.
You do not have the required permissions to view the files attached to this post.
Steve

TRR
Posts: 9
Joined: Mon Aug 26, 2013 1:25 am
Weather Station: WM-918
Operating System: Windows 8
Location: Alaska

Re: Icumulus wiki link broken

Post by TRR » Wed Sep 17, 2014 6:52 pm

Thank you so much Steve, that was a really fast reply.

TRR
Posts: 9
Joined: Mon Aug 26, 2013 1:25 am
Weather Station: WM-918
Operating System: Windows 8
Location: Alaska

Re: Icumulus wiki link broken

Post by TRR » Wed Sep 17, 2014 7:09 pm

That worked like a charm.

If you want to check out the weather in Wasilla, AK; www.robothome.us

User avatar
scramblers
Posts: 48
Joined: Wed Jan 26, 2011 9:53 pm
Weather Station: Davis VP2+ with daytime FARS
Operating System: Windows 7
Location: Tamworth, Staffordshire
Contact:

Re: Icumulus wiki link broken

Post by scramblers » Sun Mar 29, 2015 9:24 pm

I've adapted David A Jamieson's original file for use with my Davis Weather station in Tamworth but it should work with any station with UV and Solar sensors.

I have also extended the file to include the Month and the Year.
You do not have the required permissions to view the files attached to this post.
John

Image

User avatar
scramblers
Posts: 48
Joined: Wed Jan 26, 2011 9:53 pm
Weather Station: Davis VP2+ with daytime FARS
Operating System: Windows 7
Location: Tamworth, Staffordshire
Contact:

Re: Icumulus wiki link broken

Post by scramblers » Mon Mar 30, 2015 6:41 pm

I've adapted David A Jamieson's original file for use with my Davis Weather station in Tamworth but it should work with any station with UV and Solar sensors and my Maplins Weather station in Barcelona.

Both files now include:
  • Station rollover time ie. midnight, 9:00am or 10:00am
    Wind Run
    Current Month
    Current Year
The UVSolar file also includes:
  • Hours of Sunshine
    UV Index
    Solar Radiation
To view the standard file:
http://www.barcaweather.com/iphone/index.html

To view the UVSolar file:
http://www.tamworthweather.com/iphone/index.html
You do not have the required permissions to view the files attached to this post.
John

Image

Mopral26
Posts: 38
Joined: Thu Jul 11, 2013 7:16 am
Weather Station: Davis vantage pro II plus solar
Operating System: win 7
Location: france

Re: Icumulus wiki link broken

Post by Mopral26 » Mon Jul 20, 2015 8:02 am

hi guys, i've traduce in french i join it for french users with solar uv .

please change the station name because the name of station in index.html is mine ;)

i join it .
You do not have the required permissions to view the files attached to this post.

cvzyl
Posts: 15
Joined: Tue Dec 01, 2015 6:23 am
Weather Station: WMR200
Operating System: OSX & Linux
Location: Langebaan, South Africa

Re: Icumulus wiki link broken

Post by cvzyl » Sun Dec 20, 2015 7:35 pm

Hi guys

I'm trying to get this running with CumulusMX. I unzipped the files and uploaded them to the server. However, in CumulusMX I cannot find the option to upload the specific index.html file as specified in the instructions.

Is there a special trick to get it working?

Thanks
Cobus

User avatar
steve
Cumulus Author
Posts: 26713
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Icumulus wiki link broken

Post by steve » Sun Dec 20, 2015 7:41 pm

You configure extra files in MX in a similar way to Cumulus 1. See 'Extra web files' on the 'Settings' menu.
Steve

cvzyl
Posts: 15
Joined: Tue Dec 01, 2015 6:23 am
Weather Station: WMR200
Operating System: OSX & Linux
Location: Langebaan, South Africa

Re: Icumulus wiki link broken

Post by cvzyl » Sun Dec 20, 2015 8:52 pm

Hi Steve

Thanks for the quick reply. Sorry, I missed that page.

I now set it up but still get file with the tags <#temp>, etc. in stead of the actual values. What am I doing wrong?

Just to check, in the local filename box I have "c\cumulusmx\webfiles\mobile\index.html". I put the index.html file inside the webfiles folder just to group it with the other web files. I noticed that in the wiki instructions the colon is left out. Is that intentional?
For remote filename I have "/weather/mobile/index.html". The FTP account I set up in CumulusMX goes directly to the html folder, when I connect using an FTP application I see the /weather/ folder. That is why I omitted the "/var/www/..." part. Is that the correct assumption?

How does the local index.html file get updated?

Thanks
Cobus

water01
Posts: 1477
Joined: Sat Aug 13, 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 7 64bit HP SP1
Location: Somewhere in the USA
Contact:

Re: Icumulus wiki link broken

Post by water01 » Sun Dec 20, 2015 9:26 pm

I now set it up but still get file with the tags <#temp>, etc. in stead of the actual values. What am I doing wrong?
You have forgotten to tick the Process box which tells Cumulus to process the tags and substitute "live" values prior to upload.

cvzyl
Posts: 15
Joined: Tue Dec 01, 2015 6:23 am
Weather Station: WMR200
Operating System: OSX & Linux
Location: Langebaan, South Africa

Re: Icumulus wiki link broken

Post by cvzyl » Mon Dec 21, 2015 5:34 am

The "Process" box is ticked (and FTP).

How does Cumulus know where the index.html file is located on my local drive?

cvzyl
Posts: 15
Joined: Tue Dec 01, 2015 6:23 am
Weather Station: WMR200
Operating System: OSX & Linux
Location: Langebaan, South Africa

Re: Icumulus wiki link broken

Post by cvzyl » Mon Dec 21, 2015 6:49 am

cvzyl wrote:How does Cumulus know where the index.html file is located on my local drive?
Ok, I had a look at the folder on the local hard drive where the index.html file is located and it seems like Cumulus is creating a index.htmltemp file in this folder every minute but the index.html file is not updated. I think that is why the file that is uploaded is not populated with the correct information. Question is now, why does it only create a temp file?

Thanks for the assistance.
Cobus

cvzyl
Posts: 15
Joined: Tue Dec 01, 2015 6:23 am
Weather Station: WMR200
Operating System: OSX & Linux
Location: Langebaan, South Africa

Re: Icumulus wiki link broken

Post by cvzyl » Mon Dec 21, 2015 6:51 am

Ok, got it working. Seems like the local file address should include the colon. Changed to "C:\CumulusMX\webfiles\mobile\index.html" and now it works.

Cobus

User avatar
steve
Cumulus Author
Posts: 26713
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Icumulus wiki link broken

Post by steve » Mon Dec 21, 2015 8:19 am

Drive letter specifiers on Windows always include a colon. I've corrected the screen shot in the wiki.
Steve

Post Reply