Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.9.0 (build 3095) - 09 October 2020 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this Wiki link to Download the Software (Cumulus MX / Cumulus 1 and other related items).

Stopped reading data from the outside transmitter

Discussion and questions about Cumulus weather station software version 1. This section is the main place to get help with Cumulus 1 software developed by Steve Loft that ceased development in November 2014.
Post Reply
pspringett
Posts: 3
Joined: Mon 05 Oct 2020 6:31 pm
Weather Station: Aercus
Operating System: windows 10

Stopped reading data from the outside transmitter

Post by pspringett »

I was doing fantastically with my weather station ad the cumulus software on windows 7. And then I moved cumulus and all my data to a enw windows 10 machine, and now I'm hitting problems.

It seems like the indoors receive is not automatically reading data from the outside transmitter. I can trigger it to read it (by pressing the down button on my inside receiver, and it duly updates the outdoors temperature, but otherwise stays the outdoor temperature stays unchanged, ditto the rain gauge.

I've set the station configuration on cumulus to update every one minute, and have started to look at cumulus.ini to see if it really has set that, but its not clear.

DataLogInterval=0
and
EWInterval=0.00100000004749745

But then its unclear to me that the station configuration is actually written back to the station (probably it is?). Ive not worked out what units the DataLogInterval is so am not sure whether an interval of zero means don't update, or what really. And leaving it overnight doesn't show up as any memory being used.

I've changed batteries in both the outside transmitter and the inside receiver and reset everything, without getting any other joy.

Strangely if I leave the USB connected and cumulus running, it triggers an error or new record or seeing 255.6 millimetres of rain withina minute or so (i've not measured that), which makes me think the USB link is not being interpreted correctly, and that woudl show up when i moved to the windows 10 machine. But that is pure speculation.

I dont do any web stuff.

Any help or ideas would be much appreciated!

Thanks

Phill

pspringett
Posts: 3
Joined: Mon 05 Oct 2020 6:31 pm
Weather Station: Aercus
Operating System: windows 10

Re: Stopped reading data from the outside transmitter

Post by pspringett »

Just checked and DataLogInterval=0, does mean every minute.

My debug.log file has a lot of entries saying ***** Logging Disabled ****.

Don't know if that means just extra debug logging is disabled or my data logger is disabled.

Phill

water01
Posts: 1983
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 10 64bit
Location: Burnham-on-Sea
Contact:

Re: Stopped reading data from the outside transmitter

Post by water01 »

You should check your Cumulus.ini for "UseDataLogger".

If it is set to 0 it is disabled i.e. as far as Cumulus is concerned it doesn't exist, which seems to reflect you log messages.

To use the logger it has to be set to 1 i.e. enabled so Cumulus looks for new entries.
David
Image

User avatar
mcrossley
Posts: 7009
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Stopped reading data from the outside transmitter

Post by mcrossley »

As for the unreliability, it could be the USB port on the new machine is electrically "noisier" than the old one.

Does the console get reliable reception if you unplug it from the computer?
If so, you could try a new higher quality USB cable, or putting ferrite cores on the existing cable.

pspringett
Posts: 3
Joined: Mon 05 Oct 2020 6:31 pm
Weather Station: Aercus
Operating System: windows 10

Re: Stopped reading data from the outside transmitter

Post by pspringett »

Thanks for your thoughts. I reached the point where my display just wasn't updating. A factory reset seems to have solved that, so now the display changes sensibly.

But the actual graphs shown on cumulus are strange and wrong, and if its left plugged into the USB for a minute or two, cumulus reads a money
rain rate of 240+. Which may mean that the USB is problematic.

In general though it seems to update the Oct20Log.txt file correctly (or example). Well, that's actually not true. The aercus receiver has recorded rain today, but that hasn't been written to the file, and the temperatures are way too high (not even slightly close).

Post Reply